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Introduction

If CA Gen Client Manager is being used as a middleware for communication then it has to be up and running before any client/server applications can be successfully launched. It might be desirable to have Client Manager automatically start up when an application is launched. There is no standard way to achieve an automatic startup and shutdown of the Client Manager in CA Gen. However, an external action block can be used to offer this facility.

Create a new r7.6 model (give it a name of your liking) using the r7.6 Toolset and follow the instructions below in order to implement this solution:

1. Create an External Action Block
1. Create an Action Block
a. Open the model in the Toolset, go to Design->Action Diagram
b. Create an action block called "TAKE_CM_ACTION". 
This action block will serve as an EAB that initiates the Client Manager (in minimize mode) or stops the Client Manager depending on the “Start” or “Stop” action passed to it. 
Initiating the Client Manager in minimize mode means that when the Client Manager is launched it will be visible on the desktop as a minimized icon. 

2. Create Work Set Attributes
a. Go to Tool->Design->Work Set List
b. Create a Work Set that contains the following two attributes: 
Attribute Name = Status

Domain = Number

Length = 2

Attribute Name = Action

Domain = Text

Length = 5

3. Add Attributes to Views
a. Go to Edit->Add View->Add Work View.
b. Add the above two attributes to the action block’s import and export views 
4. Add Code
a. Go to Edit->Add Statement
b. Click External. 
This will add the word EXTERNAL to the action block which indicates that this is an External Action Block.

This is what the finished action diagram would look like:
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2. Create the Calling Procedure
1. Create a Window procedure
a. Go to Design->Navigation Diagram.

b. Click Edit->Add Window. 
c. Give the window a Title in the Title entry field.

d. Type a name for this window in Name field (give it any name). Click OK. 
This creates a client procedure that is used to call the EAB.
2. Add Views
a. Open the Action Diagram for this procedure.

b. Define the exact same import and export views as defined in the EAB earlier. 

3. Add Open Event
a. Go back to the Navigation Diagram and open the window for the client procedure. At this point the window is blank and has no objects on it. 
b. Click Detail->Events
c. Under Event Type drop down, select Open and click Add. This adds an Open event to the window. 
d. Click Close. 
e. Open the Action Diagram for the procedure. 
4. Add code under Open Event

a. Highlight the EVENT ACTION statement and click Edit->Add Statement->Set. 
b. Click ‘attribute view’
c. Click ‘action’
d. Click ‘To Expression’->Char String and type Start in the Character String pop up dialog. 
e. Click OK

f. Click Add. This adds the SET statement
g. With the SET statement selected, click Edit->Add Statement->Use. 
h. The take_cm_action action block name is now visible. Click Add. 
i. In the pop up dialog ‘TAKE_CM_ACTION Import View Matching’, select the IMPORT view. 
j. Possible Supplying Views are now visible. Select the EXPORT view and click Match. 
k. Click Close. 
l. Click Close again as nothing will be matched in the ‘Export View Matching’ dialog. 
This adds the USE statement that enables this procedure to call the EAB.
5. Add Push Button
a. Go back to the Navigation Diagram and with the window open, click Add->Push Button. 
b. In the Text entry field enter some text, such as Close Application

c. Click the Events push button

d. Make sure the ‘Event Type’ drop down is set to ‘Click’. 
e. Click Add. This adds the Click event to the push button. 
f. Click Close. 
g. Click OK on the ‘Push Button Properties’ dialog
h. Place the button on the window.  
i. Open the Action Diagram for the window
j. Look for the newly added EVENT ACTION that is tied to the push button. 
k. Highlight the EVENT ACTION statement
l. Click Edit->Add Statement->Set
m. Click ‘attribute view’
n. Click ‘action’ attribute. 
o. Click ‘To Expression’->Char String
p. Type Stop in the Character String pop up dialog

q. Click OK
r. Click Add. This should add the SET statement.
s. Add a Use statement in exactly the same manner as it was added earlier in Step 4g or copy the Use statement from the Open Event and paste it under the Set statement.
Following is an example of the calling procedure:
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Save the model.

3. Package, Generate and Build the Application
1. Packaging

a. Go to either Cooperative Code Packaging (Construction->Packaging, Diagram->Open->Cooperative Packaging) or Window Packaging (Diagram->Open->Window Packaging). 
b. Highlight the Business System
c. Click Edit->Add Load Module

d. Type an 8 character name for the load module and make sure that the ‘Type’ drop down is set to ‘Window Mangr’. 
e. Click ‘Add Psteps…’ 
f. Select the client procedure.

g. Click OK

h. Click OK again

i. Highlight the newly added Window Manager
j. Click Edit->Complete

k. Close the Packaging window
2. Generation and Build
a. Click on Construction->Generation
b. Click on Diagram->Open
c. Select Window or Cooperative Code (depending on which one the packaging was added to in Step 1 above)

d. Fully expand the Window Manager and highlight it
e. Select the ‘Code’ and ‘Inst’ columns as shown below
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f. Click Options->Generation Defaults and make sure they are set as shown in the screen shot below.
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g. Click Generate->Code Selected

Generation of the Window Manager takes place and the Build Tool launchs automatically to compile/build it. 

Note: At this point the application will fail to build successfully with the error message shown below (which is expected behavior).
P1.OBJ : error LNK2019: unresolved external symbol _TAKECMAC referenced in function _p1_launch_client_manager_win_01
C:\modelsr76\launchcm.ief\c\CMWIN.DLL : fatal error LNK1120: 1 unresolved externals

NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual Studio 8\VC\BIN\link.EXE"' : return code '0x460'

Stop.

In the steps to follow, we will compile the EAB and place it in an external library. Then we will build the application again which will resolve the above error.
4. Compile the EAB
1. Copy EAB to new location
a. Open Windows Explorer and navigate to the folder where you keep your models (including the one being used for this exercise)

b. Look for the extrn folder at this location
c. Create a sub folder under the extrn folder and give it a name of your liking
d. Navigate to the <model.ief>\c folder and copy the TAKECMAC.c file which contains the source code for TAKE_CM_ACTION action block
e. Paste this file into the newly created sub folder present under extrn folder
The example screen shot below shows a sub folder under the extrn folder called launchcm where EABs are maintained. 
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2. Edit the EAB with Custom Code
a. Open the TAKECMAC.c file with a text editor and search for the following line

/*    User-written code should be inserted here   */
The code shown in the next step is placed underneath this line.

b. Copy and paste the following C code
HWND cm;

char caption[64];

char pwd[255];

char path[255];

HANDLE rc;

char param[255];

int code;

char *profile="client.ini";

char *section="Client Manager";

strcpy(caption,"Client Manager");

strcpy(pwd,"%IEF%");

strcpy(path,"IEFCM76N.EXE");

strcpy(param,"iefcm startup /initfile=iefcmn.ini");

if (!strcmp(a_0006684838_ioa->l000l01.action_001, "Start")) {

   cm=FindWindow("IEFWINDOW",caption);

   if(!cm) {

      /* Client Manager is not started */

      if(a_0006684838_ioa->l000l01.status_001==1) code=SW_HIDE;

      else code=SW_MINIMIZE;

      rc=ShellExecute(NULL,NULL,path,param,pwd,code);

      if((int) rc<= 32) {

         if((int) rc== 0) a_0006815910_ioa->l001l01.status_002=33;

         else a_0006815910_ioa->l001l01.status_002=(int) rc;

      }

      else

     a_0006815910_ioa->l001l01.status_002=0;

      }

   else

   a_0006815910_ioa->l001l01.status_002=0;

}

else {

   cm=FindWindow("IEFWINDOW",caption);

   if(cm) PostMessage(cm, WM_CLOSE, 0, 0); 
   /* Terminate Application too */

   PostQuitMessage(0);

}             

c. Search for the following:

/**********************************************************/

/* ACTION BLOCK FUNCTION DECLARATIONS  */

/**********************************************************/

d. Now look for the two lines of code that look similar to the following but will not be exactly the same (the highlighted numbered portion might be different in your source code from the ones shown below):

a_0006684838_ioa = im_v_000;

a_0006815910_ioa = ex_v_000;

The above two lines show the structure names for the import and export views. These generated names may vary from model to model hence the structure names shown in your TAKECMAC.c file may be different than the ones shown above. 
e. Replace each occurrence of a_0006684838_ioa in the C code you just pasted with the structure name for the import views from your source code. 
f. Do the same for the export view structure name i.e. a_0006815910_ioa. Replace each occurrence of it in the custom C code with the export view structure name from your generated source code. 
g. Save the file but do not close it. 

3. Edit the EAB Header Info
a. Scroll towards the top of the TAKECMAC.c file and look for the following line:

#include <tiabinc.h>

b. Add the following three lines right after the above shown line.

#include <windows.h>

#include <shellapi.h>

#include <string.h>

c. Save and close the file. Now it is ready to be compiled.

4. Create a Script (.bat file) to Compile EAB

a. In order to compile the EAB in an easy manner (and repeatedly as needed), create a script (.bat file) containing commands. Alternatively, these commands can also be run through a DOS prompt one by one instead of putting them in a script file. 
b. In order to create the script, open a text editor and copy/paste the code shown below into it (make note of the highlighted parts). 
# AllFusion(R) Gen Generated makefile for TAKE_CM_ACTION object module

#

#  Copyright (c) 2007 CA. All rights reserved.           

#Set the environment for using Microsoft Visual Studio 2005

if exist "%vs80comntools%vsvars32.bat" call "%vs80comntools%\vsvars32.bat"

#Compile TAKECMAC.c

cl -c -I"C:\AllFusion Gen\Gen" -EHsc -Zc:forScope- -W3 -Od -nologo -DCGGUI -DNDEBUG -D_WINDOWS -D_MBCS -MD -D_AFXDLL  -DWIN32 -D_WIN32 -DWIN -D_X86_ -Dtry=cktry -Dexcept=__except -Dleave=__leave -Dfinally=__finally -D_CRT_SECURE_NO_DEPRECATE -DCRTAPI1=_cdecl -DCRTAPI2=_cdecl -DMSC -DNONTTRACE -DWIN_NT -DREENTRANT -Fo"C:\models76\extrn\launchcm\TAKECMAC.obj" "C:\models76\extrn\launchcm\TAKECMAC.c" 

# If extrnc.lib does not exist then create the external library file
 lib /out:extrnc.lib TAKECMAC.obj
c. Replace "C:\AllFusion Gen\Gen” with the appropriate path to your %IEF% folder
d. Replace all instances of "C:\models76\extrn\launchcm" with the path to the sub folder that was created underneath the extrn folder. 
e. Save the file with a .bat extension, for e.g. mak_action.bat, in the same location as the TAKECMAC.c file (see below)
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f. Close the file.

5. Compile EAB by Executing the Script

a. Open a DOS prompt and change to the folder where the newly created .bat file is present. 
b. Type the name of the .bat file and press enter.
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c. You will receive warnings about the ‘#’ not being recognized as an internal and external command but these warning can be safely ignored. 
d. Do check the output for any errors that might have been reported although no errors should exist if all of the above steps were followed properly. 
e. Upon successful execution of the .bat file, an object file called TAKECMAC.obj and an external library file called extrnc.lib displays in the same location. 
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5. Add Visual Studio C Libraries to LOC.EXTERNAL_LIB
In order to successfully build the client procedure that had failed earlier under the ‘Packaging and Generation’ step, Visual Studio C libraries need to be added to the Build Tool Profile Manager key LOC.EXTERNAL_LIB with their fully qualified paths. 
1. Make sure the Build Tool is open
2. Click Tools->Profile Manager
3. Click on C under the Profile Tree
4. Look for the LOC.EXTERNAL_LIB key under the Profile Table (as shown below):
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5. Add the libraries shown below with their fully qualified paths to the LOC.EXTERNAL_LIB key. Each library needs to be quoted and separated with a single space.
"C:\Program Files\Microsoft Visual Studio 8\VC\PlatformSDK\Lib\User32.Lib" "C:\Program Files\Microsoft Visual Studio 8\VC\PlatformSDK\Lib\Shell32.Lib"

NOTE: Make sure to type the double quotes also as shown above other wise the compile will fail.

6. Move Extrnc.lib to MODELDIR\Extrn
1. The Build Tool automatically looks for extrnc.lib in the extrn folder. Hence, we need to move extrnc.lib to the extrn folder. 
2. Move extrnc.lib up one level from extrn\launchcm to extrn.
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7. Build the Application
Now that we have taken care of the external libraries needed to successfully compile the application, build the application again. This time the application builds successfully and is ready to test.
8. Execute the Application
1. In order to test the application from the Build Tool, highlight the load module and click Action->Test. The ‘Load Module Test’ window comes up. 
2. Select the only trancode visible under the Trancodes box and click OK. 
3. Notice the Client Manager window minimized on the desktop. 
4. The application can also be executed by double clicking the Window Manager .exe file present in the <model.ief>\c folder. 
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5. To shutdown the application and Client Manager, click on the push button present on the window. 
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