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1

Xcelsius 2008 Versions Available

This user guide is applicable for all versions of Xcelsius 2008. The following
versions are available:

» Xcelsius Present

*  Xcelsius Engage

+ Xcelsius Engage Server

» BusinessObjects Xcelsius Enterprise

Xcelsius Present is the entry level product version. It is intended for users
who wish to create visualizations with Excel data only. Xcelsius Present does
not offer connectivity to external data sources. This version has a robust
suite of the most commonly used components. It also features the most
commonly used visualization export options.

Xcelsius Engage has all of the features of Xcelsius Present. It offers additional
components as well as additional visualization export options. It is intended
for users who need to connect to an external data source.

Xcelsius Engage Server provides all of the features of Xcelsius Engage. In
addition, it offers integration capabilities with web portals and Reporting
Services. Xcelsius Engage Server is bundled with Flynet Web Services
Generator. It is intended for users who wish to create visualizations that are
deployed in a portal environment.

BusinessObjects Xcelsius Enterprise provides all of the features of Xcelsius
Engage. In addition, it offers integration capabilites with web portals and
Reporting Services. BusinessObjects Xcelsius Enterprise integrates with the
BusinessObjects platform, including Query as a Web Service (QaaWs),
LiveOffice, and Crystal Reports. It is intended for users who wish to create
visualizations that are deployed in a BusinessObjects Enterprise environment.
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2 |App|ication Overview

What is Xcelsius 20087

Xcelsius 2008 is a leading-edge Microsoft Windows application that brings
data to life!

Using breakthrough technology, Xcelsius 2008 bridges the gap between
data analysis and visual presentation, empowering users of all proficiencies
to create visually stunning interactive reports and applications.

With Xcelsius 2008, users can communicate data in a clear and powerful
style that's appealing to the mind and to the eye.

Xcelsius 2008 is intuitive enough for beginners and versatile enough for
advanced users. Most importantly, it makes the process of generating reports
and applications fun, without requiring users to learn arcane programming
languages. With Xcelsius 2008, simply pointing and clicking your mouse can
create rich interactive presentations. Your only limitation is your imagination.

Xcelsius 2008 offers tight integration with Microsoft Corporation's ubiquitous
Office products. This tight integration lets you attach your reports to Microsoft
Outlook e-mail messages or embed them into PowerPoint slides using just
a single mouse click!

The Technologies That Drive Xcelsius 2008

Xcelsius 2008 combines two of the most widely used software applications
in the world:

* Microsoft Excel
* Adobe Flash Player

Microsoft Excel is one of the most popular software programs today. It is a
member of the Microsoft Office family of products and is used daily by millions
of people around the world to create reports.

Adobe Flash Player is widely used to view applications developed in Adobe
Flash. According to Adobe, there are roughly 516 million computers with the
Flash Player (as of March 2003).

With these figures, it is almost a certainty that your personal computers — at
home and at the office — already have Microsoft Excel and Adobe Flash
Player installed. The synergy derived by integrating these two widely deployed
applications allows Xcelsius 2008 to leverage years of sophisticated
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2

programming and proven IT and business technologies. The result is a
winning combination that raises the standard in terms of power and usability.

What Skills Does a User Need?

Xcelsius 2008 is uniquely designed to be easy and enjoyable to use. Since
its underlying technology is Microsoft Excel, the only skills a user needs to
create striking visual effects in their reports is a basic understanding of how
Excel works. No additional training is required!
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3

What's New in Xcelsius 2008
Importing a Crystal Xcelsius 4.5 file into Xcelsius 2008

Embedded Spreadsheet

Xcelsius 2008 now provides an embedded spreadsheet which is a fully
functional Excel workbook incorporated into Xcelsius 2008. The Embedded
spreadsheet allows you to create, edit, and manipulate model data directly
in your Xcelsius 2008 file, without the need to import or re-import Excel
spreadsheets.

New Components
Xcelsius 2008 now provides the following new components:
+  Tree Maps

Tree Maps are visualizations that display hierarchical data in a small area.
In Xcelsius 2008, Tree Maps have two parameters: size and color intensity.

* Reset Button
Reset

The Reset Button allows the end user to revert to the visualization's
original settings after changing data at runtime.

*  New Maps

Additional maps have been added that cover Europe and Asia-Pacific
countries. A new map of the US that includes Alaska and Hawaii has also
been added.

e Print Button

Print

The Print Button allows a user to print the SWF file directly from the
browser.
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Importing a Crystal Xcelsius 4.5 file into Xcelsius 2008

Xcelsius Engage new components

In addition to the components available in Xcelsius 2008, Xcelsius Engage
provides the following components in all versions:

« Panel Container

A Panel Container acts as a smaller canvas within the main canvas and
holds one or more components. Components in the Panel Container can
be moved, added, changed, or deleted. Panels can be placed anywhere
on the canvas.

« Tab Set
+ -

Tab Set is similar to Panel Containers. The Tab Set acts as a smaller
canvas within the main canvas. A Tab Set contains multiple tab views;
each can be displayed on the canvas by clicking its corresponding tab.

* Trend Analyzer

Iy

The Trend Analyzer combines data analysis and visualization. The
component analyzes the data selection and provides an additional data
series that can be plotted to display a trend line.

+ History
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The History component tracks and displays the history of changes in a
selected cell. This allows you to easily see the effect of changes in
worksheet data.

* Connection Refresh Button

Refresh

The Connection Refresh Button is linked to one or more data connections
that retrieve data from an external source. Adding the Connection Refresh
Button to your visualization allows users to refresh the data on demand.

* Reporting Services Button
Reporting Services

The Reporting Services Button component enables you to connect to the
Xcelsius Reporting Services (XRS) server and select the report that will
be used to populate the visualization. The XRS server is a web service
that allows Xcelsius to communicate with your SQL Server Reporting
Services (SSRS) server. Use of XRS requires an installation on your web
server. Please refer to the XRS documentation included on the CD for
more information.

«  Source Data

28

The Source Data component indexes the selected source data range.
This component does not have a visual display; it works within the
visualization in combination with other components.

New Features

Xcelsius 2008 now provides the following new features:
* Alerts for selectors
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Alerts can now be added to the following selector components: Label
Based Menu, Combo Box, List Box, List Builder, and Ticker.

Insert Filtered Rows

A selector component can be bound to a Source Data range of multiple
rows with duplicate labels; when a label is selected, the component will
filter the range to insert only the rows corresponding to that label.

Dynamic Selected Item

In list-based selectors, the labels can be changed dynamically through
another component in the model.

Trigger Key

Trigger keys are bound to variable cells and are set to fire when the cell
value matches a target value. Trigger keys are used to trigger data
connections and are also available in the URL Button and Connection
Refresh Button.

Dual Axis Charts

Xcelsius 2008 now has the ability to plot series data on both a primary
and a secondary axis. This is available for the following charts: Line, Bar,
Stacked Bar, Column, Stacked Column, Area, Stacked Area, and
Combination Chart.

Add-on Manager

This feature allows you to install or remove add-ons from within the
Xcelsius application.

Export to Acrobat 9

Visualizations can now be exported to Acrobat 9.
Export to Adobe AIR

Visualizations can now be exported to Adobe AIR.

New Functions

Xcelsius 2008 now provides the following new functions:

Copy/paste components across XLF files
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Once you have set up a component in an XLF, you can reuse the
component by copying and pasting it into other XLFs. The component
will attempt to retain the same binding references and appearance.

Printing

Visualizations can now be printed during Preview mode or from the
exported SWF.

New Functions in Xcelsius Engage versions:

In addition to the functions in Xcelsius 2008, Xcelsius Engage provides the
following functions:

Data Manager
i

External connections are now managed in a central location. The Data
Manager is used to configure and manage all external data connections.

LiveCycle Data Services connections

LiveCycle Data Services provides up-to-second views of your business
data via dashboards connected to Adobe LiveCycle Data Services,
streaming real-time data into interactive visualizations.

External Interface Connection

Data from the SWF file can now be passed into or out of a specific cell
range, using push/pull technology.

Crystal Reports integration

Xcelsius 2008 visualizations that are embedded in Crystal Reports can
be configured to read data from the hosting Crystal Report and dynamically
update when the Crystal Report data changes.

Appearance

Components Browser
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Categary | Tree | List |

Favarites

Charts

A

Line Chart

Pie Chart

Containers

Selectors

Single Yalue

b apz

Text

Other

Art and Backgrounds

"Web Connectivity

The Components Browser look and feel has been significantly changed
from previous versions.

* Interface

The Components Browser displays the components in a sliding
accordion menu. Components can be displayed in Category, Tree, or
List view.

* Favorites

Frequently used components can be added to the Favorites category
in the Category view.

» Object Browser
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Ohject Browser o x

Background 1
28! Group 1 Y
: j Accordion Menu 1
- #2 Dual slider 1 d
. | _>I_I
Lock/Unlock =

Components can be locked in the object browser to prevent them from
being selected or changed while the visualization is being designed.

Move forward/back

Components can easily be moved forward or backward in layers of
the visualization by dragging the component or group towards the top
or bottom of the Object Browser, or by selecting selecting a component
or group and clicking the directional arrows at the bottom of the Object
Browser.

Group/Ungroup

Grouped components appear as subsets in the Object Browser.
Components can be added to or removed from a group in the Object
Browser.

Hide/Show

Individual components and groups can be hidden or shown by clicking
on the dot or checkmark located in the column under the Hide icon.
All components on the canvas can be hidden/shown by clicking on
the Hide icon.

» Docking

The Components, Object, and Properties Browsers can be moved by
clicking on a browser's title bar and dragging it to dockable areas on the
canvas. Mouse over an arrow (displayed while a browser is being dragged)
and Xcelsius 2008 will highlight the corresponding docking location.
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Auto-hiding

To increase screen space for the canvas, the Components, Objects, and
Properties Browsers can be minimized to the margins of the display. A
display tab is shown for minimized browsers; hovering over the tab
displays the browser window.

The images below show the Object Browser minimized (top image) and
displayed on mouse over (bottom image).
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] Guick Views F3|Pre:
My Warkspace
Canvas

Excel

Zanvas and Excel

Xcelsius 2008 includes pre-configured workspace configurations. In
addition, your customized workspace is automatically saved as My
Workspace when Xcelsius 2008 closes. You can select a different
workspace view from the Quick Views menu.

Importing a Crystal Xcelsius 4.5 file into
Xcelsius 2008

Xcelsius supports the ability to import a visualization created with Xcelsius
4.5. This import ability lets Xcelsius 4.5 customers upgrade their existing
visualizations to take advantage of the new features of Xcelsius 2008. Backup
your current XLF, JPEG, and external SWF files before upgrading your
visualization.

Note: Xcelsius 3.0, 3.5, and 4.0 files cannot be imported into Xcelsius 2008.
To use these files in Xcelsius 2008 you must first import them into Xcelsius
4.5, then import the files into Xcelsius 2008.

To import your existing visualizations, start Xcelsius 2008 and select File >
Open. Select the XLF that you would like to import and click Open. Xcelsius
2008 will detect that the XLF is an older visualization and warn you that it is
going to import the visualization into Xcelsius 2008, and that this may result
in certain features not functioning.

Note: After you import and save your visualization with Xcelsius 2008, the
visualization cannot be opened using an earlier version of Xcelsius.

Xcelsius 2008 minimizes the impact of migrating visualizations from Xcelsius
4.5. However, it is possible that some of your visualizations, or more
specifically, some components, will look slightly different from the original
file.

The following are some of the most frequently encountered changes:

» The size of some components is different. In most cases the size
difference is a matter of a few pixels.
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» Due to art improvements, some custom colors appear to be slightly
different.

* The Spreadsheet Table component differs in size and formatting.
In the event of formatting differences in your components, bring up the

Properties panel for the component and re-bind any properties that are tied
to the cells in the spreadsheet.
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Getting to Know Xcelsius 2008

Overview

Overview

This section provides an introduction to Xcelsius 2008, the components of
the program, and the functionality of the program.

Understanding the Xcelsius 2008 system

Xcelsius 2008 visualizations conform to SWF file format. SWF is the
vector-based graphics format designed to run in the Adobe Flash Player.
Because a SWF file is vector-based, its graphics are scalable and play back
smoothly on any screen size and across multiple platforms. Also, a
vector-based file usually has a smaller file size than other animations.

Xcelsius 2008 files are stored in a zipped format with an XLF extension. The
XLF file format contains the Xcelsius 2008 visualization information and its
associated embedded spreadsheet file.

Note: Xcelsius 2008 requires Flash version 9 or later. Newer Flash versions
have security features which may prevent your Xcelsius 2008 visualization
from connecting with an external data source. Without a policy file, SWF files
from one domain cannot access data on another domain or sub-domain. In
addition, SWF files served over HTTP cannot access data at an HTTPS
location. Please refer to the online article from Adobe regarding security
restrictions for data loading for information on creating a policy file to allow
access to data in the cases above.

How Xcelsius 2008 differs from traditional reporting
applications

Xcelsius 2008 complements all types of Portal initiatives, Business
Intelligence programs, Executive Dashboards, Balanced Scorecard projects,
Marketing Reports, and day-to-day reporting and presentation requirements.
Xcelsius 2008 does this by letting end users participate in the report creation
process and analysis.
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How Xcelsius 2008 works

There are three steps to create an Xcelsius 2008 visualization:
1. Add data to the spreadsheet.

2. Build the visualization.

3. Publish the visualization.

For detailed instructions on creating visualizations, see Creating and Updating
Xcelsius 2008 Visualizations on page 69.

How visualizations look

Visualizations created with Xcelsius can have any type of standard or
personalized look. Visualizations are also fully compatible with Microsoft
Power Point, HTML, and Portals.

Xcelsius visualizations conform to SWF file format. SWF is the vector-based
graphics format designed to run in the Flash Player. Because a SWF file is
vector-based, its graphics are scalable and play back smoothly on any screen
size and across multiple platforms.Also, a vector-based file usually has a
smaller file size than a bitmap animation.

Visualizations created with Xcelsius are dynamic. What-if scenarios let users
adjust conditions on the visualization and view the results. Interactive
components let users alter the visualization conditions.

The following examples show visualizations created with Xcelsius.

Example 1: What-if presentation using alerts

This visualization shows the return-on-equity (ROE) for a financial institution
against its peer group performance. The alert colors are triggered, comparing
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the selected bank against the peer group average.

Profitability Index - Peer Group Comparison Einfo
Li#
Financial Spreag |
4.00%
| ._.e ............. [E m m
Transformation
) Net Profit Return on Assets Return on Equity
$850 7.04% 18,00%
8 [
Revenues from
Services —
51,800
....... 8.
I
Total Assets t
524,000 = ) 1
| i g 1 i I
34 of Nonyielding " Nonyielding Assets
ks Retained Earnings Leverage ) Eality
23.00% $3,889 2,70 0.62
RN P b S
b
Paid-in Capital
55,000

Example 2: What-if presentation using a calculator

The following visualization was created to calculate the monthly payment for
a home loan. Users can adjust the input values by moving the sliders. The
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calculator dynamically changes and displays the new values.

How Much Will My Payments Be? ><.°¢'5'“5®
Required Information
® 10an amount e e———— T $243,000
® remiinYeas 0090090909090 se——————-—— 30
@ vearly Property Taxes P - e R £32,000
@ vearly Homeowner's Insurance L. - e " R i s600
® [nrecest Rate R RTTRIR T . ST 7,000%

Yuur Estimated Payments Are:

Frindpal and Interest
W Taxes anc Insarance

Monthly principal and interest payment is $1L,617

Monthly estimated taxes and insurance payment is §217 ‘

Total monthly estimated payment is $1,833

* Homeawner's insurance wil be calowiaded ab Hme of closing. i may vary ,,/
depending on severa factors M % of down parment, foan amount. sl =%

@ Copyright Infommersion Inc. 2003

Example 3: Historical data comparison presentation

The following visualization is a dynamic financial statement report. It shows
the traditional Statements of Income. When a user clicks on an account, the
visualization shows the historical data organized by region or as a comparison
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against competitors.

Consolidated statements of income

Sales by Region

Two years ended December 29, 2001

1in millizas) 2001 2000
Cost of sales 13,487 12,650
Research and development 2,796 3,897
Marketing, general and administrative 4,464 5,089
Armartization of goodwill 2,338 1,586
Purchased In-process research and development 198 10%
Operating costs and expenses 24,283 23,331
Operating income 2,256 10,395
Gains (losses) on equity securities, net (465) 3,759
Interest and other, net 393 SB7
Income before taxes 2,183 15,141
Provision for taxes 892 4,606

Net income 1,291 10,535

prvered b
Net Revenues tane panding

36K

North America

/K

Millions $
Millians

15K

e R — =

B lss3 1sa4 1395 1996 1957 1395 1959 2000 000

0 CapynIgn Infammersian Ing, 2003

Understanding the Xcelsius 2008 tools

Before you begin using Xcelsius, take a moment to familiarize yourself with
the interface by reading the following section. In this section you will learn
about Xcelsius elements, browsers, tools, and other options.

Note: To view a browser, select the browser from the View menu. In the
View menu, a check mark next to the browser name indicates that the browser
window is open; if you cannot see the browser in your workspace, it may be
minimized at the perimeter of the Xcelsius window.

Using the Components Browser

The Components Browser shows the available components that can be
added to your model.
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The window contains three views:

» Category View
* Tree View
* List View

Category View

The components are grouped in a sliding accordion menu according to their
functionality.

Categary | Tree | List |

Favarites

Charts

A

Line Chart

Pie Chart

Containers

Selectors

Single Yalue

b apz

Text

Other

Art and Backgrounds

"Web Connectivity

You can navigate to a component in the Category view of the Components
Browser by clicking on a category title or dragging the scrollbar until you
reach the desired category.

* Favorites
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¢ Charts

» Containers (available only in Xcelsius Engage 2008)

+ Selectors

* Single-Value

+ Maps
« Text
«  Other

* Art & Backgrounds
* Web Connectivity

Note: To add a component to Favorites, navigate to the component in the
Category view, right-click on its icon and select Add To Favorites. To delete
the component, right-click the icon in the Favorites category and select

Remove From Favorites.

List View

In the List View, the components are organized alphabetically.

Cakegory | Tree  List |
=

() Africa by country
() Albania by region
() Andorra by region b
[ area Chart

O Armenia

() Asia by country

() Asia Pacific (large) by country

() Asia Pacific (small) by country

() Australia by region

() Austria by state

() Azerbaijan by province

| Background

| v

To navigate in the List View, click anywhere within the window, then type
the first letter of the component you wish to open, or drag the scrollbar until
you reach the desired component.
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Note: The List view does not contain the Favorites category. Favorites can
only be viewed or added in Category and Tree views.

Tree View

In Tree View the components are organized in folders according to their
category.

Caktegory  Tree | Lisk |

[#-_J Charts

[+ Containers

[#-_J Selectors

- Single Yalue

-] Maps

) Text

- Cther

[~ Art and Backgrounds
[~ web Connecivity

Note: To add a component to Favorites, navigate to the component in the

Tree view, right-click on its icon and select Add To Favorites. To delete the

component, right-click the icon in the Favorites category and select Remove
From Favorites.

Using the Canvas

The canvas area is the white work area where you place components to
create a visualization.

The canvas color can be customized using its Properties panel. If the
Properties panel is not open, double click anywhere on the canvas to open
the panel.

Placing components on the canvas using drag and drop

1. On the Components Browser, click a component.
2. Holding down the left mouse button, drag the component onto the canvas.
3. Release the mouse button.
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The component is dropped on the canvas at the location of the mouse
pointer.

4. Repeat this procedure for each component.

Placing components on the canvas using point and click

1. On the Components Browser click a component.
2. Click the canvas area.

The component is dropped on the canvas at the location of the mouse
pointer.

3. Repeat this procedure for each component.

Fitting the canvas to components

After you complete your visualization, you may want to adjust its final size
to eliminate any surrounding white area.

2 To do this, use the Fit Canvas to Components button on the tool bar.
Your visualization size will be adjusted to the minimum size according to the
components placed on the canvas.

& = Inaddition, you can use the Increase Canvas and Decrease Canvas
buttons on the toolbar to shrink or grow the canvas in small increments.

Fitting the canvas to the window

% To resize the canvas so that it fills the workspace, click Fit Canvas to
Window on the toolbar.

Changing the canvas size

You can change the canvas size before you start creating a visualization by
clicking Document Properties on the File menu. The Document Properties
dialog box appears.
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x4
Carnvas size in pixels
& Preset Size [ 600 * 00 =]

Fonts

Verdana ﬂ

% Usa Device Fonks (Fonts vl not be embedded)

" Use Embedded Fonts —

You can modify the preset size to some standard sizes, or you can create
your own size. The ideal size of your visualization depends on the quantity
of components that you plan to use.

If you are building a simple visualization that contains a chart and slider, the
size can be around 640x840. Use the full size screen for dashboards or
one-page visualizations that contain several charts and selectors.

In the description field, you can write a brief description of your visualization,
the author, the date, and its intended functionality. This information will appear
to all other designers when they use your XLF file or when you save your
visualization as a template.

Using the Grid Tool

The Grid command on the Preferences menu provides a layout tool that can
aid in positioning components on the canvas. Select File > Preferences >
Grid to open the Grid Tool.
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Grid

[ Show Grid [ Snap To Grid

| 100 +—s idth 100 I Height

The following options for customizing the grid are available:
+ Show Grid. This option controls the visibility of the grid.

» Snap to Grid. This option aligns the selected components to the grid lines.
» Height. This option sets the vertical spacing intervals for the grid in pixels.

+ Width. This option sets the horizontal spacing intervals for the grid in
pixels.

Using the Canvas Properties Panel

Type
Click the drop-down menu to select a canvas type:
» Solid Color

» Gradient (default)
* Image
* None

Note: Canvas Appearance Type “None” creates a transparent background
with used in conjunction with the “wmode” Flash Object parameter in
HTML code.

Background Color

Click the adjacent cell selector button to customize the color of the canvas
background.

Note: This setting is only available if Gradient is the selected Type.
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Background Color 1 and 2

Click the adjacent cell selector button to customize the first and second color
to be used in the canvas background. Color 1 will be displayed at the top of
the canvas and fades downward into Color 2. Color 2 will be displayed at
the bottom of the canvas and fades upward into Color 1.

Note: These settings are only available if Gradient is the selected Type.

Import Button

Click the Import Button to launch the Open file dialog box. Navigate to the
JPEG or SWF file to be used as the canvas background.

Note: This setting is only available if Image is the selected Type.

Using the Properties panel

The component Properties panel contains the setting and format options for
the selected component. After you place a component on the canvas area,
you can access the Properties panel by double-clicking the selected
component, right-clicking on the component, or selecting the component and
typing ALT+ENTER. In general, the Properties panel has the same structure
for all components, but the options available are specific to each individual
component.

The Properties panel may have the following tabs:

e ; ! @
LY ﬁ[ Bz \/ Pk |G
hal N Ja T el
General Dorill Doy Behavior Appearance Alerts
*  General
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General

The General tab contains the required settings for the selected component.
At a minimum, it contains an area for the title or label(s), and an area to
select the Data Source or enter the values that will be displayed.

Drill Down

I";.“l\j

il Down

The Drill Down tab ontains a series of parameters for adding drill-down
capability for charts. For information on the Drill Down tab, see Drill Down
tab on page 264.

Note: This tab applies only to Chart components.

Behavior

W
/&

Behawior

The Behavior tab contains settings related to the way the component will
work in the visualization. Typically, it contains areas for defining the
functions related to limits, interactivity, and dynamic visibility. See Dynamic
Visibility functionality on page 148 for more information.

Appearance

i
_"r- -

Appearance

The Appearance tab contains a series of settings areas, and in some
cases sub-tabs, that let you modify the appearance and formatting of
components. On this tab you will find options like font size, title location,
and colors.

Alerts
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The Alerts tab contains all the parameters available for using alerts. On
this tab, you can define the number of alert colors, the colors used, and
the target limits. See Alerts on page 154 for more information.

Properties for multiple selections

By selecting multiple components on the canvas, you can simultaneously
edit Properties for the components in your selection. To access Properties
for multiple components select your components and double click the
selection. You can also access the Properties by right-clicking the selection
and selecting Properties from the context menu.

If the components are of the same type, you will be able to edit Properties
specific to that component type. For example, if your current selection
contains three Line Chart components, you will be able to access the
Properties specific to the Line Chart. Any change made to the Properties will
apply to all components in the selection. The Properties panel selections
with components of mixed types or groups are limited to the Dynamic Visibility
parameters of the Behavior tab. When a number of components are grouped,
the Properties for individual components within that group may be accessed
by right-clicking on that sub-group component in the Object Browser window.
See Using the Object Browser on page 49 for more information.

Using the Object Browser

In the Object Browser, you can select, hide, show, cut, copy, paste, delete,
bring forward, move back, group, ungroup, lock, unlock, and access
Properties panels of components.
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The Object Browser can be docked in locations around the workspace or
minimized as needed. If you have closed the Object Browser, click Object
Browser on the View menu to re-open it.

context menu

Display a context menu by right-clicking on any component in the browser
or on the canvas.

The context menu provides access to many of the functions that are available
in the Object Browser.

components

To select a component in the Object Browser, click the component name or
icon to make it the active component on the canvas.

To select multiple components, click a component name or icon, and then
hold down the CTRL key while you click additional components. To select
a range of components, hold down the SHIFT key while selecting the range
in the Object Browser, or click on the canvas and drag the cursor over a
group of components.

Combine methods by selecting a group of components first with SHIFT+click
and then other separate components using CTRL+click. Always select using
SHIFT+click first; this will not work in reverse.

Select all components by selecting any component, then pressing CTRL+A.

Note: On the canvas, you cannot select components that are marked as
hidden or locked. Those components can only be selected in the Object
Browser.
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Grouping components

Objects in the Object Browser can be grouped in the following ways:

» Select several components, then right-click on any of the components
and select Group from the context menu.

Select several components, then click 2l n the toolbar.

Once grouped, the components will appear in the browser in tree form with
a folder representing the group. Expand the group folder by clicking the +
button or double-clicking the folder icon or the group label. Components can
be dragged into and out of the group by dragging them to a different location
in the browser tree.

To ungroup selected components, click i1 on the toolbar or right-click on
the group to access the context menu, then select Ungroup.

Hiding components

To hide a component in the Object Browser, click the dot in the column under

o,

the hide icon == .
To hide a group, click the dot in the hide column for the group.
To hide all components, click the hide icon.

To show a hidden component or group, click the check mark under the hide
icon. To show all hidden components and groups, click the hide icon twice.

Locking Components

Components and groups can be locked on the canvas to prevent any
interaction with them. This can be helpful when there are many components
laid out on the canvas. The component or group will only be selectable in
the Object Browser.

To lock a component or group, click the dot under the lock icon = . To
unlock a group or component, click the check mark under the lock icon. All
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components and groups can be locked by clicking the lock icon once, and
all unlocked by clicking twice.

Deleting components

Delete any selected components by pressing DELETE or selecting Delete
from the right-click context menu.

Tip: You do not need to ungroup components to delete components that
are in the group.

Deleting a component can be undone pressing CTRL+Z or clicking Undo
on the Edit menu.

Opening Properties panels

Properties panels for components, either alone or in a group, are opened
using one of the following methods:

* Click the icon or label.

Note: Slowly double-clicking the label will enable the Rename function
instead of Properties.

+ Select the component and press ALT+ENTER.
* Right-click the component and click Properties.
Properties panels for a group are opened separately from the Properties

panels of individual components within the group:

* Right-click the group label or icon and click Properties.

» Select the group and press ALT+ENTER.

Note: Do not double-click a group to open its Properties panel; unlike

individual components, double clicking on a group entry expands or collapses
that group within the tree.

Once the Properties panel is opened for one component you can navigate
to the Properties panel of another component or group by clicking on the
entry in the Object Browser.
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Renaming components

Each component is assigned a default browsing name when placed on the
canvas. This is the name that appears in the title bar of the Properties panel
and in the entry in the Object Browser.

You can override these default names to enter your own. Double-click slowly
on the component name in the Object Browser to enable label edit mode.
Type in a name and press ENTER or click on another component.

Using the Embedded Spreadsheet

’]
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The Xcelsius 2008 workspace incorporates an embedded spreadsheet. This
fully functional spreadsheet is displayed below the canvas and contains the
source data for your visualizations. You can add, modify, and delete your
data directly within the spreadsheet without having to import or re-import an
Excel spreadsheet.

There are several ways to bring data into the embedded spreadsheet:

¢ Import a spreadsheet from Excel. See: Importing Excel spreadsheets
on page 56 .

» Copy/paste data from an Excel or Xcelsius 2008 file.

* Manually enter the data into the embedded spreadsheet.

You can bind cells in your embedded spreadsheet to components on your
canvas.
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Note: If you import a spreadsheet after linking to cells, the imported data
will overwrite all data in the current embedded spreadsheet. The cell binding
locations will remain the same, but the data may be changed.

You can also copy and paste cells between Xcelsius 2008 and Excel. Excel
values and formulas can be copied into Xcelsius 2008, but conditional
formatting of cells will not be retained.

Note: Xcelsius 2008 opens an instance of Excel that runs in the background.
Although you can open a second instance of Excel, you will not be able to
copy formulas between the instances. If you need to use Excel and Xcelsius
2008 files simultaneously, first open Xcelsius 2008, then open your Excel
files by navigating to them using Windows Explorer and double-clicking on
them.

If you need to keep synced Excel and Xcelsius 2008 files, we recommend
making your updates in the Xcelsius 2008 embedded spreadsheet and then
exporting the data to an Excel spreadsheet.

Note: Xcelsius 2008 imports Excel files by copying the spreadsheet data
and inserting the data into the Xcelsius 2008 embedded spreadsheet. After
the data has been imported, it is no longer linked to the original Excel
spreadsheet. Any changes you make to the source file will not appear in the
Embedded Spreadsheet, nor will any changes to the Xcelsius 2008 file appear
in the original Excel file.

The embedded spreadsheet is a fully functioning Excel spreadsheet, complete
with toolbars used in Excel.

If you are using Excel 2003, you will be able to see your default toolbars.
Toolbar buttons not related to working with the data have been disabled
(Save, Open, Print, etc.). These disabled buttons are functions that are
handled by Xcelsius. If you wish to Save the spreadsheet, use Xcelsius's
File > Save function, or export the spreadsheet back to Excel. See Importing
Excel spreadsheets on page 56 for more information.

If you are using Excel 2007, you will be able to see the ribbon displayed at
the top of the program. In addition to the disabled buttons, the drop down
menus are disabled in the ribbon.

For both versions of Excel, you can add Excel functionality to the toolbar by
right-clicking on any toolbar and adding the toolbar with the desired
function(s).
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Embedded Spreadsheet

Although the embedded spreadsheet is a fully functioning Excel spreadsheet,
not all Excel functions are supported. Xcelsius 2008 does not support macros,
conditional formatting, or all available formula functions. For a full list of

supported formula functions, see Supported Excel Functions on page 387.

Xcelsius 2008 does support the moving of bound data ranges. For instance,
if your chart source data range needs to be moved down a row to fit in the
title, simply select the range and move it to its new location. Xcelsius 2008
will retain the new information and reference the new range. However, if only
part of the range is moved the bound cell reference will remain the same.
You will need to open the component's Properties panel and re-bind the cell
reference to the new location if only part of the range is moved and you want
the new location referenced.

Note: The component's Properties panel will note reflect the updated range
as the listed cell reference if a range is moved, expanded by inserting cells,
or decreased by deleting cells. The new range is still bound and recognized
by Xcelsius 2008.

The embedded spreadsheet allows you to change the sort order of your data.
However, this action is not read as an event by Excel, and as such does not
prompt Xcelsius to update. You will not see any component bound to the
sorted data update with the new data order. The new sort will be reflected
in Preview mode or the exported visualization. An update can also be forced
by rebinding the range in the component.

and Exporting data

Xcelsius 2008 uses an embedded Excel based spreadsheet as its data
source. This provides the ability to copy and paste data between the Xcelsius
2008 embedded spreadsheet and an Excel spreadsheet. Source data can
be created either in the embedded Xcelsius 2008 spreadsheet directly or in
Excel and brought into Xcelsius 2008 . Smaller pieces of data can be
copy/pasted or whole files can be imported.

Because Xcelsius 2008 files incorporate Excel data, spreadsheet data can
easily be imported from Excel into Xcelsius 2008 or exported from Xcelsius
2008 to Excel.
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Importing Excel spreadsheets

To use an existing Excel spreadsheet as the source data for your

visualization, select Data > Import or use the Import Model button & on
the toolbar to import the file.

Note: When the Excel file is imported the data is copied and is no longer
connected to the original data. Editing the original source file will not change
the data imported into Xcelsius.

WARNING: Importing an Excel spreadsheet will overwrite any data that is
currently in the spreadsheet.

Exporting data to Excel

Select Data > Export to export the embedded spreadsheet data as an Excel
file.

Using the Format menu

Align

The Format menu provides various options for formatting the placement and
layout of the components in the visualization.

Access to the Themes and Color Schemes dialog boxes is provided under
the Format menu.

Note: These options are also available on the Format and Themes Toolbars.

With the Align options, you can align the boundaries of components or groups
of components relative to the first component in the selection. Align functions
require the selection of at least two components.

The following Align options are available:
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Make Same Size
With the Make Same Size options, you can make the selected components

the same width ~= , height Hi , Or size i relative to the first component in
the selection.

Space Evenly

With the Space Evenly options, you can distribute a selection of components
either horizontally (Across) or vertically (Down) so that there are even spaces
between them.

Note: To use the Space Evenly options, you must have more than one
component selected.

Center in Canvas

With the Center in Canvas options, you can center selected components on
the canvas. You can center them vertically, horizontally, or both.

Other commands on the Format menu

The following commands are also available on the Format menu:
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@ Bring to Front. Brings component to the topmost layer.
%4 Send to Back. Sends component to the bottom layer.
5 Bring Forward. Brings component forward one layer.
L4 Send Back. Sends component back one layer.

I8 Group. Groups selected components as a single item.
I Ungroup. Ungroups a group of components.

Understanding fonts in Xcelsius 2008

The following options are available for displaying fonts in Xcelsius 2008:

Device Fonts

By default, Xcelsius 2008 uses this option for components within a
visualization. This option is recommended when creating models that
require the extended character set as defined by Unicode. The Device
Fonts option uses the SWF player to directly render the TrueType Font
you select.

Device Fonts also let you use different fonts for different components in
the same visualization. However, depending on the TrueType Fonts
installed on the end user's machine, the fonts in the visualization may not
display properly.

Embedded Fonts

This option generates the characters from the TrueType Font you select,
and embeds them into the SWF file. Because the font is embedded in
the SWF file, the font displays properly regardless of whether the user
has the TrueType Font installed. However, this option increases the file
size and the time required to load the visualization.

Note: Asian character sets are not supported with Embedded Fonts due
to the large number of characters they require. You must use
Non-Embedded Fonts for situations where you require Asian characters.
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To change the font for a visualization

1. On the File menu, click Document Properties.

The Document Properties dialog box appears.

x
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" Use Embedded Fonts e —
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2. If you want to use one embedded font for all components in the
visualization:
a. On the Font list, click the font that you want.
b. Click OK.

3. If you want to use a different font for each component in the visualization,
or you want to use non-embedded fonts:

a. Click Use Device Fonts.
b. Click OK.

You can now use the Font Settings on the Component Properties panel
to change the font used for that component.
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Using Themes

Themes (formerly Skins) allow you to globally change the appearance of
components. Each theme has a number of different components that you
can use to maintain the look and feel of that particular theme. Combined with
Color Schemes, you can use Themes to create a multitude of different looks
for your visualizations.

Select a theme from the main toolbar dropdown or from the Format
menu.

The Themes dialog box contains a list of available Themes and a preview
of each. Selecting a new Theme will apply the Theme to all existing
components as well as new components.

Admiral Preview:
Bero
Agua
Elan
Graphite
Halo
iTheme

IWindnws Classic @,

Note: Some variations of a component type are only available when a
particular Theme is applied (for example, half gauge is only in Graphite).
Changing the Theme with these unique components on the canvas will
change those components to the default for that category of component.
However, the original component type is retained and will revert back to its
original form if the Theme is changed back.

Using Color Schemes

Color Schemes (formerly Styles) alter the color palette of your visualization.
You can customize your entire visualization, or only certain components.
You can create your own Color Schemes based on an existing scheme or
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combination of custom colors. Color Scheme only affect the colors of
components, and do not affect fonts, text formatting, or alerts.

Note: Color Schemes are not transferred with XLF files. If the Color Scheme
used by an XLF is unavailable, the style will continue to be used by the
existing componenets in the visualization, but it will not be able to be applied
to new components.

Changing the current Color Scheme

To change the current Color Scheme, click the color scheme icon I on
the Themes toolbar. Select a color scheme from the menu:
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Select Create New Color Scheme to create a custom color scheme. See
Creating a Custom Color Scheme on page 63

Alternatively, you can change the color scheme by selecting Color Scheme
from the Format menu.
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Color Schemes
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In the Color Schemes dialog box, select a color scheme from the list. Click
OK to apply the selected Color Scheme to the components on the canvas.
The Color Scheme that is applied to the visualization is displayed on the
Component Explorer.

Note: There is a default color scheme associated with each Theme that
cannot be modified. Select Current Theme Colors to revert to the original
appearance of the visualization. Any color changes made will be reverted to
their default values.

Selecting a new color scheme will affect all components placed on the canvas
after the new scheme is applied. If you would like to change the color scheme
of components already on the canvas, you will need to select Apply To
Existing Components.

Click Create New to create a custom color scheme, or select a custom color
scheme from the list and click Edit to modify the scheme.

Note: Only Custom color schemes can be edited.
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For information on the Custom Color Scheme Dialog, see Creating a Custom
Color Scheme on page 63

Creating a Custom Color Scheme

You can create custom Color Schemes by modifying the parameters of an
existing color scheme.
To create a Custom Color Scheme
1. On the Format menu, click Color Scheme then select Create New, or
select the Color Scheme icon from the toolbar Bl and select Create New
Color Scheme from the dropdown menu .

The Color Schemes dialog box appears.
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2. Select a color from the palette to edit its value.

3. Select a new color by clicking on the color picker or by manually entering
the color values.

4. You can modify the other colors individually, or Xcelsius 2008 can
automatically modify the other colors in the scheme to be more or less
alike than the selected color. To do this, select Auto Match Colors and
use the slider to adjust the colors.

5. Select Advanced Settings to access the advanced color menu. Here,
you can set the colors for individual elements in the visualization.

6. Click Save to save the new Color Scheme.
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7. Click OK.

The new color scheme is the active color scheme and will be applied to
any components that are added to the visualization. To apply the new
color scheme, select Apply to Existing Components.

Note: Click Reset before saving the Color Scheme to revert to the originally
assigned color settings.

Transferring Custom Color Schemes

Color Schemes are transferred with XLF files.

When a visualization with a custom color scheme is opened, the applied
color palette will be displayed in the Colors toolbar icon. The custom color
scheme will also be applied to any components added to the visualization.
However, the Custom color scheme will not appear in the list of available
Color Schemes. To add the transferred color scheme to the host machine,
follow the steps for Creating a Custom Color Scheme on page 63.

Previewing the Visualization

With Xcelsius 2008, you can test run your visualization as many times as
you need. It lets you experiment with various combinations of components,
colors, and layouts to make sure your visualization functions according to
your specifications.

Select File > Preview or use the Preview button 3 to toggle between the
design view and Preview.

You can also select File > Export > Preview to view the visualization in your
default web browser.

In Preview, you can interact with the visualization as you would when it is
published.
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Viewing sample Xcelsius 2008
visualizations

The sample visualizations included with Xcelsius 2008 show how some of
the components and functions work.

Note: Samples include their own embedded spreadsheet data. Opening a
sample will overwrite any data already in the embedded spreadsheet.

The following User Guide Samples are included with Xcelsius 2008 (Samples
in bold have step-by-step instructions in this User Guide):
Accordion Menu
Alerts — Charts
» Alerts — Selectors
* Alerts — Single Values
Calendar
Check Box
» Connection Refresh / XML Data Connection
*  Drill-Down Chart
Dual Axis Chart
Dynamic Selected Item
*  Dynamic Visibility
+ Filter
Filtered Rows
Fisheye Picture Menu
*  Filter
» Filtered Rows
Fisheye Picture Menu
» Flash Variable Data Connection
* Grid
» History
Icon
Ignore End Blanks
* Image
* Line Chart
List Box
List Builder
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« Map

» Panel Container
* Play Selector

* Reset Button

- Slider

» Slideshow

» Sliding Picture Menu
» Status List

+ Tab Set

* Ticker

» Tree Map

*  Trend Analyzer
* Value Display

Note: Samples include their own embedded spreadsheet data. Opening a
sample will overwrite any data already in the embedded spreadsheet.

To view sample Xcelsius 2008 visualizations

1. On the File menu, click Samples.
The Samples dialog box appears.

2. In the Category box, click User Guide Samples.

3. In the Items box, click the component that you want to view an example
of.

A description of the component and a preview of the visualization are
shown.

4. Click OK to open the sample visualization.

Using Templates

Xcelsius 2008 offers a set of templates you can use to create a new
visualization. You can use the existing Xcelsius 2008 templates or you can
create a visualization from scratch and save it as a template.

For more information on creating and using templates, see Creating templates
on page 157.
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To View Xcelsius 2008 Templates

1. On the File menu, click Templates.
The New From Template dialog box appears.

2. In the Category box, click New.
3. In the Items box, click the Template you would like to view.
A description and preview of the Template is shown.

4. Click OK to open the Template.
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This section introduces the process of creating and updating Xcelsius 2008
visualizations.

Creating a visualization

1. Add or import spreadsheet data to an Xcelsius 2008 file.
2. Link components to the spreadsheet.

3. Preview and publish the visualization.

Step 1: Add Spreadsheet Data

The first step in creating an Xcelsius 2008 visualization is to add spreadsheet

data to support your visualization. There are three ways to do this:

» Import a spreadsheet from Excel

»  Copy/paste cells from an Excel file or Xcelsius 2008 embedded
spreadsheet

* Manually enter information into the embedded spreadsheet

You can add, modify, and delete data in the embedded spreadsheet. If you
have linked cells to components, the components will automatically update
when you change the data in linked cells.

Step 2: Link components to the spreadsheet

The second step in creating an Xcelsius 2008 visualization is to select the
data sources linked to the components. In this step, you assign one or more
cells from your embedded spreadsheet to one or more Xcelsius 2008
components.

User Guide Sample: Slider

This model uses a Column Chart to show “Car Sales by Location(1? and a
Horizontal Slider to create a simple "what-if" scenario that shows the impact
of selling "N" number of additional cars. Adjusting the slider will cause the
sales to increase or decrease, which is visualized in the column chart.
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To open the User Guide Sample file:

1. Select File > Samples.

2. Select the User Guide Samples category.

3. Select the file name in the Items section.

The Sample file will contain all components and the corresponding
spreadsheet data. To follow along with the below step-by-step instructions,
open the Sample file and then delete the components. These instructions
will produce a working visualization that will demonstrate the use of a
component or feature; additional settings, formats or components may have
been added to enhance the appearance of the sample visualization.

Note: The completed sample XLF file with embedded spreadsheet data,
and SWF file for this visualization can be located by navigating to the following
location:

C:\Program Files\Business Objects\Xcelsius\assets\samples\User Guide
Samples

Selecting the data source for the components

Place a Column Chart on the canvas.
Double-click the Column Chart to open the Properties panel.
Click the Data by Range cell selector button.

Select the range of cells that contain the data for the Column Chart from
the spreadsheet and click OK .

Type or link the chart title and subtitle.

Type or link the axis names.

Click the Horizontal Slider component to open the Properties panel.
Click the Data cell selector button.

Select the Price Per Unit value cell from the spreadsheet, and click OK.

N

©o®eNo O

Step 3: Preview and publish the visualization

The third step is to preview and publish the visualization. You can Preview
the live visualization, test the simulation results, and generate the Flash
animation SWF that contains the visualization. The visualization is then ready
for publishing and distribution.
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Click the Preview button ™3 on the tool bar to toggle between the design
view and Preview. In Preview, you can interact with the visualization as you
would when it is published.

Once you are satisfied with the results, the visualization is ready to be
published. You can publish your visualization using one of the following
methods:

Export as Adobe Flash (SWF)

Note: This option is available in Xcelsius Engage 2008 only.

Export as HTML

Note: This option is available in Xcelsius Engage 2008 only.

5

5 Export to Microsoft PowerPoint

% Export as Adobe PDF

% Email Using Microsoft Outlook

%| Export to Microsoft Word

(7] Export to BusinessObijects Platform

Note: This option is available in BusinessObjects Xcelsius Enterprise
2008 only.

See Exporting Xcelsius 2008 Visualizations on page 135 for more information.

Updating data for a visualization

The Export Settings command on the File menu lets you specify how you
want to update data. You can update the embedded spreadsheet as needed
or you can specify an external Excel file to use as a data source. The following
options for updating the data in your visualization are available:

Use Current Excel Data

This option takes the data as it exists in the embedded spreadsheet. This
is the default option.

Use Another Excel File
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This option lets you specify a different Excel file from which to take data
when the file is exported.

Updating the Embedded Spreadsheet

The easiest way to update your data is to make your changes directly in the
embedded spreadsheet. Change the data in the embedded spreadsheet the
same way you would with an Excel spreadsheet.

You can copy and paste cells from an Excel spreadsheet. Formulas and
values will be pasted into Xcelsius 2008, however conditional formatting will
not be retained.

Note: Xcelsius 2008 opens an instance of Excel that runs in the background.
Although you can open a second instance of Excel, you will not be able to
copy formulas between the instances. If you need to use Excel and Xcelsius
2008 files simultaneously, first open Xcelsius 2008, then open your Excel
files by navigating to them using Windows Explorer and double-clicking on
them.

If you need to keep synced Excel and Xcelsius 2008 files, we recommend
making your updates in the Xcelsius 2008 embedded spreadsheet and then
exporting the data to an Excel spreadsheet.

Note: Xcelsius 2008 imports Excel files by copying the spreadsheet data
and inserting the data into the Xcelsius 2008 embedded spreadsheet. After
the data has been imported, it is no longer linked to the original Excel
spreadsheet. Any changes you make to the source file will not appear in the
Embedded Spreadsheet, nor will any changes to the Xcelsius 2008 file appear
in the original Excel file.
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Overview

This section introduces the Xcelsius 2008 components and their most basic
functionality.

Using the Chart components

Charts are one of the most powerful ways to transmit your message. A
well-created chart can transmit a real sense of value to any report. This
section describes the basic functionality available in charts.

For more information about chart components, see Chart Components
Reference on page 259.

Xcelsius 2008 provides the following charts:
* Line Chart

120

20
40
1 2 3 4 5

0

A single- or multi-line chart ideal for showing tendency over a period of
time. Use this chart in visualizations that emphasize a trend or a continuing
sequence of data, such as Stock Prices or Revenue History.

+  Pie Chart

H!:
H:Z

A chart that represents the distribution or participation of each item
(represented by a slice) of a certain total that is represented on the overall
pie value. The pie chart is appropriate for visualizations such as Revenue
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Contribution by Product. In that example, the overall pie size would
represent the total revenue, and each slice would represent a different
product.

OHLC Chart and Candlestick Chart

28.8 Ij *
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The open-high-low-close and candlestick charts are primarily used to
display stock data. Each marker corresponds to the values, which are
represented as lines attached to the marker on the OHLC chart and as
colors on the candlestick chart. Open displays the opening price of the
stock. High displays the highest price the stock achieved on that day.
Low displays the lowest price the of the stock on that day. Close displays
the closing price of the stock.

Bar Chart and Column Chart

0 20 40 &0 20 120

A single- or multi-bar chart that shows and compares one or more items
over a period of time or in a specific range of values. You could, for
example, use a column chart in visualizations that contain the quarterly
headcount by region.

Stacked Column Chart and Stacked Bar Chart
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A chart that compares several variables over a period of time. Stacked
bars compare one or more variables, with each series adding to the total
value. This chart compares several variables over a period of time, for
example: Marketing Cost and Administrative Cost. Each one of the cost
components is presented in a different color and each bar represents a
different time period. The total bar size represents the Total Cost.

Combination Chart

120
a0

40

A combination column and line chart ideal for displaying a range of values
and a trend line for those values. You can use the combination chart in
visualizations examining stocks. A line series might show the historical
stock price over the year, and a column chart might show the volume of
trading for that stock.

Bubble Chart
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The bubble chart is one of the most powerful analytic tools available. It
lets you compare a group or series of items based on three different
parameters. It has an X-axis and Y-axis to represent the item location
over the chart area, and a Z value to represent the item size.

You could, for example, use this chart to represent the market composition
with the X-axis representing the ROI by industry type, the Y-axis
representing the Cash Flow, and the Z-axis representing the Market Value.

XY Chart
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A chart that displays data that encompasses two dimensions. The XY
chart shows each data point as a result of the intersection of X values
and Y values. You can, for example, use the XY chart in visualizations
that compare ROI (on the X axis) against Market Value (on the Y axis)
for a group of companies.

Area Chart
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A standard chart with vertical and horizontal axes. Each point along the
horizontal axis represents a data point. The actual values for each data
point are plotted against the vertical axis. For each series, colored areas
are created by connecting the plotted points against the horizontal axis.
Use this chart in visualizations that emphasize a trend line, such as Stock
Prices or Revenue History.

Stacked Area Chart

A standard chart with vertical and horizontal axes. Each point along the
horizontal axis represents a data point. The actual values for the data
points are plotted against the vertical axis, with each series adding to the
total value. You could use the stacked area chart to compare the revenue
for multiple products as well as the combined revenue of all the products
and the contribution of each product to the combined revenue.

Radar Chart and Filled Radar Chart
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A chart with axes that radiate outwards from the center of the chart. These
charts can have several axes. They are useful for plotting
multi-dimensional sets of data. In the filled radar chart, the shape created
by connecting the points along each axis is filled in with color. You could
use the radar charts to compare aspects of stocks. One axis could display
the price, another the volume, another the Price to Earnings ratio, and
any other relevant data.

* Tree Map

A chart that displays hierarchical data in a small area. Each data point is
represented by a rectangle. In Xcelsius 2008, the tree maps display two
parameters, represented by size and color intensity. Tree maps can be
used to compare two sets of data.

For example, a tree map could be used to represent the size and interest
rate of loans. You can set the size of the rectangle as the loan amount;
a large loan would be repesented by a larger rectangle. The color of the
rectangle would represent the interest rate; a higher interest rate would
be represented by a brighter color value.

How to configure a chart

Configuring a chart in Xcelsius 2008 is similar to creating a chart in Excel.
The minimum requirement is to have a list of values in a range of cells. After
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this, you can enhance your chart with some basic information such as Title,
Subtitle, Axis Titles and Series Names.

Example: Creating a visualization with a chart

For this example, you will need an Excel file that contains an adjacent range

of cells.
1. Open or create an Xcelsius 2008 file that includes the data you want to
use.
2. Place a column chart on the canvas.
3. Double-click the column chart component to open the Properties panel.
Here you can select the data sources and modify the chart's appearance.
Titles
Chart:
Column Chart 3]
Subtkitle:
Sample Sub Title 3]
Cateqary (X) Axis:
£
Value () Axis:
£
Secondary Value (Y] Axis:
4. Type the title of the chart in the Chart box.
Tip: You can also click the Chart cell selector button to select the chart
title from the spreadsheet.
5. Type the subtitle of the chart in the Subtitle box.
Tip: You can also click the Subtitle cell selector button to select the chart
subtitle from the spreadsheet.
6. Type the axis name in the Category (X) Axis box.

Tip: You can also click the Category (X) Axis cell selector button to select
the axis name from the spreadsheet.
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7. Type the axis name in the Value (Y) Axis box.

Tip: You can also click the Value (Y) Axis cell selector button to select
the axis name from the spreadsheet.

8. (Optional) Type the axis name in the Secondary Value (Y) Axis box.

Tip: You can also click the Secondary Value (X) Axis cell selector button
to select the axis name from the spreadsheet.

9. Click the Data by Range cell selector button and select the range of
values from the spreadsheet.

The data range is the list of values to be presented on the chart
component. Select the full range of values you want to display in the chart.

10. Select a radio button to indicate how your data is arranged: Data in Rows
or Data in Columns.

In some cases, you may want to create a multi-series chart. To do this, select
the By Series option and select one or more series. Each series is
represented by columns of the same color.

@ B Series

Plot Series On:

Cakegory Labels(x):

Once you have created your basic chart, you can enhance and customize
it. Refer to Chart Components Reference on page 259 for more information.
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User Guide Sample: Drill-Down Chart

This sample provides an example of the Drill Down capability that allows
charts to behave as selectors. This visualization displays a Pie Chart that
contains yearly sales for several branches. When a user clicks on a slice of
the Pie Chart, the monthly sales for that branch are displayed in a Column
Chart.

To open the User Guide Sample file:

1. Select File > Samples
2. Select the User Guide Samples category.
3. Select the file name in the Items section.

The Sample file will contain all components and the corresponding
spreadsheet data. To follow along with the step-by-step instructions, open
the Sampile file and then delete the components. These instructions will
produce a working visualization that will demonstrate the use of a component
or feature; additional settings, formats or components may have been added
to enhance the appearance of the sample visualization.

Note: The completed sample XLF file with embedded spreadsheet data and
SWEF file for this visualization can be located by navigating to the following
location:

C:\Program Files\Business Objects\Xcelsius\assets\samples\User Guide
Samples

1. Open or create an Xcelsius 2008 file that includes the data you want to
use.

For this example the spreadsheet should contain monthly sales data for
different branches.

2. Place a Pie Chart component on the canvas.

3. Place a Column Chart component on the canvas below the Pie Chart
component.

4. Double-click the Pie Chart component to open the Properties panel.

5. Click the Values cell selector button and select the data range from the
spreadsheet.
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For this example, select the cells that contain the Sales Totals for the
individual branches.

Click the Data in Columns radio button to indicate that the data is
organized in a column.
On the Drill Down tab, click Enable Drill-Down.

The Drill Down settings can now be configured.
On the Insertion Type list, click Rows.
This will let you insert a row of data into the Destination range.

Click the Source Data cell selector button and select the source data from
the spreadsheet.

For this example, the range of cells should contain the columns of monthly
sales data from January to December and the names of the branches.

Click the Destination cell selector button and select a range of cells from
an empty row of the spreadsheet.

This is the range of cells where the row of data (Branch name and sales
Jan-Dec) will be inserted.

Note: The cells must be empty or the drill down functionality will be
compromised.

Click the Column Chart component to open the Properties panel.

Click the Chart cell selector button and select the first cell of the
Destination range selected for the Pie Chart.

Click Data by Series; click the plus button to add a series to the list box.
Click the Values (Y) cell selector button and starting with the first cell to
the left of the cell selected in Step 12, select the remainder of the range
of empty cells you selected for the Destination range.

Click the Category Labels (X) cell selector button to select the cells in the
spreadsheet that contain the column headers, for this sample the months
of the year.

Click the Preview button to view the interaction between the Pie Chart
and Column Chart components.

As you click on slices of the Pie Chart, the column chart will update to
show the monthly sales data for the selected branch.
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User Guide Sample: Dual Axis Charts

Xcelsius 2008 now has the ability to plot series data on both a primary and
a secondary axis. This is available for the following charts: Line, Bar, Stacked
Bar, Column, Stacked Column, Area, Stacked Area, and Combination Chart.

To open the User Guide Sample file:

1. Select File > Samples
2. Select the User Guide Samples category.
3. Select the file name in the Items section.

The Sample file will contain all components and the corresponding
spreadsheet data. To follow along with the step-by-step instructions, open
the Sample file and then delete the components. These instructions will
produce a working visualization that will demonstrate the use of a component
or feature; additional settings, formats or components may have been added
to enhance the appearance of the sample visualization.

Note: The completed sample XLF file with embedded spreadsheet data and
SWEF file for this visualization can be located by navigating to the following
location:

C:\Program Files\Business Objects\Xcelsius\assets\samples\User Guide
Samples

1. Open or create an Xcelsius 2008 file that includes the data you want to
use

Place a Combination Chart component on the canvas. .

Double-click the Combination Chart to open the Properties panel.

In the Chart box, type "Stock Price vs. Volume".

In the Category (X) Axis box, type "Week Ending".

In the Value (Y) Axis box, type "Price".

Click Data by Series; click the plus button to add a series to the list box.
In the Name box, type "Closing Price".

Click the Values (Y) cell selector button and select the Source Data for
this series; for this sample, select the data under the column header
"Closing Price".

10. Under Plot Series On, click the Primary Axis radio button.

11. Click the plus button to add another series to the list box.

12. In the Name box, type "Volume".

OeNOGOR®WN
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Click the Values (Y) cell selector button and select the Source Data for
this series; for this sample, select the data under the column header
"Volume".

Under Plot Series On, click the Secondary Axis radio button.

Click the Category Labels (X) cell selector button and select the data
labels; for this sample select the data under the column header "Date".
Click the Appearance tab; click the Series sub-tab.

For the series "Closing Price", click the Type dropdown menu and select
Column.

For the series "Volume", click the Type dropdown menu and select Line.

Click Preview to view the Combination Chart component displaying two
series plotted on separate axis.

In this sample, the Combination Chart component has been configured to
display two disparate sets of data, each plotted on its own axis.

Using the Container components

This category contains a group of components that group and display other
components.

Note: These components are not available in Xcelsius Present.

For more information about Container components, see Container
Components Reference on page 281.

Panel Container

S

The Panel Container components act as smaller canvases within the
main canvas and hold one or more components. Components in the Panel
Container can be moved, added, changed or deleted. Click the plus sign
next to the Panel Container in the Object Browser to expand the list of
components within the Panel Container.

Tab Set
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The Tab Set component is similar to the Panel Container components.
The Tab Set acts as a smaller canvas within the main canvas. A Tab Set
contains multiple tab views; each can be displayed on the canvas by
clicking its corresponding tab. Tabs can be added or deleted from the
Tab Set by clicking on the gray plus and minus buttons displayed on the
top left corner. These buttons do not display when the visualization is run.

User Guide Sample: Panel Container

To open the User Guide Sample file:

1. Select File > Samples.
2. Select the User Guide Samples category.
3. Select the file name in the Items section.

The Sample file will contain all components and the corresponding
spreadsheet data. To follow along with the step-by-step instructions, open
the Sample file and then delete the components. These instructions will
produce a working visualization that will demonstrate the use of a component
or feature; additional settings, formats or components may have been added
to enhance the appearance of the sample visualization.

Note: The completed sample XLF file with embedded spreadsheet data and
SWEF file for this visualization can be located by navigating to the following
location:

C:\Program Files\Business Objects\Xcelsius\assets\samples\User Guide
Samples

1. Open or create an Xcelsius 2008 file that includes the data you want to
use.

2. Place a Panel Container on the canvas

3. Click the Panel Container, displaying the black sizing boxes. Increase
the size of the Panel Container by dragging the bottom corner sizing box.
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4. In the Components browser, select a Pie Chart component; drag the
pointer and release in the interior of the Panel Container. The Pie Chart
will now be inside the Panel Container.

5. In the Components browser, select a Label component; drag the pointer
and release in the interior of the Panel Container. The Label will now be
inside the Panel Container.

6. Inthe Objects Browser, click the plus sign to expand the Panel Container
tree. The Pie Chart and Label will be displayed as sub-components of
the Panel Container.

7. Select the Label, click Enter Text. Type or paste any block of text into the
box.

8. Click the Panel Container, displaying the black sizing boxes. Decrease
the size of the Panel Container so that only the Pie Chart is visible by
dragging the bottom corner sizing box.

9. Click Preview to view how the Panel Container displays components.

In this sample, the Panel Container has been sized smaller than its contents.
The Panel Container automatically adds horizontal and/or vertical scroll bars
as needed. If more components were added to the canvas of the visualization,
dynamic visibility functionality could be used to show or hide the entire Panel
Container and its contents, rather than applying the functionality to each
component individually.

User Guide Sample: Tab Set

The Tab Set component is similar to the Panel Container component. The
Tab Set acts as one or more smaller canvases within the main canvas. A
Tab Set contains multiple views organized in tabs; each view can be displayed
by clicking its corresponding tab. Each view can hold one or more
components and works similar to the Group function during design of the
visualization. Components in the Tab Set can be moved, added, changed
or deleted. In the Object Browser, click the plus sign next to the Tab Set
expand it; each tab view is represented as a Canvas which can also be
expanded to list the components it contains.

The number of tab views displayed by the Tab Set can be increased or
decreased by clicking a tab label. Gray plus and minus buttons will display
above the first tab. Clicking the plus button will open an Insert dialog box,
which prompts you to enter a Label for the new tab.
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Note: The plus and minus buttons do not display when the visualization is
run.

To open the User Guide Sample file:

1. Select File > Samples.

2. Select the User Guide Samples category.
3. Select the file name in the Items section.

The Sample file will contain all components and the corresponding
spreadsheet data. To follow along with the step-by-step instructions, open
the Sample file and then delete the components. These instructions will
produce a working visualization that will demonstrate the use of a component
or feature; additional settings, formats or components may have been added
to enhance the appearance of the sample visualization.

The completed sample XLF file with embedded spreadsheet data and SWF
file for this visualization can be located by navigating to the following location:

C:\Program Files\Business Objects\Xcelsius\assets\samples\User Guide
Samples

1. Open or create an Xcelsius 2008 file that includes the data you want to
use.

2. Place a Tab Set component on the canvas.

3. Double-click the interior of the Tab Set (canvas) to open the Properties
panel.

4. In the Label box, type "North America".

5. In the Components browser, select a Pie Chart component; drag the
pointer and release in the interior of the Tab Set. The Pie Chart will now
be inside the Tab Set.

6. Click the tab label; click the plus button to add a new tab.

7. At the prompt, enter "Latin America" for the tab Label; click OK to add
the new tab.

8. In the Components browser, select a Line Chart component; drag the
pointer and release in the interior of the Tab Set. The Line Chart will now
be inside the Tab Set.

9. Click the tab label; click the plus button to add a new tab.

10. At the prompt, enter "Europe" for the tab Label; click OK to add the new
tab.

11. In the Components browser, select a Column Chart component; drag the
pointer and release in the interior of the Tab Set. The Column Chart will
now be inside the Tab Set.
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12. Click the tab label; click the plus button to add a new tab.
13. Atthe prompt, enter "Asia" for the tab Label; click OK to add the new tab.
14. In the Components browser, select a Bar Chart component; drag the

pointer and release in the interior of the Tab Set. The Bar Chart will now
be inside the Tab Set.

15. Click the tab label; click the plus button to add a new tab.

16. At the prompt, enter "Australia & Pacific" for the tab Label; click OK to
add the new tab.

17. In the Components browser, select a Pie Chart component; drag the
pointer and release in the interior of the Tab Set. The Pie Chart will now
be inside the Tab Set.

18. Optional: Using the Objects Browser, navigate to the chart in each tab
and bind it to the spreadsheet data. For step-by-step chart configuration
instructions see User Guide Sample: Status List. For this sample exclude
configuration of the Status and Key for each chart.

19. Click Preview to view how the Tab Set displays components.

In this sample, the Tab Set has been configured to display five different
views, each with a unique component (and data set if configured). Click on
the tabs to navigate between the views.

Using the Selector components

The functionality of selector components lets you create a visualization with
multiple selections.

Note: [@| The Information button that appears on the Properties panel of
each selector component displays an animation that describes the
functionality of the selector component.

For more information about Selector components, see Overview on page 290.

Each selector can be combined with other components to create a dynamic
visualization:

* Accordion Menu
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The Accordion Menu is a two-level menu that lets users first select a
category and then select from items within that particular category.

Note: This component is not available in Xcelsius Present.

Check Box

A standard user-interface component where users toggle between two
states: checked and unchecked.

Combo Box

4BC B

A standard user-interface component that drops down a vertical list of
items when it is clicked. Users can then select an item from the list.

Filter

123 B B

The Filter component looks at a range of cells with multiple fields of data
and categorizes them by unique data entries. The Filter sifts through the
data range and inserts data corresponding to the drop down selections.

Fisheye Picture Menu
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With the Fisheye Picture Menu, users select from a set of pictures or
icons. As the mouse is moved over each item in the menu, the item is
magnified. The closer the mouse is to the center of the item, the more
the item is magnified. This creates an effect similar to that of a fish-eye
lens.

Sliding Picture Menu

~ T

With the Sliding Picture Menu, users select from a set of icons or pictures.
The users can use arrows to scroll through the icons or the menu can be
configured to scroll through the icons as the user moves the mouse.

Note: This component is not available in Xcelsius Present.

Icon

The Icon can be used as a selector or display component. As a selector,
it functions similar to the Check Box component. It can represent the
actual value contained in one cell and be compared to its target value in
another cell.

The Icon can also be set to change color depending on its value relative
to the target value, which is an Alert. See Alerts on page 154 for more
information. At the same time, you can use the Icon to activate and display
other components. See Dynamic Visibility functionality on page 148 for
more information.

Note: To configure the Icon as a display-only component, click the
Appearance tab and uncheck Show On/Off . The Icon will not be selectable
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* Label Based Menu

The Label Based Menu lets users select items from a vertical or horizontal
grouping of buttons.

* List Box
. B
A2 u
A3
Bl [v]

A standard user-interface component that lets users select items from a

vertical list.
+ List View
Mame Q1 )= Total
Company 1 1000 2000 3000
Company 2 1200 2200 2400
Company 3 1400 2400 2800
Company 4 1600 2600 4200
Company & 1800 2800 4600
|« ] N | [v

Note: This component is not available in Xcelsius Present.

The List View component has the same functionality as the table
component, but lets the user sort the columns and adjust the width of the
columns in the exported SWF file.

» List Builder
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source Destination

|

The List Builder provides a way for end-users to build their own set of
data. This data set can then be used to populate another component.

Note: This component is not available in Xcelsius Present.

Radio Button

0~
!

1C

The Radio Button component lets users select from a vertical or horizontal
group of selections.

Ticker

aAss T BBB T CCC - |

The Ticker component displays horizontally scrolling text in your
visualization. Scrolling stops when the user hovers the mouse over the
labels.

Note: This component is not available in Xcelsius Present.

Toggle Button
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Off

A standard user-interface component that lets users toggle between two
states: on and off.

Spreadsheet Table
A1 B1
# 210 of}
# 45 FL
# 23 MY
# 105 MD

The Spreadsheet Table component is a What You See Is What You Get
representation of any group of cells from your spreadsheet.

Note: The Spreadsheet Table component can be used as a display
component as well as a selector component. As a display component,
the Spreadsheet Table is a graphic representation of a range of cells in
the spreadsheet. To use the Spreadsheet Table as a display component,
click the Display Data cell selector button and select a range of cells to
display from the spreadsheet. Under the Behavior tab, click Deselect All.
The rows of the table will not be selectable. To use the spreadsheet table
as a selector component, after setting the Display Data range, set the
Insert Option to rows.

Play Selector

!'|'_|'|'|'|'|'|'|'|'i

M - [ 2 - H

The Play Selector sequentially inserts one row or column from a defined
range into the Destination cells you selected. You can link the Destination
cells to a chart so that the chart data changes each time the play selector
inserts a new row or column. The Play Selector component can display
a large amount of data with a movie effect which lets users view the data
without clicking on each selection.

Note: This component is not available in Xcelsius Present.
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User Guide Sample: Filter

The Filter component takes a range of data with fields that contain duplicate
data entries and filters each field into a Combo Box so that there are only
unique entries in each field. The Filter component can present a large amount
of data and can be used to create a selector with up to ten Combo Box fields.
When selections are made on the Filter component, the corresponding data
is inserted in the spreadsheet and can be used as source data for a chart
component.

In this sample, the quarterly Sales data is displayed. The data is organized
by Product, Sales Rep, and Account Type. Selecting an item from any of the
Combo Boxes will show the quarterly Sales data for the corresponding
combination of selections on the Bar Chart.

To open the User Guide Sample file:
1. Select File > Samples.

2. Select the User Guide Samples category.
3. Select the file name in the Items section.

The Sample file will contain all components and the corresponding
spreadsheet data. To follow along with the step-by-step instructions, open
the Sampile file and then delete the components. These instructions will
produce a working visualization that will demonstrate the use of a component
or feature; additional settings, formats or components may have been added
to enhance the appearance of the sample visualization.

The completed sample XLF file with embedded spreadsheet data and SWF
file for this visualization can be located by navigating to the following location:

C:\Program Files\Business Objects\Xcelsius\assets\samples\User Guide
Samples

1. Open or create an Xcelsius 2008 file that includes the data you want to
use.

2. Place a filter component on the canvas.
3. Double-click the filter component to open the Properties panel.

4. Click the Source Data cell selector button and select all the data to be
included in the visualization.
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For this sample, the data selection should include the fields used by the
filter as well as the corresponding data that will be displayed in the chart.

5. Click the Destination cell selector button and select an empty range of
cells in a row. The range must be large enough to display a full row of
chart data.

For this sample, select the range of cells adjacent to "Filter Destination".

Note: The cells must be empty or the inserted data may not function
properly.

6. Adjust the value in the Number of Filters box.

For this sample, set the number of filters to three: Product, Sales Rep,
and Account Type.

7. Click the Title cell selector button and select the labels that will appear
above each Combo Box.

For this sample, select the column headers of the fields to be filtered.

8. Place a Bar Chart component on the canvas.

Click Data by Series; click the plus button to add a series to the list box.

10. Click the Values (X) cell selector button and select the range of empty
cells you selected for the Destination range for the Filter component.

11. Click the Category Labels (Y) cell selector button to select the cells in the
spreadsheet that contain the chart data column headers; for this sample
the quarters of the year.

12. Click the Preview button to view the interaction between the Filter and
Bar Chart components.

©

The quarterly Sales data displayed in the Bar Chart will update depending
on the selections made in the Combo Boxes of the Filter Component.

User Guide Sample: List Builder

The List Builder provides a way for users to build their own sets of data. The
List Builder consists of a Source list containing all possible selections, a
Destination list containing the user's selections, and an Update button. Users
can move items between the Source and Destination lists in a number of
ways:
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» Double-clicking items in either the Source or Destination list to move the
item to the other list.

» Dragging items from one list to another.

+ Using the Add and Remove buttons.

When the Update button is pressed, the items in the Destination List are
inserted into the Destination range to be displayed by another component.
To change the order of selections in the Destination List, drag an item up or
down in the list.

In this sample, the user selects from a list of branches to see the yearly sales
data for those branches. The user builds a list of branches and then clicks
the Update button to see the selected data in a Column Chart.

To open the User Guide Sample file:

1. Select File > Samples.

2. Select the User Guide Samples category.
3. Select the file name in the Items section.

The Sample file will contain all components and the corresponding
spreadsheet data. To follow along with the step-by-step instructions, open
the Sample file and then delete the components. These instructions will
produce a working visualization that will demonstrate the use of a component
or feature; additional settings, formats, or components may have been added
to enhance the appearance of the sample visualization.

The completed sample XLF file with embedded spreadsheet data and SWF
file for this visualization can be located by navigating to the following location:

C:\Program Files\Business Objects\Xcelsius\assets\samples\User Guide
Samples

1. Open or create an Xcelsius 2008 file that includes the data you want to
use.

2. Place a List Builder component on the canvas.

3. Place a Line Chart component on the canvas below the List Builder
component.

4. Double-click the List Builder component to open the Properties panel.

5. Click the Labels cell selector button and select the Source List items from
the spreadsheet.

For this sample, select the list of branches.
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12.

13.

14.

. On the Insertion Type list, click Row.

This inserts a row of data corresponding to each item that is placed in
the Destination List.

Click the Source Data cell selector button and select the range of data
from the spreadsheet.

For this sample, the range of cells should contain the table of yearly sales
data for the branches.

Click the Destination cell selector button and select a range of empty
cells.

For the List Builder, the Destination range must be the same size as the
Source Data range you selected in the last step.

Note: The cells must be empty or the List Builder may not function
properly.

. Click the Column Chart component to open its Properties panel.
10.
1.

Click Data by Series; click the plus button to add a series to the list box.
Click the Values (Y) cell selector button and select the range of empty
cells you selected for the Destination range for the List Builder component.
Click the Category Labels (X) cell selector button to select the cells in the
spreadsheet that contain the chart data column headers, for this sample
the fiscal years.

On the Behavior tab, in the Ignore Blank Cells area, click In Series and
In Values.

Note: This ensures that the Column Chart only displays data for the items
that were selected in the Destination List of the List Builder.

Click the Preview button to view the interaction between the List Builder
and Column Chart components.

Move some of the branches from the Source List to the Destination List.
Click the Update button. The Column Chart will update to show the yearly
sales data for the selected Branches.
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User Guide Sample: Accordion Menu

The Accordion Menu component is a two-level menu that displays Categories,
and when clicked on the Categories expand to display a list of items to select
from. For this sample, the Accordion Menu displays Regions that when
clicked on show the names of Sales Reps; selecting a Sales Rep displays
their sales data for the year.

To open the User Guide Sample file:

1. Select File > Samples.

2. Select the User Guide Samples category.
3. Select the file name in the Items section.

The Sample file will contain all components and the corresponding
spreadsheet data. To follow along with the step-by-step instructions, open
the Sample file and then delete the components. These instructions will
produce a working visualization that will demonstrate the use of a component
or feature; additional settings, formats, or components may have been added
to enhance the appearance of the sample visualization.

The completed sample XLF file with embedded spreadsheet data and SWF
file for this visualization can be located by navigating to the following location:

C:\Program Files\Business Objects\Xcelsius\assets\samples\User Guide
Samples

1. Open or create an Xcelsius 2008 file that includes the data you want to
use.

Place an Accordion Menu component on the canvas.
Place a Column Chart component on the canvas.

Double-click the Accordion Menu component to open the Properties panel.

Select Category 1 in the list box; click the Name cell selector button and
select the first Category name.

ok © BN

In this sample, select the first region name.

6. Click the Labels cell selector button and select the items to be listed under
the first category.

For this sample, each region is a Category and the Labels for each region
are the names of the corresponding sales representatives.
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7.

14.

15.

16.

Click the Source Data cell selector button and select the data
corresponding to the Labels in the first Category.

For this sample, the range of cells should contain the sales data for the
sales representatives in the first region.

. Repeat steps 5-7 for each Category. In this sample, repeat the steps for

each region in the spreadsheet.

. Click the Insertion Type dropdown menu, then select Row.
10.
1.
12.
13.

Click the Destination cell selector button and select an empty row of cells.
Click the Column Chart component to open its Properties panel.

Click Data by Series; click the plus button to add a series to the list box.
Click the Values(Y) cell selector button and select the range of empty
cells you selected for the Destination range for the Accordion Menu
component.

Note: Do not include the first cell of the Destination range; this is where
the Sales Rep's name will be inserted. The Values (Y) range should only
include the cells that will contain sales data.

Click the Category Labels(X) cell selector button to select the cells in the
spreadsheet that contain the chart data column headers, for this sample
the months of the year.

Click the Chart cell selector button and select the first cell in the
Destination range selected for the Accordion Menu.

This cell will contain the name of the sales representative and will now
be displayed as the Column Chart title.

Click the Preview button to view the interaction between the Accordion
Menu and Column Chart components.

As you click on a region and select a sales representative, the chart will
display the monthly sales data for that sales representative.

User Guide Sample: Sliding Picture Menu

The Sliding Picture Menu component displays thumbnail images that when
selected insert data corresponding to the images that can be displayed by
another component. In this sample, the Sliding Picture Menu displays
thumbnail images of a company's products, clicking on a product image
displays sales data for that product in a Column Chart.
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To open the User Guide Sample file:

1. Select File > Samples.

2. Select the User Guide Samples category.
3. Select the file name in the Items section.

The Sample file will contain all components and the corresponding
spreadsheet data. To follow along with the step-by-step instructions, open
the Sample file and then delete the components. These instructions will
produce a working visualization that will demonstrate the use of a component
or feature; additional settings, formats, or components may have been added
to enhance the appearance of the sample visualization.

The completed sample XLF file with embedded spreadsheet data and SWF
file for this visualization can be located by navigating to the following location:

C:\Program Files\Business Objects\Xcelsius\assets\samples\User Guide
Samples

1. Open or create an Xcelsius 2008 file that includes the data you want to
use.

2. Place a Sliding Picture Menu component on the canvas.

3. Place a Column Chart on the canvas beneath the Sliding Picture Menu
component.

4. Double-click the sliding picture menu component to open the Properties
panel.

5. Click the Labels cell selector button and select the data to be displayed
as the image labels.

For this sample, select the names of the products.
6. Click the Embedded radio button, then click the Import button.
The Import Thumbnail dialog box appears.

7. Select the Click to Add Images button. Navigate to the first thumbnail
image and click OK. For this sample, image files have been provided in
the User Guide Samples file directory.

8. Repeat Step 7 until all images to be used have been added to the Import
Thumbnail dialog box.

9. On the Insertion Type list, select Row.

10. Click the Source Data cell selector button and select the range of cells
containing the source data.
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14.

15.

16.

17.

For this sample, the range of cells should contain the yearly sales data
for the products.

Click the Destination cell selector button and select an empty row of cells.
Click the Column Chart component to open its Properties panel.

Click Data by Series; click the plus button to add a series to the list box.
Click the Values(Y) cell selector button and select the range of empty

cells you selected for the Destination range for the Sliding Picture Menu
component.

Note: Do not include the first cell of the Destination range; this is where
the product name will be inserted. The Values(Y) range should only include
the cells that will contain sales data.

Click the Category Labels(X) cell selector button to select the cells in the
spreadsheet that contain the chart data column headers, for this sample
the fiscal years.

Click the Chart cell selector button and select the first cell in the
Destination range selected for the Accordion Menu.

This cell will contain the name of the product and will now be displayed
as the Column Chart title.

Click the Preview button to view the interaction between the Sliding Picture
Menu and Column Chart components.

As you click on the images in the Sliding Picture Menu, the Column Chart
displays the yearly sales data for that product.

User Guide Sample: Dynamic Selected Item

The Dynamic Selected Item functionality is available in list-based selectors.
The selector labels can be changed dynamically through another component
in the visualization.

To open the User Guide Sample file:

1.
2,
3.

Select File > Samples.
Select the User Guide Samples category.
Select the file name in the ltems section.
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The Sample file will contain all components and the corresponding
spreadsheet data. To follow along with the step-by-step instructions, open
the Sample file and then delete the components. These instructions will
produce a working visualization that will demonstrate the use of a component
or feature; additional settings, formats, or components may have been added
to enhance the appearance of the sample visualization.

The completed sample XLF file with embedded spreadsheet data and SWF
file for this visualization can be located by navigating to the following location:

C:\Program Files\Business Objects\Xcelsius\assets\samples\User Guide
Samples

1. Open or create an Xcelsius 2008 file that includes the data you want to
use.

2. Place a List Box component on the canvas.
Double-click the List Box to open the Properties panel.

4. Click the Labels cell selector button and select the labels for the selections
in the List Box.

5. From the Insertion Type dropdown menu, select Rows.

6. Click the Source Data cell selector button and select the data
corresponding to the Labels.

7. Click the Destination cell selector button and select a range of empty
cells.

8. Click the Behavior tab; in the Selected Item section, click the ltem cell
selector box and select a cell in the spreadsheet.

9. Place a Column Chart component on the canvas.
10. Click the Column Chart to open its Properties panel.
11. Click Data by Series; click the plus button to add a series to the list box.

12. Click the Values (Y) cell selector button and select the same range of
cells as the Source Data for the List Box component.

13. Click the Category Labels (X) cell selector button and select the column
headers of the Source Data range.

14. Place a Radio Button component on the canvas.
15. Click the Radio Button to open its Properties panel.

16. Click the Labels cell selector button and select the labels for the Radio
Button selections.

17. From the Insertion Type dropdown menu, select Label.

18. Click the Destination cell selector button and select the same cell selected
in step 8 as the Selected Item for the List Box.

(g
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19. Click Preview to view the interaction between the List Box, Radio Button,
and Column Chart components.

In this sample, the Radio Button selection affects the labels that are displayed
in the List Box. The List Box selection then updates the Column Chart display
data.

User Guide Sample: Filtered Rows

The Filtered Rows functionality is one of the methods available to configure
a selector component. The selector is associated with a range of data
organized in rows. Within that range of data there are labels that will be
displayed on the selector component. These labels may be duplicated and
associated with more than one data point or row of data. With Filtered Rows,
the selector filters the range of labels into unique data entries. When the
label is selected on the selector component, only the rows that correspond
with that label are inserted in the Destination range.

To open the User Guide Sample file:

1. Select File > Samples.

2. Select the User Guide Samples category.
3. Select the file name in the Items section.

The Sample file will contain all components and the corresponding
spreadsheet data. To follow along with the step-by-step instructions, open
the Sampile file and then delete the components. These instructions will
produce a working visualization that will demonstrate the use of a component
or feature; additional settings, formats, or components may have been added
to enhance the appearance of the sample visualization.

The completed sample XLF file with embedded spreadsheet data and SWF
file for this visualization can be located by navigating to the following location:

C:\Program Files\Business Objects\Xcelsius\assets\samples\User Guide
Samples

1. Open or create an Xcelsius 2008 file that includes the data you want to
use.

2. Place a Radio Button component on the canvas.
3. Double-click the Radio Button to open the Properties panel.
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4. Click the Labels cell selector button and select the labels for the radio
buttons; for this sample select all of the data under column header "ltem".

5. On the Insertion Type dropdown menu, select Filtered Rows.

6. Click the Source Data cell selector button and select the data
corresponding to the Labels.

For this sample select all of the data under column headers "Date of

Purchase", "Quantity" and "ltem".

7. Click the Destination cell selector button and select a range of empty
cells.

For this sample, select a range of cells large enough to contain all of the
Source Data.

8. Place a Column Chart component on the canvas.

Click the Column Chart to open its Properties panel.

10. In the Chart box, type "Purchases by Date".

11. In the Category (X) Axis box, type "Date".

12. In the Value (Y) Axis box, type "Quantity".

13. Click Data by Series; click the plus button to add a series to the list box.

14. Click the Values (Y) cell selector button and select the range of cells
where the data will be inserted; for this sample select the range where
the column "Quantity" will be inserted.

15. Click the Category Labels (X) cell selector button and select the range of
cells where the labels will be inserted; for this sample select the range
where the column "Date of Purchase" will be inserted.

16. Click Preview to view the interaction between the Radio Button and
Column Chart components.

©

In this sample, the Radio Button uses the Filtered Rows functionality and
takes a range of data with duplicate data entries and filters the data so that
there are only unique entries. Based on the user's selection, the Radio Button
locates all data points that correspond to the selected label. The data is then
inserted in a range of cells to be displayed in the Column Chart.

User Guide Sample: Tree Map

The Tree Map uses two parameters to create a color block for each Product.
The size of each color block represents its Price relative to all other prices.
The light or dark shade of each block represents is Market Share relative to
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the rest of the market. This graphic representation allows instant comparison
of multiple data points against each other in two parameters. If a data point
lies far outside the range of the data points it's being compared to, it might
show up as significantly larger/smaller or very bright/dark.

To open the User Guide Sample file:

1. Select File > Samples.
2. Select the User Guide Samples category.
3. Select the file name in the Items section.

The Sample file will contain all components and the corresponding
spreadsheet data. To follow along with the step-by-step instructions, open
the Sample file and then delete the components. These instructions will
produce a working visualization that will demonstrate the use of a component
or feature; additional settings, formats, or components may have been added
to enhance the appearance of the sample visualization.

The completed sample XLF file with embedded spreadsheet data and SWF
file for this visualization can be located by navigating to the following location:

C:\Program Files\Business Objects\Xcelsius\assets\samples\User Guide
Samples

1. Open or create an Xcelsius 2008 file that includes the data you want to
use.

Place a Tree Map component on the canvas
Double-click the Tree Map component to open Properties panel.
Click Data By Series; click the plus button to add a series to the list box.

Click the Display Labels cell selector button and select the Labels for the
items to be represented in the Tree Map.

a kb

For this sample, select the product names.

6. Click the Values (Size) cell selector button and select the data that will
determine the size of the blocks within the Tree Map.

For this sample, select the price data.

7. Click the Values (Color Intensity) cell selector button and select the data
that will determine the color intensity of the blocks within the Tree Map.

For this sample, select the market share data.

8. Click Preview to view how the Tree Map displays data.
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In this sample, if the user were looking for the weakest product in this group,
Product A would stand out because it is light colored, indicating small market
share, and is also the smallest block, indicating a low price. Conversely,
Product G is dark colored, indicating a large market share, and is also one
of the largest blocks, which indicates a higher price; the dark color and large
size make it stand out as a strong product.

Using the Single Value components

Single Value components let you add user interactivity to your visualizations.
Single Value means that the components are linked to a single cell in the
spreadsheet. When you run the visualization the component lets you modify
or represent the value of that cell.

For more information about Single Value components, see Single Value
Components Reference on page 315.

Input vs. output

Single Value components have been classified as both input and output
components, which means that you can use any Single Value component
as an input or output element in your visualization.

What dictates whether a Single Value component is an input (which permits
user interaction) or output, is the cell to which it is linked. If the cell contains
a formula of any type, the component is interpreted as an output. If the cell
does not contain a formula, it is represented as an input.

For example, if you have a Gauge linked to a cell that does not contain a
formula, you can modify the value by dragging the gauge needle, thereby
modifying the cell value. If you have a Gauge linked to a cell that does contain
a formula, you cannot modify the value.

Each component can be used to add interactivity to a visualization:

+ Dial
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An input component. A Dial represents a variable that can be modified
to affect other components. For example, to represent the Price per Unit.

Slider and Dual Slider

¥

An input component. A Slider represents a variable that can be modified
to affect other components. For example, to represent the Price per Unit.
The Dual Slider allows you to adjust both the minimum and maximum
values.

Progress Bar

|IIII|IIII|IIII|IIII|IIII|D
An output component. A Progress Bar represents a value that changes
and fills the progress bar area depending on its value.

Gauge

An output when bound to a cell containing a formula, or an input when
bound to a cell containing a value.

As an output, a Gauge represents a value that changes and moves the
needle. As an input, a Gauge represents a variable that can be modified
to affect other components. Users can interact with the Gauge by dragging
the needle to change the value.

Value
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An output when bound to a cell containing a formula, or an input when
bound to a cell containing a value.

As an output, a Value represents a value that changes. As an input, a
Value represents a variable that can be modified to affect other
components. Users can interact with the Value by typing in a new value.

*  Spinner
- B

An input component. A Spinner represents a variable that can be modified
to affect other components. Users can interact with the Spinner by clicking
the up and down arrows or by typing a value into the component.

» Play Control

F""I"_"I_""I'"'I""iIj
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An input component. Play Control is used to automatically increase the
value of a cell in your spreadsheet. For example, link the play button to
a cell that contains the headcount. What will happen if the headcount
increases by one, two, three, or more? Play Control takes the initial
headcount value and increases its value automatically by increments.

User Guide Sample: Value Display

The Value component can be used to display or adjust the numeric value of
cells. This visualization contains a Column Chart displaying revenues for five
(5) different stores. Adjusting the Value component will cause an increase
or a decrease in the revenue on the Column Chart.

In this sample, a store supervisor wants to measure the effect that increasing
or decreasing the price of a particular product has over the Revenue from
products normally sold over a period of time.
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* In this case, Price per Unit is the variable that we want to modify. This
cell affects the revenues for all stores.

* Quantity sold is the normal volume of products sold over a period of time.

* Revenues are calculated as Quantity multiplied by Price per Unit..

To open the User Guide Sample file:

1. Select File > Samples.
2. Select the User Guide Samples category.
3. Select the file name in the Items section.

The Sample file will contain all components and the corresponding
spreadsheet data. To follow along with the step-by-step instructions, open
the Sample file and then delete the components. These instructions will
produce a working visualization that will demonstrate the use of a component
or feature; additional settings, formats, or components may have been added
to enhance the appearance of the sample visualization.

The completed sample XLF file with embedded spreadsheet data and SWF
file for this visualization can be located by navigating to the following location:

C:\Program Files\Business Objects\Xcelsius\assets\samples\User Guide
Samples

1. Open or create an Xcelsius 2008 file that includes the data you want to

use.

Place a Column Chart component on the canvas.

Double click the Column Chart to open the Properties panel.

Click Data by Series; click the plus button to add a series to the list box.

Click the Values (Y) cell selector and select the data under Revenues.

Click the Category Labels (X) cell selector and select the Store Names.

Place a Value component on the canvas.

Click the Title cell selector button and select the cell containing "Price per

Unit".

9. Click the Data cell selector button and select the Price per Unit value cell
from the spreadsheet.

10. Click the Preview button to view the interaction between the Value and
Column Chart components.

OGN AN

You can increase or decrease the Price per Unit by clicking in the Value
component and dragging the pointer up or down. Double-click the Value
component to type in the Price per Unit. Because the Value component is
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linked to a cell that affects the Revenues, the chart dynamically changes
when the Price per Unit changes to reflect the new revenues by store.

Using the Map components

Map components create visualizations with geographical representations
that can display data by region.

The Map components have two major characteristics: they display data for
each region and each region can also act as a Selector. By combining these
two features, you can create a visualization where the data for each region
appears when you pass the pointer over the region. At the same time, each
region can insert a row of data that contains additional information. This row
of data is displayed by other components, such as a chart or value
components.

For more information about Map components, see Map Components
Reference on page 327.

How does it work?

Xcelsius 2008 associates data with each region in the map by using region
keys. Each region in the map has a default region key, and you can enter
your own region keys. When a region on the map is selected, the component
searches either the first column or first row of that range's key. The data in
the row or column corresponding with the key will be associated with the
region.

By default, the USA maps use postal abbreviations as region keys; the Europe
map uses the ISO (or International Organization for Standardization) two-digit
country codes as region keys. To use the map components with existing
spreadsheets, you can edit the region keys associated with each region by
clicking the Manual Edit button to type the new keys, or by clicking the Region
Key cell selector button to select the row or column containing the new keys
by editing the region names.

Note: In the spreadsheet you must enter the region keys and data in adjacent
cells for both Display Data and Source Data.

Tip: Xcelsius 2008 provides a spreadsheet that lists the default region codes
for each map component. The file is located in the following location:
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C:\Program Files\Business Objects\Xcelsius\assets\samples\User Guide
Samples

User Guide Sample: Map

In this sample, the USA map acts as a selector. The Map will display Revenue
data for the state when the pointer passes over or clicks on it. The historic
Revenue data of the selected state will be displayed on the Column Chart.

To open the User Guide Sample file:

1. Select File > Samples.
2. Select the User Guide Samples category.
3. Select the file name in the Items section.

The Sample file will contain all components and the corresponding
spreadsheet data. To follow along with the step-by-step instructions, open
the Sampile file and then delete the components. These instructions will
produce a working visualization that will demonstrate the use of a component
or feature; additional settings, formats, or components may have been added
to enhance the appearance of the sample visualization.

The completed sample XLF file with embedded spreadsheet data and SWF
file for this visualization can be located by navigating to the following location:

C:\Program Files\Business Objects\Xcelsius\assets\samples\User Guide
Samples

1. Open or create an Xcelsius 2008 file that includes the data you want to
use.

2. Place a Map component on the canvas, for this sample use the United
States by State Continental component.

3. Click the Region Keys Manual Edit button to verify that each state is linked
to the same state region key as in your spreadsheet.

The U.S. by State Continental component has region keys for the 48
continental states plus Washington D.C. in alphabetical order. Before
configuring the Map component, you must include the region keys for
each state that is identified in your spreadsheet. For example, the default
region key is AL for Alabama and CA for California. The Map identifies
data in the cell adjacent to the region key "AL" as being the data for
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Alabama, and the region key "CA" as being adjacent to the data for
California.

Click theDisplay Data cell selector button and select the cells containing
the state region keys and their corresponding data that will be displayed
on the Map, for this sample the most recent Revenue data.

Under Insertion Type, select Row.

Click the Source Data cell selector button and select the cells containing
State Keys and the data to be displayed in the chart based on the user's
selection, for this sample the historic revenue data.

Note: The Display Data range and the Source Data range each must
have region keys associated with the data points, thereby requiring two
sets of data ranges depending on your data structure.

Click the Destination cell selector button and select an empty range of
cells.

Note: The range of cells must be empty and large enough to
accommodate the region key and the historic revenue data for the state.
The Map component will insert the data into the selected range of cells.

Place a Column Chart component on the canvas.

Click the Chart cell selector button and select the first cell of the
Destination range selected for the Map component.

Click Data by Series; click the plus button to add a series to the list box.
Click the Values(Y) cell selector button and starting with the first cell to
the left of the cell selected in Step 9, select the remainder of the range
of empty cells you selected for the Destination range.

Click the Category Labels (X) cell selector button to select the cells in the
spreadsheet that contain the column headers of the Source Data, for this
sample the fiscal years.

Click the Preview button to view the interaction between the Map and
Column Chart components.

The historic revenue data in the Column Chart updates according to the
State selected by the user.
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Using the Text components

This category contains components for placing labels and typing text into
your visualization.

For more information about Text components, see Text Components
Reference on page 345.

Text components let you customize your visualization:
* Input Text Area

The Input Text Area lets users input multiple lines of text into the
visualization.

e Label

ABC

The Label component lets you add an unlimited amount of text to enhance
your visualizations. You can use the Label component to create titles,
subtitles, explanations, help, and more. Label text cannot be changed by
the user.

* Input Text

The Input Text component lets users input text into the visualization.

Using the Other components

This category contains an assorted set of components that you can use to
enhance your visualizations.
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For more information about Other components, see Other Components
Reference on page 369.

e Calendar

o 11 12 12 14 15
15 17 18 19 20 Z1 22
23 24 25 @I 27 28 29
afajsiietil

The Calendar component is a selector that lets you incorporate date
selection into your visualizations.

Note: This component is not available in Xcelsius Present.
* Local Scenario Buttons

Scenario

The Local Scenario Button lets users save and load runtime configurations
of an Xcelsius 2008 visualization on their local machine. Once saved,
these configurations or scenarios can be loaded again, even after closing
the visualization. These scenarios are saved to the local machine, and
will be unavailable if the visualization is opened on a different machine.

* Trend Icon

©

The Trend Icon changes its pointing direction, depending on the value of
the cell to which it is linked:

+ If the value is positive, the arrow points up.
+ If the value is zero, the symbol is neutral.

+ If the value is negative, the arrow points down.

» History
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The History component tracks and displays the history of changes in a
selected cell. This allows you to easily see the effect of changes in
worksheet data.

Note: This component is not available in Xcelsius Present.

Panel Set

Panel 1 =

0%

| A T

The Panel Set component is a series of framing options that enables you
to easily navigate between files in a presentation. You can embed JPEG
or SWF files into the frames of the Panel Set component and adjust a
variety of formatting features to customize the look of the component in
your visualization.

Note: This component is not available in Xcelsius Present.

Source Data

28

The Source Data component has no visual interface. It allows you to push
data into other cells simply by changing the value of the component's
Selected Index.

Note: This component is not available in Xcelsius Present.

Trend Analyzer
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The Trend Analyzer combines data analysis and visualization. The
component analyzes spreadsheet data and inserts data points for a trend
line into the spreadsheet, which can then be added to your visualization.

Note: This component is not available in Xcelsius Present.
Print Button

Print

The Print Button allows the user to easily print the visualization while it
is being run. The user can click the print button to print the SWF file. The
print button is part of the canvas and will be visible in the printout.

Reset Button
Reset

The Reset Button returns the visualization to its original state. Users can
interact with the components, then click the button to clear their changes.

Grid

The Grid component is a dynamic table that represents a group of rows
and columns of content. The Grid lets you show the data just as it is on
any table, or perform data modification that can impact other components.

The Grid component differs from the Spreadsheet and List View
components in that rather than being a static representation of the data
table, the user can click the cells of the Grid and type new values or drag
the values higher/lower

Note: This component is not available in Xcelsius Present.
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Using the Local scenario button component

The Local Scenario Button component lets users save the current state of
a visualization, making it well-suited for saving results of what-if analyses.

Users can save any number of these results or scenarios and load them at
any time, even after closing the visualization.

The scenarios created are specific to each visualization. As such, two
visualizations can have scenarios with the same names without interfering
with one another.

The visualization can be moved or renamed on the same computer and will
still be able to access its saved scenarios.

Scenarios saved in preview mode will not persist outside of the preview
session. This includes snapshots and exporting to PowerPoint or to Outlook.

Note: Local scenarios created on one computer will not be accessible to the
visualization if it has been emailed or moved to another computer.

How does the Local Scenario Button component work?

To enable users to save, load, and delete scenarios, add a Local Scenario
Button component to the visualization.

When running the visualization, users click the Local Scenario Button
component for the options Save, Load, and Delete.

After one of the three options is chosen, a dialog box appears, allowing the
user to complete the operation.

Flash Player settings

An unlimited number of scenarios can be saved in every visualization, so
long as enough local storage is allocated for the Flash Player. If a user
attempts to save a scenario and there is not enough local storage, the Flash
Player will prompt the user to allocate more. If more space is allocated, the
scenario will be saved successfully. If not, the scenario will not be saved.
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If a user attempts to save a scenario and local storage has been disabled,
the local scenario button component will ask the user to enable local storage
and automatically open the Flash Player settings. The scenario will not be
saved until the user enables local storage and then saves the scenario.

The Flash Player settings can be opened by right-clicking anywhere on the
Preview or exported visualization.

Note: Setting the Local Storage amount of the Flash Player below what is
currently used, or disabling local storage by checking the Never box will
erase all saved scenarios on the computer. This includes scenarios created
in all other visualizations. The Flash Player will warn the user before allowing
the scenarios to be erased.

Loading a saved scenario should restore the visualization to almost the same
state it was in when it was saved. There are a few exceptions, primarily
cosmetic changes, which don't directly affect the data visualization. The
states of external and nested SWF files are also not restored when a scenario
is loaded.

User Guide Sample: Calendar component

The Calendar component is a selector that lets you incorporate date selection
into your visualizations. This sample shows the daily sales for different
branches in a Bar Chart based on the date selected on the Calendar
component. The Calendar lets the user scroll through either any year and
month, or a fixed date range by setting a starting and ending year and month.
The Calendar has two Insertion Types: Date and Day. The Date function
inserts the selected date formatted in the Excel universal date format. The
Day function inserts the numeric value for the selected date (day, month,
and/or year).

To open the User Guide Sample file:

1. Select File > Samples.

2. Select the User Guide Samples category.
3. Select the file name in the Items section.

The Sample file will contain all components and the corresponding
spreadsheet data. To follow along with the step-by-step instructions, open
the Sample file and then delete the components. These instructions will
produce a working visualization that will demonstrate the use of a component
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or feature; additional settings, formats, or components may have been added
to enhance the appearance of the sample visualization.

The completed sample XLF file with embedded spreadsheet data and SWF
file for this visualization can be located by navigating to the following location:

C:\Program Files\Business Objects\Xcelsius\assets\samples\User Guide
Samples

1.

12.
13.

. Open or create an Xcelsius 2008 file that includes the data you want to

use.
Place a Calendar component on the canvas.

Place a Bar Chart component on the canvas below the Calendar
component.

Double-click the Calendar component to open the Properties panel.
Click the Insertion Type dropdown menu; select Date.

Click the Destination cell selector button and select an empty cell from
the spreadsheet.

Note: The cell must be empty or the functionality of the Calendar
component will be compromised.

On the Behavior tab, under Default Date, click Use Custom Date. For this
sample set the Day to 1, Month to 7 and the Year to 2007.

Check Enable Calendar Limits for the Calendar component. For this
sample, set the Start Month to 7, Start Year to 2007, End Month to 7 and
the End Year to 2007.

Click the Bar Chart component to open its Properties panel.

. Type in the Chart box or click the adjacent cell selector button and select

the title from the spreadsheet.
For this sample, use "Daily Sales by Branch".

Click the Subtitle cell selector button and select the subtitle from the
spreadsheet.

For this sample, choose the "Chart Subtitle" value cell which will update
based on the Calendar selection.

Click Data by Series; click the plus button to add a series to the list box.

Click the Values(X) cell selector button; for this sample select the row of
cells adjacent to "Chart Data Range".
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14. Click the Category Labels (Y) cell selector button to select the cells in the
spreadsheet that contain the column headers of the Source Data, for this
sample the branch names.

15. Click the Preview button to view the interaction between the Calendar
and Bar Chart components.

As you click on the dates in the Calendar component, the Bar Chart
component will display the daily sales data for all of the branches for that
date.

User Guide Sample: Grid

In some visualizations, you might want to complement the graphical display
of data with traditional tables that show the underlying data. One way to do
this is by using a Value component. For instances where you would need
multiple Value components, you can also use the Grid component. The Grid
component is a collection of N number of Value components that are linked
together. Each cell of the Grid component works in the same way as the
Value component.

The Grid component can be used as an input or output component. Each
cell of the Grid can be modified by clicking the value and dragging the value
higher or lower.

This sample shows Sales by Branch. Selecting a Branch from the List Box
will show the historical data for the selected Branch on the Column Chart.
The Grid displays the data that underlines the Column Chart. Adjusting the
data in the Grid will modify the data in the Column Chart.

To open the User Guide Sample file:

1. Select File > Samples.
2. Select the User Guide Samples category.
3. Select the file name in the Items section.

The Sample file will contain all components and the corresponding
spreadsheet data. To follow along with the step-by-step instructions, open
the Sampile file and then delete the components. These instructions will
produce a working visualization that will demonstrate the use of a component
or feature; additional settings, formats, or components may have been added
to enhance the appearance of the sample visualization.
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The completed sample XLF file with embedded spreadsheet data and SWF
file for this visualization can be located by navigating to the following location:

C:\Program Files\Business Objects\Xcelsius\assets\samples\User Guide
Samples

1.

10.

Open or create an Xcelsius 2008 file that includes the data you want to
use.

For this sample, open the User Guide Sample Listbox. This provides the
data and a visualization to add the Grid component to.

Expand the canvas by clicking the Fit Canvas to Window button on the
Standard toolbar.

Place a Grid component on the canvas.

Double-click the Grid component to open the Properties panel.

Click the Data cell selector button; select the range of cells adjacent to
"Insert In Row". This is where data used by the Column Chart is inserted.
Place a second Grid component on the canvas, above the first Grid.
Double-click the Grid component to open the Properties panel.

Click the Data cell selector button; select the column headers of the
Source Data, in this sample the fiscal years.

On the Behavior tab of the second Grid, clear the Enable Interaction check
box.

Note: This Grid is acting as a display with text values, therefore users
should not be able to interact with the values.

Click the Preview button to view the interaction between the Grid and
Column Chart components.

As you click the values in the Grid and drag the pointer up or down, the
values displayed in the Column Chart will be increased or decreased.

User Guide Sample: History

The History component is linked to a data point, and then records the value
of that point every time it changes. It can also be configured to record the
value at a set time interval.

To open the User Guide Sample file:

1.

Select File > Samples.
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2. Select the User Guide Samples category.
3. Select the file name in the Items section.

The Sample file will contain all components and the corresponding
spreadsheet data. To follow along with the step-by-step instructions, open
the Sample file and then delete the components. These instructions will
produce a working visualization that will demonstrate the use of a component
or feature; additional settings, formats, or components may have been added
to enhance the appearance of the sample visualization.

The completed sample XLF file with embedded spreadsheet data and SWF
file for this visualization can be located by navigating to the following location:

C:\Program Files\Business Objects\Xcelsius\assets\samples\User Guide
Samples

1. Open or create an Xcelsius 2008 file that includes the data you want to
use.

Place a Play Selector component on the canvas.

Double-click the Play Selector to open the Properties panel.

Click the Insertion Type dropdown menu; select Row.

Click the Source Data cell selector button and select the source data.

aprobN

For this sample, select the data in the Values column.

6. Click the Destination cell selector button and select an empty cell. For
this sample, select the top left-most cell.
7. Click the Behavior tab. In the Interaction Options section, check all Auto
options.
8. Place a History component on the canvas.
Click the History component to open its Properties panel.
10. Click the Data cell selector button and select the same cell as the
Destination cell for the Play Selector.
11. Click the Data Destination cell selector button and select an empty range
of cells.

©

Note: The size of this cell range will be the maximum number of historical
changes recorded.

12. Click the When Value Changes radio button.
13. Place a Line Chart component on the canvas.
14. Click the Line Chart to open its Properties panel.
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15. Click Data by Range; click the cell selector button and select the same
range of cells as the Data Destination range for the History component.

16. Click the Data in Columns radio button.

17. Click Preview to view the interaction between the History component and
the Play Selector and Line Chart components.

In this sample, the Play Selector has a fixed series of data points. The selector
inserts each point in sequence into a cell of the spreadsheet. The History

component records the value in this cell each time it changes. The Line Chart
then displays the history of changes as recorded by the History component.

User Guide Sample: Reset Button

The Reset Button component can be added to a visualization to allow users
to reset all components to the values displayed when the visualization was
loaded. This sample has three Sliders that affect the value displayed. By
clicking the Reset Button the Sliders and Value component are reverted to
their original values.

To open the User Guide Sample file:

1. Select File > Samples.
2. Select the User Guide Samples category.
3. Select the file name in the Items section.

The Sample file will contain all components and the corresponding
spreadsheet data. To follow along with the step-by-step instructions, open
the Sample file and then delete the components. These instructions will
produce a working visualization that will demonstrate the use of a component
or feature; additional settings, formats, or components may have been added
to enhance the appearance of the sample visualization.

The completed sample XLF file with embedded spreadsheet data and SWF
file for this visualization can be located by navigating to the following location:

C:\Program Files\Business Objects\Xcelsius\assets\samples\User Guide
Samples

1. Open or create an Xcelsius 2008 file that includes the data you want to
use.

2. Place a Horizontal Slider component on the canvas.
3. Double-click the Horizontal Slider to open the Properties panel.

126  Xcelsius 2008 User Guide



Using Xcelsius 2008 Components
Using the Other components

6

4. Click the Title cell selector button and select the title for the Slider; for
this sample, select "Cost per ltem".

5. Click the Data cell selector button and select the data for the Slider; for
this sample, select the "Cost per Item" value.

Repeat steps 3-5, using "Quantity Sold".
Repeat steps 3-5, using "Sales Price".
Place a Value component on the canvas.
Click the Value to open its Properties panel.

. Click the Title cell selector button and select the title; for this sample select
"Net Profit".

11. Click the Data cell selector button and select the data for "Net Profit".
12. Place a Reset Button component on the canvas.

13. Click Preview to view the interaction between the Slider and Value
components, and how the Reset Button affects that interaction.

©©x®NO

-—

In this sample, the Slider components adjust the value displayed by the Value
component. Clicking the Reset Button clears any adjustments made to the
Sliders and reverts the Value component to its original number.

User Guide Sample: Trend Analyzer

The Trend Analyzer combines data analysis and visualization. The component
analyzes the data selection and provides an additional data series that can
be plotted to display a trend line. The Trend Analyzer does not display in the
visualization.

To open the User Guide Sample file:

1. Select File > Samples.

2. Select the User Guide Samples category.
3. Select the file name in the Items section.

The Sample file will contain all components and the corresponding
spreadsheet data. To follow along with the step-by-step instructions, open
the Sampile file and then delete the components. These instructions will
produce a working visualization that will demonstrate the use of a component
or feature; additional settings, formats, or components may have been added
to enhance the appearance of the sample visualization.
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The completed sample XLF file with embedded spreadsheet data and SWF
file for this visualization can be located by navigating to the following location:

C:\Program Files\Business Objects\Xcelsius\assets\samples\User Guide
Samples

1.

NooaprwODd

©

1.

12.
13.
14.
15.
16.
17.

18.
19.

20.

Open or create an Xcelsius 2008 file that includes the data you want to
use.

Place a Combination Chart component on the canvas.

Double-click the Combination Chart to open the Properties panel.

In the Chart box, type "Stock Price Trend Analysis".

Click Data by Series; click the plus button to add a series to the list box.
In the Name box, type "Price".

Click the Values (Y) cell selector button and select the Source Data for
this series; for this sample, select the data under the column header
"Price".

Click the plus button to add another series to the list box.

In the Name box, type "Trend".

. Click the Values (Y) cell selector button and select the Source Data for

this series; for this sample, select the empty cells under the column header
"Analyzed Trend Data".

Click the Category Labels (X) cell selector button and select the data
labels; for this sample select the data under the column header "Date".
Click the Appearance tab; click the Series sub-tab.

For the series "Price," click the Type dropdown menu and select Column.
For the series "Trend," click the Type dropdown menu and select Line.
Place a Trend Analyzer component on the canvas.

Click the Trend Analyzer to open its Properties panel.

Click the Data cell selector button and select the data to be analyzed for
trending; for this sample, select the data under the column header "Price".
In the Trend/Regression Type section, click the Use Best Fit radio button.
Click the Analyzed Data Destination cell selector button and select an
empty range of cells for the new data series to be inserted into; for this
sample, select the empty cells under the column header "Analyzed Trend
Data".

Click Preview to view the between the Combination Chart component
displayed with a trend line.

In this sample, the Trend Analyzer component analyzes the selected data
and determines a the best way to display a trend line for the data.
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Using the Art and Background
components

Art and backgrounds can be used to enhance your visualizations. The
background components can be used to import images or Flash movies into
your Xcelsius 2008 visualization.

For more information about Art and Background components, see Art and
Background Components Reference on page 337.

Art and background components can be used to customize visualizations:
* Background

Backgrounds are prebuilt artwork that you can add to your visualizations
to assist layout and improve design. Backgrounds can be used to create
divisions and designate groups of related components.

» Image Component

0%

The image component can be used to display JPEG images or SWF files.
You can add your own logos or artwork into an Xcelsius 2008 visualization.
You can also add videos, animations, and other interactive elements by
importing a Flash file.

* Rectangle

A rectangle that you can add to your visualizations to outline, define, or
contain sections.

» Ellipse
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O

An ellipse or circular shape that you can add to your visualizations to
outline, define, or contain sections.

* Line

A vertical or horizontal line that you can add to your visualizations to
outline, define, or contain sections.

How to use the Image component

Use the Image component to display JPEG images. This allows you to add
your own logos or artwork to an Xcelsius 2008 visualization.

Note: Progressive JPEGs and JPEGs with CMYK coloring, as opposed to
the standard RGB coloring, are not supported.

You can also add videos, animations, and other interactive elements by
importing a Flash files. Since Xcelsius 2008 visualizations are Flash files,
you can use this feature to add an exported Xcelsius 2008 visualization into
another Xcelsius 2008 visualization.

Note: Flash Player versions 9 and later have new security features which
may prevent your Xcelsius 2008 visualization from connecting with an external
data source. Without a policy file, SWF files from one domain cannot access
data on another domain or sub-domain. In addition, SWF files served over
HTTP cannot access data at a HTTPS location. Please refer to the online
article from Adobe regarding security restrictions for data loading for
information on creating a policy file to allow access to data in the cases
above.

Embedding external files

When importing external files into the Image components, you may choose
whether or not to embed the file. If you do so, it will become a part of the
SWEF file that is created when the visualization is exported.
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If you choose not to embed the file, at runtime the file will be loaded into the
exported visualization as needed. When the visualization is exported, all of
the non-embedded external files used in the visualization are written out to
a folder with the same name and location as the exported visualization. The
visualization will load the external files from this folder. The visualization and
folder must exist in the same directory for the external files to be loaded
correctly.

The decision to embed the file will depend on your specific needs.

The main advantages for embedding files are as follows:
+  Embedded files let you distribute your entire visualization in a single file.
» Dynamic Visibility is faster as reloading is not necessary.

+  Embedded files maintain their state when hidden with Dynamic Visibility.

The main advantages for not embedding files as follows:

» Possible runtime performance increases since the external files are
unloaded when they are hidden with Dynamic Visibility.

» Shorter load times for the application since external files are loaded only
when necessary.

» The visualization does not need to be re-exported if external file changes.

Regardless of which option you choose, Xcelsius 2008 stores a local copy
of the file internally in the XLF file. The original file is no longer accessed or
used in the visualization. An XLF file with embedded content can be moved
or emailed and the contents of the file will travel with it. XLF files with
non-embedded content will need to be updated if external files are moved
or the XLF is moved. These XLF files must be emailed or moved with the
folder Xcelsius 2008 created with the same name.

In certain cases, you may not want to use local copies of images, but rather
load an image from a specified URL at runtime.

Nested external files

Xcelsius 2008 lets you use external SWF files in your visualizations. These
SWEF files may, in turn, have external assets such as other SWF files, images,
or XML files. The external assets used by the SWF that are referenced with
relative paths must be available from the location of the host visualization.
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For example, if you have a SWF file located at z:\file.swf, which loads an

external image at z:\images\mylmage.jpg, and you use the SWF file within
your visualization at c:\visualization.xIf, the SWF file will attempt to load an
image at c:\images\mylmage.jpg, which is the location of the visualization.

In the following example, you can insert a corporate logo into your
visualization.

To create an Xcelsius 2008 visualization with an image component

1.

o9k, owbd

Place an Image component on the canvas.

Double-click the image component to open the Properties panel.
Click Import.

Navigate to and select the JPEG or SWF file.

Click Open.

Select Embed File to have a copy of the image stored in the visualization.
Your logo is imported into the visualization at its default size. You can
now place and resize the image.

Tip: Click Resize Image to Component to prevent the image from loading
and automatically changing the size of the component.

Using the Web Connectivity components

This category contains a group of components that provides options for
linking your visualizations to the Web.

For more information about Web Connectivity components, see Web
Connectivity Components Reference on page 355.

URL Link Button

UEL

A button that links to a relative or absolute URL when pressed.

Slide Show
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The Slide Show component creates a slide show of URL-based images
and SWEF files.

Unlike the normal Image Component, which requires that you first Import
the file, the Slide Show component loads the image at the URL specified
in the URL data source.

Note: When an image is imported into normal Image Components,
Xcelsius 2008 stores its own local copy of the file internally in the XLF
file. The original file is no longer accessed or used in the visualization.
Because the file data is stored within the XLF, the XLF can be moved or
emailed and the contents of the file travels with it. The Slide Show points
to a URL, however, which can change at runtime. This means that the
image does not travel with the XLF. Therefore the image must be available
to the SWF at runtime.

Note: Whenever the Slide Show URL changes, it attempts to load in the
image at that location. Once it has loaded the image, it will transition from
the current image to the new one specified at the URL data source.

Note: Flash Player versions 9 and later have new security features which
may prevent your Xcelsius 2008 visualization from connecting with an
external data source. Without a policy file, SWF files from one domain
cannot access data on another domain or sub-domain. In addition, SWF
files served over HTTP cannot access data at a HTTPS location. Please
refer to the online article from Adobe regarding security restrictions for
data loading for information on creating a policy file to allow access to
data in the cases above.

Note: This component is not available in Xcelsius Present.
Connection Refresh Button
Refresh

A button that manually refreshes the connection it is linked to.

Note: This component is not available in Xcelsius Present.
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For more about this component, please see User Guide Sample:
Connection Refresh Button — XML Data Connection on page 173.

* Reporting Services Button
Reporting Services

The Reporting Services Button component enables you to connect to the
XRS server and select the report that will be used to populate the
visualization.

Note: This component is only available in Xcelsius Engage Server and
BusinessObjects Xcelsius Enterprise.
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Exporting Xcelsius 2008 Visualizations

Overview

Overview

This section provides information on exporting your Xcelsius 2008
visualizations. All versions of Xcelsius 2008 provide the following export
options:

+  PowerPoint
- PDF

*  Outlook

* Word

* Acrobat 9

* Adobe AIR

In addition to the above, Xcelsius Engage versions also have the following
options:

* Adobe Flash (SWF)
+ HTML

In addition to all of the above options, BusinessObjects Xcelsius Enterprise
also has the following option:
»  Export to Business Objects Platform

This option provides the ability to export to either BusinessObjects
Enterprise or Crystal Reports Server.

Exporting your visualization to
PowerPoint

Once your visualization is complete, you can export it as a PowerPoint slide.
You can then modify the slide using Microsoft PowerPoint.

To export an Xcelsius 2008 visualization to
PowerPoint

1. Create an Xcelsius 2008 visualization.
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2. Select File>Export, then select PowerPoint Slide, or click the Export to
PowerPoint button % in the toolbar.

The Save As dialog box appears.

3. Enter a name for the PPT file, and click Save.

Xcelsius 2008 generates the PowerPoint (PPT) file and a SWF file with the
same name. The generated PowerPoint file is automatically opened and the
visualization will be visible on the first slide of the presentation. When the
presentation is run, the visualization is dynamic and interactive.

Note: When the visualization is exported, any external files are placed in a
folder with the same name and location as the exported visualization. The
external files must remain in the same folder as the visualization for the
visualization to work properly.

Exporting your visualization to Adobe
PDF

Once your visualization is complete, you can export your content as an
Adobe® Portable Document Format (PDF) file. The PDF file can be viewed
locally, opened in a browser, or deployed on a web site. The visualization is
embedded in the PDF and is dynamic and interactive.

Xcelsius 2008 now supports Acrobat 9. You can save your PDF files to be
compatible with either Acrobat 6 (and later verions) or Acrobat 9.

To export an Xcelsius 2008 visualization to Adobe
PDF

1. Create an Xcelsius 2008 visualization.

2. Select File> Export, then select PDF, or click the Export to PDF button
2 in the toolbar.
Note: Clicking the Export to PDF button automatically embeds the SWF
file into an Acrobat PDF file. In Xcelsius Present, the default PDF version

is Acrobat 9 (PDF 1.8); in Xcelsius Engage versions, the default PDF
version is Acrobat 6 (PDF 1.5).
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If you selected, File > Export, the Save As dialog box appears.

3. Select the PDF version (Acrobat 6 for PDF 1.5, or Acrobat 9 for PDF 1.8)
you would like your files to be compatible with.

Note: Acrobat 9 will require users to have the latest version of Acrobat
Reader installed in order to view the visualization.

4. Enter a name for the PDF file, and click Save.

Xcelsius 2008 generates the Adobe PDF file. The generated PDF file is
automatically opened and the visualization is visible on the first page of the
document. The visualization in the PDF file is dynamic and interactive.

Note: When the visualization is exported, any external files are placed in a
folder with the same name and location as the exported visualization. The
external files must remain in the same folder as the visualization for the
visualization to work properly.

Emailing your visualization with Outlook

Once your visualization is complete, you can export it using Microsoft Outlook.

To email an Xcelsius 2008 visualization with Outlook

1. Create an Xcelsius 2008 visualization.

2. Select File >Export, then select Outlook, or click the Export to Outlook
button % in the toolbar.

Xcelsius 2008 generates a SWF file. Outlook launches a new email message

window and the SWF file is attached to a new email. You can then customize
and send the email.

Exporting your visualization to Word

When your visualization is complete, you can export it to a Microsoft Word
document. The visualization in the Microsoft Word document is dynamic and
interactive.
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To export an Xcelsius 2008 visualization to Word

1. Create an Xcelsius 2008 visualization.
2. Select File >Export, then select Word, or click the Export to Word button
%! in the toolbar.

The Save As dialog box appears.

3. Enter a name for the Word document, and click Save.

Xcelsius 2008 generates a Word document and embeds a SWF of your
visualization in the document.

Note: If your visualization in Word is static, on the Microsoft Word Control

toolbar click the Exit Design Mode button .

Exporting your visualization to Flash

Once your visualization is complete, you can export your content as an Adobe
Flash (SWF) file. The SWF file can be executed locally with the standalone
Flash player, opened in a browser, used as part of a web site, or imported
into a number of different programs.

Note: This export option is only available in Xcelsius Engage versions.

To export an Xcelsius 2008 visualization to Flash

1. Create an Xcelsius 2008 visualization.
2. Select File > Export, then select Flash (SWF).

The Export dialog box appears.

3. Enter a name for the SWF file, and click Save.

Xcelsius 2008 generates the Adobe Flash file.

Note: If there are any non-embedded external files in the visualization, a
folder containing those files is also generated with the same name and
location as the exported file. The visualization loads the external files from
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this directory at runtime. The visualization and folder must exist in the same
directory for the external files to be loaded correctly.

Exporting your visualization to HTTML

Not all computers are configured to open Flash files in the browser. By
embedding your SWF visualization in an HTML file, you ensure that your
users can view the visualization simply by double-clicking one file. The
generated HTML document references your SWF visualization.

Note: This export option is only available in Xcelsius Engage versions.

To export an Xcelsius 2008 visualization to HTML

1. Create an Xcelsius 2008 visualization.
2. Select File > Export, then select HTML.

The Save as HTML dialog box appears.

3. Enter a name for the HTML file, and click Save.

Xcelsius 2008 generates the HTML file and a SWF file with the same name,
and saves them in the selected directory. These files must be kept together
in order for the HTML file to work properly.

Exporting your visualization to an
Enterprise folder

When your visualization is complete, you can export it to a folder in
BusinessObjects Platform or Crystal Reports Server.

Note: This export option is only available in BusinessObjects Xcelsius
Enterprise versions.
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To export an Xcelsius 2008 visualization to an
Enterprise folder

1. Create an Xcelsius 2008 visualization.
2. Select File >Export, then select Business Objects Platform, or click
the Export to Business Objects Platform button 1 in the toolbar.

The Log On to BusinessObjects Enterprise dialog box appears.

3. Enter your logon information.

+ Inthe System field, type the name of the Central Management Console
(CMC) that you want to export the SWF file to.

The CMC stores information about the objects saved to the Enterprise
system. For more information about the CMC , refer to the
BusinessObjects Enterprise or Crystal Reports Server guides.

* In the User name and Password fields, type your logon credentials.

* From the Authentication list, select the authentication type.

If you are unsure of your logon information, contact your system
administrator.

4. Click OK.

The Save As dialog box appears and displays the folder structure of the
Enterprise repository.

5. Select the folder that you want to export the SWF file to, enter a file name,
and click Save.

The SWEF file is exported to the Enterprise repository.

Exporting your visualization to Adobe

AIR

Once your visualization is complete, you can export your content as an Adobe
Integrated Runtime (AIR) desktop application. The visualization is exported
as a browserless runtime for rich internet applications (RIAs) that can be
deployed onto the desktop across multiple operating systems.
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Requirements for exporting to Adobe AIR

Xcelsius requires Adobe Flex 3.0 SDK in order to export visualizations to
Adobe AIR. To install the requirement:

1. Download Adobe Flex 3.0 SDK:
http://www.adobe.com/cfusion/entitlement/index.cfm?e=flex3email

2. Unzip Adobe Flex 3.0 SDK in the folder under c:\Program
Files\Adobe\Flex Builder 3 Plug-in\sdks\3.0"

Note: You can change the folder location in file [Xcelsius’s Installa
tion Path]\Xcelsius\assets\air\sdkPath.dat after Xcelsius install.

3. Download Java 2 Runtime Environment (J2RE 1.4 or higher).

Requirements for running exported AIR files

To run the exported AIR file, you will need to download and install the AIR
player.

http://get.adobe.com/air/

To Export your visualization to Adobe AIR
1. Create an Xcelsius 2008 visualization.

2. Select File > Export, then select AIR.
The AIR — Export Settings dialog box appears.
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AIR - Application & Installer Settings ?_

Application Information

* Mame: | Unkitled |

#10: | com.air.Flash.Unt * Yersion:

Description:

Copyright (Mac Only): | |

wWindow Skyle: |System Chrame b |

Window Size: [ | Use custom size

&00 {width) (height)

Application Icons (PRG Only)

16 16 & |
32 % 32 | E|
48 % 46; | E|
128x128:| E|

Application Installer Settings

* Destination : | C:\Program Files\Business Objectst¥celsiusi\Untitled. air E |

* Indicates required fields [ Export l [ el l

Enter the Application Information:

*  Name. Enter the name for the application that will appear on the
installation screen. The default value is the current document name.

+ ID. Enter a unique ID that will identify the application. The default value
is “com.air.flash.[ DOCUMENT_NAME]".
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Version Enter a version number for the application. The default value
is “1.0”.

Description. Enter a description of the application The description will
appear on the installation screen.

Copyright. Enter the copyright information for the application. This
information will appear on the installation screen.

Note: Copyright information will only appear for users installing the
application on a Macintosh system. Copyright information will not
appear when installing on a Windows system.

Window Style. Select the Window Style from the drop-down menu.
The default selection is “System Chrome”.

Window Size. Specify the size of the window when the application is
run. The default value is the current document size.

. Select the image files to be used as application icons.

Note: AIR only supports PNG files for application icon images.

Taking a Snapshot of your visualization

In Preview mode, you can interact with the visualization just the same as an
end user will. If you find a scenario or combination of settings while in Preview
mode, you can take a snapshot of the visualization.

To access the Snapshot tool, select File > Snapshot, then select one of the
following export methods:

Current Excel Data
An Excel spreadsheet (XLS) with the current data values is generated.

Tip: This can be a useful tool for diagnosing dashboards that are not
performing as desired.

PDF

An Adobe PDF file with the current state of the components is generated.

PowerPoint Slide

144  Xcelsius 2008 User Guide



Exporting Xcelsius 2008 Visualizations
Taking a Snapshot of your visualization

7

A Microsoft PowerPoint file with one slide that contains a Flash (SWF)
file with the current state of the components is generated.

*  Outlook

A Microsoft Outlook email that attaches the Flash (SWF) file with the
current state of the components is generated.

The following Snapshot export options are only available in Xcelsius Engage
versions:

- Flash (SWF)

A Flash (SWF) file with the changes made in preview mode is generated.
« HTML

An HTML file and a Flash (SWF) file with the current state of the
components is generated.
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Using Advanced Features

Overview

Overview

This section provides an introduction to the more advanced functionality that
can be used to customize Xcelsius 2008 visualizations.

Dynamic Visibility functionality

For information on the specific dynamic visibility options, see Dynamic
Visibility on page 251.

You can show or hide components in your visualization with dynamic visibility.
For example, you can add a Toggle Button to display a specific chart. The
Toggle Button can be configured to toggle between inserting showChart and
hideChart into a Destination cell when it is selected. By linking the Chart's
status to this Destination cell and setting the Chart's Key to showChart, the
Chart becomes visible when the Toggle Button inserts the value showChart
and hidden when the Toggle Button inserts hideChart.

You may want to switch between a number of components. To accomplish
this, use the Key and a Selector. For example, a visualization might need to
toggle between different charts. To achieve this, give each chart a unique
Key, such as chart1 or chart2. Link each Chart's Status to the same cell in
the spreadsheet. Add a List Box with Source Data that matches the Chart
Keys. As the List Box value is inserted into the Status cell, the corresponding
chart is made visible, while the others are hidden.

User Guide Sample: Dynamic Visibility

Dynamic Visibility allows users to control the visibility of components in a
visualization. In this sample, the Check Box is used to toggle the visibility of
the Line Chart. Clicking the Check Box inserts a certain value into a cell. The
Dynamic Visibility Status of the Line Chart is also linked to this cell. The Line
Chart will appear or disappear depending on whether the value in the Status
cell matches its Dynamic Visibility Key.

To open the User Guide Sample file:
1. Select File > Samples.
2. Select the User Guide Samples category.
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3. Select the file name in the Items section.

The Sample file will contain all components and the corresponding
spreadsheet data. To follow along with the step-by-step instructions, open
the Sample file and then delete the components. These instructions will
produce a working visualization that will demonstrate the use of a component
or feature; additional settings, formats, or components may have been added
to enhance the appearance of the sample visualization.

The completed sample XLF file with embedded spreadsheet data and SWF
file for this visualization can be located by navigating to the following location:

C:\Program Files\Business Objects\Xcelsius\assets\samples\User Guide
Samples

1. Open or create an Xcelsius 2008 file that includes the data you want to
use.

Place a Check Box component on the canvas.
Place a Column Chart component on the canvas.
Double-click the Check Box component to open the Properties panel.

Click the Source Data Manual Edit button and set the values to be inserted
when the Check Box is checked and unchecked. Click OK.

apkwNbN

For this sample, use the default values of 0 for Unchecked and 1 for
Checked.

6. Click the Destination cell selector button and select an empty cell from
the spreadsheet.

7. Click the Column Chart to open its Properties panel.
Click Data by Series; click the plus button to add a series to the list box.

9. Click the Name cell selector button and select the name of the first series.
For this sample, select "Market Growth."

10. Click the Values(Y) cell selector button and select the data for the first
series.

11. Repeat Steps 8-10 for the second series "Sales Growth."

12. Click the Category Labels (X) cell selector button to select the cells in the
spreadsheet that contain the column headers, for this sample the years.

13. On the Behavior tab, click the Dynamic Visibility Status cell selector button
and select the Destination cell for the Check Box.

14. Set the Dynamic Visibility Key value to match the Source Data of the
Check Box component. For this sample, use the default value of 1.

15. Click Preview to view the interaction between the Check Box and Line
Chart components.

g
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16. Click the Check Box to display the Line Chart, and un-check to hide the
Line Chart.

Note: By default, the Check Box status is unchecked. Therefore, when you
Preview the visualization, the chart will not be initially visible. Users must
click on the Check Box to enable the chart's visibility. This can be changed
by modifying the Line Chart's Dynamic Visibility Key value, or by changing
the Selected Item to Checked on the Behavior tab of the Check Box
component.

User Guide Sample: Status List

Selector components can be configured to insert different forms of data in
the spreadsheet. This sample provides an example of the Insertion Type:
Status List in conjunction with the Dynamic Visibility functionality. The
visualization has different charts displaying the revenue of the selected
region. Selecting the radio button for a region will display the corresponding
chart.

The Insertion Type: Status List functions so that when a selection is made
on the selector component a value of 1 is entered in the cell of the Destination
range corresponding to that selection, and a value of 0 is entered in all other
cells in the Destination range. For example, if the second of three options is
selected, the values 0, 1, 0 will be inserted into the Destination range.

To open the User Guide Sample file:

1. Select File > Samples.
2. Select the User Guide Samples category.
3. Select the file name in the Items section.

The Sample file will contain all components and the corresponding
spreadsheet data. To follow along with the below step-by-step instructions,
open the Sample file and then delete the components. These instructions
will produce a working visualization that will demonstrate the use of a
component or feature; additional settings, formats or components may have
been added to enhance the appearance of the sample visualization.

Note: The completed sample XLF file with embedded spreadsheet data, and
SWEF file, for this visualization can be located by navigating to the following
location:
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C:\Program Files\Business Objects\Xcelsius\assets\samples\User Guide

Samples

1.

g

10.

1.

12.

13.
14.

15.
16.

17.

18.

Open or create an Xcelsius 2008 file that includes the data you want to
use.

Place a Radio Button component on the left side of the canvas.
Double-click the Radio Button component to open the Properties panel.
Click the Labels cell selector button and select the cells containing the
labels for the buttons from the spreadsheet. For this sample, the cells
should contain the region names.

On the Insertion Type list, click Status List.

Click the Destination cell selector button and select an empty column of
cells. For Status List, the Destination range must have the same number
of cells as the number of Labels. For this example, the range of cells must
have five cells, one for each of the region names.

. Place the following charts on the canvas, placing them on top of each

other: Pie Chart, Line Chart, Column Chart, Bar Chart, Pie Chart

Using the Object Browser, click on the first Pie Chart to open its Properties
panel.

Click the Data Values cell selector button and select the data for the North
America region. Click the Data by Rows radio button. Type the region
name in the Chart box.

Click the Labels cell selector button and select the column headers of the
source data. For this sample, select the product names.

Repeat steps 8-10 for the second pie chart, using the Australia & Pacific
region.

Using the Object Browser, click on the Line Chart to open its Properties
panel.

Click Data by Series; click the plus button to add a series to the list box.
Click the Values(Y) cell selector button and select the data for the Latin
America region.

Type the region name in the Chart box.

Repeat steps 12-15 for the Column and Bar Charts, using the Europe
and Asia regions.

Using the Object Browser, click the first Pie Chart used for the North
America region.

On the Behavior tab, click the Dynamic Visibility Status cell selector button
and select the first cell of the Destination range for the Radio Button. For
this sample, North America is the first Label on the Radio Button; therefore
the North America chart's visibility will correspond to the first cell.
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19. Set the Dynamic Visibility Key to 1.

20. Repeat steps 17-19 for the other charts and their corresponding regions.
Link the Latin America chart's Status cell to the second cell of the
Destination range, and so on according to the spreadsheet order.

21. Click Preview to view the interaction between the Radio Button and Chart
components.

When a region is selected on the Radio Button component, a value (in this
sample Status List was selected, so the value equals 1) is inserted in the
spreadsheet in the cell of the Destination range that corresponds to that
region's position in the list of regions. All of the other Destination range cells
have the value zero (0). The visibility of all the charts is also linked to the
Destination range. Each chart has been configured to be visible only when
its corresponding cell has the value 1 inserted. Since only one cell in the
range has the value 1 at any given time, only one chart at a time is visible.

Ignore End Blanks for variable length
ranges

Series: Ignore End Blanks

Select the Series: Ignore End Blanks option to prevent all of the empty series
past the last non-empty series from being displayed in the Chart. This option
is useful when you need to display a variable number of series in your Chart.

For example, you may want to create a model in which users select a region
and then see statistics for every store within that region all in one chart. Each
series in the Chart would represent one store within the region, and the
values of the series would represent the different statistics for that store.
Since each region may have a different number of stores, Series: Ignore End
Blanks could be enabled so that the number of series displayed in the Chart
could vary to match the number of stores within each region.

For this example:

1. Link the Chart to a range with the same number of series as the maximum
number of stores within any region.
2. Configure your model so that when a user selects a region:
+ the store statistics for all of the stores within that region are inserted
into the beginning of the Chart Data range.
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+ the rest of the series ranges are filled with empty values.
3. Enable Series: Ignore End Blanks on the Chart.

This feature allows just one Chart to display all of the store statistics for every
region.

Note: Although the Chart may not be displaying all of the data within the
Data range, the performance of the model will be affected by the actual size
of the range.

Values: Ignore End Blanks

Select the Values: Ignore End Blanks option to prevent all of the empty values
past the last non-empty value from being displayed in the Chart. This option
is useful when you need to display a variable amount of data in your Chart.

For example, you may want to create a model in which users select a region
and then see the total sales for every store within that region in a chart. Each
value within the Chart would represent the total sales of one store. Since
each region may have a different number of stores, Values: Ignore End
Blanks could be enabled so that the number of values displayed in the Chart
could vary to match the number of stores within each region.

For this example:

1. Link the Chart to a range with the same number of values as the maximum
number of stores within any region.
2. Configure your model such that when a user selects a region:
+ the sales figures for the stores within that region are inserted into the
beginning of the Chart Data range.
» the rest of the Chart Data range is filled with empty values.

3. Enable Values: Ignore End Blanks on the Chart.

This feature allows just one Chart to display all of the sales figures for every
region.

Note: Although the Chart may not be displaying all of the data within the Data
range, the performance of the model will be affected by the actual size of
the range.
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Alerts

For information on Alert tab settings, see Alerts Tab on page 253.

Alerts are commonly used to call the attention of the user to a specific item
or action that has reached some pre-established limits. These limits are often
called targets, budgets, benchmarks, etc. and are a standard to which an
item is compared. In all mature Business Intelligence applications, you will
find the capability to trigger alerts when some conditions are not met. Xcelsius
2008 has one of the most advanced and user friendly Alert methods available.
Its flexibility, use, and application is covered in this section.

Xcelsius 2008 lets you define alerts on most charts and single-value
components. When alerts are enabled on these components, the component
will represent the current level of the alert by displaying the specific color
that corresponds to that level.

How to Use Alerts

Using simple and easy-to-understand methods, you can configure and
customize the Alert levels, colors, methods, etc.

On the Properties panel, select the Alerts Tab. This tab is available for most
Charts and Single Value components. Some Selector components have
Alerts functionality as well.

Note: Alerts can be enabled in Chart components with only a single series.

User Guide Sample: Alerts - Selectors

Alerts can now be added to the following selector components: Label Based
Menu, Combo Box, List Box, List Builder, and Ticker.

To open the User Guide Sample file:

1. Select File > Samples.
2. Select the User Guide Samples category.
3. Select the file name in the Items section.

The Sample file will contain all components and the corresponding
spreadsheet data. To follow along with the step-by-step instructions, open
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the Sample file and then delete the components. These instructions will
produce a working visualization that will demonstrate the use of a component
or feature; additional settings, formats, or components may have been added
to enhance the appearance of the sample visualization.

The completed sample XLF file with embedded spreadsheet data and SWF
file for this visualization can be located by navigating to the following location:

C:\Program Files\Business Objects\Xcelsius\assets\samples\User Guide
Samples

1. Open or create an Xcelsius 2008 file that includes the data you want to
use.

2. Place a Label Based Menu component on the canvas.
Double-click the Label Based Menu to open the Properties panel.

4. Click the Labels cell selector button and select the labels for the selections
in the menu; for this sample select the product names.

5. On the Insertion Type dropdown menu, select Rows.

6. Click the Source Data cell selector button and select the data
corresponding to the Labels.

7. Click the Destination cell selector button and select a range of empty
cells.

8. Click the Alerts tab; check Enable Alerts.
9. Click the Alert Values cell selector button and select the range of cells
with alert values; for this sample select the "Average Sales" data.
10. Click the By Value radio button.
11. In the Color Order section, click the High Values are Good radio button.
12. Place a Column Chart component on the canvas.
13. Click the Column Chart to open its Properties panel.
14. Click Data by Series; click the plus button to add a series to the list box.
15. Click the Values (Y) cell selector button and select the same range of
cells as the Source Data for the Label Based Menu component.
16. Click the Category Labels (X) cell selector button and select the column
headers of the Source Data range.
17. Click Preview to view the interaction between the Label Based Menu and
Column Chart components.

(g

In this sample, the Label Based Menu can alert the user to values in the
Column Chart that may require closer attention.
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User Guide Sample: Alerts - Single Value

This sample provides a demonstration of the alert functionality applied to the
Gauge component. The alert levels show the Actual Values vs. the Target
Values for the accounts Revenues, Inventory, and the Cost of Goods Sold.
Using the Slider component, the Actual Values can be adjusted up or down
which will trigger different alert level displays.

To open the User Guide Sample file:

1. Select File > Samples.
2. Select the User Guide Samples category.
3. Select the file name in the Items section.

The Sample file will contain all components and the corresponding
spreadsheet data. To follow along with the step-by-step instructions, open
the Sampile file and then delete the components. These instructions will
produce a working visualization that will demonstrate the use of a component
or feature; additional settings, formats, or components may have been added
to enhance the appearance of the sample visualization.

The completed sample XLF file with embedded spreadsheet data and SWF
file for this visualization can be located by navigating to the following location:

C:\Program Files\Business Objects\Xcelsius\assets\samples\User Guide
Samples

1. Open or create an Xcelsius file that contains the data you would like to
use.

2. Place a Gauge component on the right of the canvas.

Double-click the Gauge component to open the Properties panel.

4. Click the Title cell selector button and select the cell containing the title
for the Gauge component. For this sample, use the value "Sales".

5. Click the Data cell selector button and select the Actual Value for Sales.

6. Inthe Scale section, click Manual. Set the Minimum and Maximum Limits
to 99 and 500 respectively.

7. On the Alerts tab, click Enable Alerts.

8. Click As Percent of Target, click the cell selector and select the Target
value for Sales.

9. In the Color Order section, click High Values are Good.

(d
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In the Alert Location section, check both Background and Marker.
Place a Horizontal Slider component under the Gauge.

Click the Slider to open its Properties panel.

Click the Data cell selector button and select the Actual Value for Sales.
In the Scale section, click Manual. Set the Minimum and Maximum Limits
to 99 and 500 respectively.

Repeat steps 2-14, customizing the second Gauge and Slider components
to display the "Inventories" data. For both components, set the Scale
Minimum and Maximum limits to zero (0) and 108 respectively. For the
Gauge, in the Color Order section, click Middle Values are Good.
Repeat steps 2-14, customizing the third Gauge and Slider components
to display the "Cost of Goods Sold" data. For both components: set the
Scale Minimum and Maximum limits to zero (0) and 440 respectively. For
the Gauge: in the Color Order section, click Low Values are Good.

Click the Preview button to view the interaction between the Gauge and
Slider components.

Dragging the Slider adjusts the Actual Value of each account. The affect on
the alert display of increasing or decreasing the Actual Value varies based

on whether it should be higher or lower than the Target Value. Sales values
should be high, while the Cost of Goods Sold should be low, and Inventory
amounts should be as close as possible to its Target.

Creating templates

Xcelsius 2008 offers a set of templates you can use to create a new
visualization. You can also create a visualization from scratch and save it
as a template.

To open a template, on the File menu, click Templates. A list of available
Categories is available. Each Category contains a group of templates that
are displayed under the ltems section. As you select each template in the
list, a preview of the template is shown on the right side of the screen. You
can click on the selectors to see the intended functionality of the components.
Select a template from the list and click OK.

When selected, the template is inserted on the canvas as a new visualization.
You can now add, delete or modify the template, and save it as a new
visualization or as a modified or new template.
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Note: Templates are not bound to any data. They demonstrate assorted
layouts and combinations of components.

Custom-made templates

You can create your own templates. For example, if you are creating a set
of Portlets for use in your corporate portal, you may want to save your
visualizations as templates so that you can re-use them when updates are
necessary.

To create a new template

1.
2,

No ok

Create the Xcelsius 2008 visualization you want to save as a template.
On the File menu, click Save As.

The Save As dialog box appears.

Navigate to:

C:\Program Files\Business Objects\Xcelsius 2008\assets\tem
plate

Note: To create a new Category, create a new folder under the \template
directory of the Xcelsius 2008 installation.

Enter a file name for the template, and click Save.

On the File menu, point to Export, and click Flash (SWF).
Navigate to the templates folder.

Enter the same file name for the SWF file that you entered for the
template, and click Save to export the visualization.

Note: Exporting the Flash (SWF) creates the template preview that will
be displayed in the Preview section of the Templates window.

The visualization is now available as a template. The next time you open the
templates window, your template will be available for preview and use.
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Using the Add-on Manager

This feature allows you to install or remove add-ons from within the Xcelsius
application. In addition, you can view the details of any add-ons you have

installed.
Xcelsius Add-On Manager fgl
Add-0n Details:

Mane:
Publishe !
Wehbsite:
Fublish Drate:

\ersion:

=
=
=

License Agreement:

Description

Get More Add-Ons

To Install an Add-on
1. Select File > Manage Add-Ons from the main toolbar.

2. Click the Install Add-On button.

To Remove an Add-on
1. Select File > Manage Add-Ons from the main toolbar.

The Add-on Manager will display the current add-ons in the left panel.

2. Select the Add-on you want to delete and click the Remove Add-On
button.
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To View the Details of an Add-on
1. Select File > Manage Add-Ons from the main toolbar.

The Add-on Manager will display the current add-ons in the left panel.

2. Select the Add-on you want to view.

The details of the Add-on are displayed in the Add-on Details panel.
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Using Advanced Features in Xcelsius Engage
Using the Data Manager

Using the Data Manager

The Data Manager is a central place to configure and manage external
connections in your visualization.

You can configure the following types of connections:

New Connections
*  Query as a Web Service (QaaWs)

Note: This connection type is only available in BusinessObjects Xcelsius
Enterprise.

*  Web Service Connections

+ XML Data Connections

* FlashVariable (flashvars)

» Portal Data

» Crystal Report Data Consumer

+ FS Command

» LiveCycle Data Services (LCDS)
+ External Interface

Existing Connections

*  Excel XML Maps
« Live Office connections

Note: This connection type is only available in BusinessObjects Xcelsius
Enterprise.

The Data Manager can be used to add several types of XML-compliant data
connections to your visualization. The Data Manager will also detect any
existing connection types when a visualization is opened. Some connection
types are not available to add as a new connection, but are supported only
as existing connections in data sources created outside of Xcelsius 2008.
These connection types are listed in the Add menu under Existing: Excel
XML Maps and Live Office Connections.
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To add a connection

1. Select Data > Connections, or click the Manage Connections button in
the toolbar. 4

The Data Manager dialog box appears.

Data Manager x
x|
Add - |

+ + s

2. Click the Add button and select a connection type from the list.

3. Configure the connection. See Configuring Connections with the Data
Manager on page 164 for more information.

To remove a connection
1. Select Data > Connections, or click the Manage Connection button on

the toolbar i'J .
The Data Manager dialog box appears.
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Add -|
w  Connechion 1 / — ]
—él Query as aWeb Sesvice Defirition ~
Column Headers:
Ciata:
Dierscripbicn: =
+ 4 )q < >

2. Select the connection you want ro remove and click the Delete button
X at the bottom of the connections list.

Configuring Connections with the Data Manager

This section discusses configuring data connections with the Data Manager.
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Configuring QaaWS connections

Definition Usage

Mame: Connection &

WSDL LRL: w Impaort

Method: W

Web Service URL: E

Input Yalues Qukput Yalues

Read From: Insert In:

Add or edit the following connection parameters for Querying as a Web
Service (QaaWs) Connections:

Note: This Data Connection is only available in BusinessObjects Xcelsius
Enterprise.

Definition Tab
* Name

Type a name for the connection.
- WSDL URL

Type the URL for the WSDL that you would like to bind the connection
to, or select one from the drop-down menu.

* Import

Click on the Import button to bind the connection to the WSDL that was
entered into the WSDL URL text box.
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Method

Select the method that you would like to bind the Query as a Web Service
Connection.

Web Service URL
Type the URL for the Web Service, or select a cell from the spreadsheet.
Input Values

Select a node from the tree to bind the node to the spreadsheet. Selecting
a node enables the Input Value selection icons.

Read From

Select a cell in the spreadsheet that will provide data for the Query as a
Web Service Connection to read from.

Output Values

Select a node from the tree to bind the node to the spreadsheet. Selecting
a node enables the Output Value selection icon.

Insert In

Select a destination cell for the Output Values.
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Usage Tab

See Usage Tab on page 201 for Data Manager Usage Tab options.

Configuring Web Service Connections

Definition Usage
Mame: Connection 9
WSDL LRL: w Import
Method: W
Web Service URL: E
Input Yalues Qukput Yalues
Read From: X Insert In:

Add or edit the following connection parameters for Web Service Connections:

Definition Tab

Name
Type a name for the connection.
WSDL URL

Type the URL for the WSDL that you would like to bind the connection
to, or select from the dropdown.

Import button

Click on the Import button to bind the connection to the WSDL that was
entered into the WSDL URL text box.

Method
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Select the method that you would like to bind the Web Service Connection
to.

*  Web Service URL field

Enter the URL for the Web Service, or click the cell selector to select a
cell in the spreadsheet.

* Input Values

Select a node from the tree to bind the node to the spreadsheet. Selecting
a node enables the Input Value selection icon.

 Read From

Select a cell in the spreadsheet that will provide data for the Web Service
Connection to read from.

*  Output Values

Select a node from the tree to bind the node to the spreadsheet. Selecting
a node enables the Output Value selection icon.

* InsertIn

Select a destination cell for the output values.

Usage Tab
See Usage Tab on page 201 for Data Manager Usage Tab options.

Advanced Tab

If your Web Service Connection requires information to be passed in the
SOAP Header, enter your information in HTML format into the text field, or
click the cell selector button to select a cell in the spreadsheet.
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Using the Data Manager
& Data Manager, [g |
( #dd ~]
Connection 1 e
—% 'wieb Service Connection Definition Usage Advanced
SOAP Header:

Copy and paste vour SOAP header information into the text field or bind the header to the
spreadsheet.

Close

Note: When using the cell selector button, the <soap:Header> HTML tags
will be automatically added to the text values contained in the cell. For
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example, the selected cell would only need to contain
“<username>joe</username> <password>1234</password>".

Configuring the XML Data Connection

Definition Ilsage
Mame: Connection 10
#ML Daka URL: IE.!
MIME Type: applicationx-www-form-urlencoded .

[ Enable Send [ Enable Load

| Import Mamed Ranges |

With the XML Data Connection, you can refresh visualization data from an
external source through HTTP. The connection can be used to send live
visualization data to an external source; for example, form submission and

data collection.

The data can be refreshed and sent periodically and automatically or on
demand when combined with the Connection Refresh Button component.

Note: Flash Player versions 9 and later have new security features which
may prevent your Xcelsius 2008 visualization from connecting with an external
data source. Without a policy file, SWF files from one domain cannot access
data on another domain or sub-domain. In addition, SWF files served over
HTTP cannot access data at a HTTPS location. Please refer to the online
article from Adobe regarding security restrictions for data loading for
information on creating a policy file to allow access to data in the cases

above.
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The XML Data connection lets you use send and load functionality
simultaneously through one URL. The send ranges are sent to the URL prior
to retrieving the load data. This lets you create scripts which examine the
sent data and return data that corresponds to the values sent —much like a
web request. For example, if a date was sent to a server script, the script
could return the sales figures for that date.

Excel ranges are mapped to XML using a row-column structure. For example,
a one-row, three-column range named "ExampleRange" would be represented
in XML with:

<variable name="ExampleRange">
<row>
<column> Rowl Columnl value </column>
<column> Rowl Column2 value </column>
<column> Rowl Column3 value </column>
</row>
</variable>

where "Row1 Column1 value" would be the actual value of the cell in the
first row and first column of the range, and so on.

The entire group of ranges is encapsulated within <data> tags.

During a load, XML is translated into Excel ranges using the reverse process.

Configuring XML Data Connections

Add or edit the following connection parameters for XML Data Connections:

Definition Tab
* Name

Enter a name for the connection.

+ XML Data URL

Type the URL for the button or use the Cell Selector button to select a
cell in the embedded spreadsheet. Any change to the value of this cell
will update the URL button with the link to the new value

Note that http:// is required for hyperlinks.
*  MIME Type

Select the MIME Type from the drop-down menu.
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* Enable Load

Select this check box to load the XML data at the URL into the Load
Ranges when the connection is triggered.

List Box

Select a range in the list box to edit the cell selection for that range.
Add

Use the Add button to add a new range.

Remove

Use the Remove button [ to delete the highlighted range from the
list.

Name

Type a name for the selected range, or use the cell selector button to
link to a cell in the spreadsheet.

Range
Use the Range cell selector to select the cells from the spreadsheet.
Preview XML button

Use the Preview XML button to see the structure of the XML that your
visualization needs to receive data from the external data source.

Import Named Ranges

Use this button to import named ranges from the spreadsheet.

+ Enable Send

Select this check box to send the XML data to the URL from the Send
Ranges when the button is triggered. Edit the ranges that are translated
to XML and sent to the URL. The translated ranges are sent via HTTP
using the POST method.

List Box

Select a range in the list box to edit the cell selection for that range.

Add
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Use the Add button to add a new range.

* Remove

Use the Remove button [ to delete the highlighted range from the
list.

« Name

Type a name for the selected range, or use the cell selector button to
link to a cell in the spreadsheet.

* Range
Use the Range cell selector to select the cells from the spreadsheet.
*  Preview XML button

Use the Preview XML button to see the structure of the XML that your
visualization needs to send data to the external data source.

Usage Tab
See Usage Tab on page 201 for Data Manager Usage Tab options.
User Guide Sample: Connection Refresh Button — XML Data Connection

This sample demonstrates a simple XML Data connection that is triggered
by clicking a Connection Refresh Button. This sample also includes the Reset
Button to clear the data retrieved, so that the connection can be refreshed.

To open the User Guide Sample file:

1. Select File > Samples.
2. Select the User Guide Samples category.
3. Select the file name in the Items section.

The Sample file will contain all components and the corresponding
spreadsheet data. To follow along with the step-by-step instructions, open
the Sample file and then delete the components. These instructions will
produce a working visualization that will demonstrate the use of a component
or feature; additional settings, formats, or components may have been added
to enhance the appearance of the sample visualization.
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The completed sample XLF file with embedded spreadsheet data and SWF
file for this visualization can be located by navigating to the following location:

C:\Program Files\Business Objects\Xcelsius\assets\samples\User Guide
Samples

1.

12.

13.
14.
15.
16.

17.
18.

Open or create an Xcelsius 2008 file that includes the data you want to
use.

Open the Data Manager and add an XML Data Connection.

Enter the URL where the XML file is hosted. For this sample, use this
URL:

http://www.businessobjects.com/ipl/default.asp?destination=Xcelsius
Marketplace

In the MIME Type dropdown menu, select application/x-www-form-urlen
coded.

Check Enable Load.

Click the plus button to add a range.

Click the Range cell selector button and select a range of empty cells
from the spreadsheet. For this sample, select the cells beneath column
headers "Company" and "Quantity".

. Place a Bar Chart component on the canvas.

. Double-click the Bar Chart to open the Properties panel.
10.
1.

Click Data by Series; click the plus button to add a series to the list box.

Click the Values (X) cell selector button and select the data to be
displayed. For this sample, select the cells beneath column header
"Quantity".

Click the Category Labels (Y) cell selector button to select the cells in the
spreadsheet that contain the labels; for this sample the cells under column
header "Company".

Place a Connection Refresh Button component on the canvas.
Click the Connection Refresh Button to open its Properties panel.
In the Label box, type "Get Data".

In the Available Connections box, check the box next to the XML Data
connection. This will enable the button to refresh the selected connection.

Place a Reset Button component on the canvas.

Click Preview to view the interaction between the Connection Refresh
Button and Bar Chart components.
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In this sample, the Bar Chart is populated with the data retrieved by the "Get
Data" button (Connection Refresh Button). The Reset Button can be clicked
to clear the data populating the Bar Chart.

User Guide Sample: XML Data (Advanced)

A polling application utilizes both send and load functionality. Votes must be
sent to the server to be tallied and total results must be loaded from the
server. There are five parts to such a procedure:

* Part 1: To configure the XML Data Connection on page 176
Specify the server script that will communicate with the component.

* Part 2: To send the data selection on page 176
Select the cells that will be sent to the server at run time.

» Part 3: (Server-side) To receive data from the XML Data Connection on
page 177

Develop the web script to receive and tally votes.

* Part 4: To load the data selection on page 180

Select the cells that will be updated at run time from the server.

* Part 5: (Server-Side) To send data to the XML Data Connection on
page 181

To open the User Guide Sample file:

1. Select File > Samples.

2. Select the User Guide Samples category.
3. Select the file name in the Items section.

The Sample file will contain all components and the corresponding
spreadsheet data. To follow along with the step-by-step instructions, open
the Sampile file and then delete the components. These instructions will
produce a working visualization that will demonstrate the use of a component
or feature; additional settings, formats, or components may have been added
to enhance the appearance of the sample visualization.
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The completed sample XLF file with embedded spreadsheet data and SWF
file for this visualization can be located by navigating to the following location:

C:\Program Files\Business Objects\Xcelsius\assets\samples\User Guide
Samples

Part 1: To configure the XML Data Connection

To create applications that connect to external sources using the XML Data
Connection, you must configure the connection and refresh options.

Each XML Data connection can communicate with a different external source.
This source is specified by a URL on the Definition tab of the Data Manager.
The URL must be available to the generated SWF application at run-time in
order for the data to be sent and loaded correctly.

In this example, votes need to be tallied and up-to-date results displayed.
We can accomplish this by communicating with a server script that interacts
directly with a database. An ASP .NET script called addresults.aspx is used,
but there are no restrictions on how the server script needs to be
implemented.

To configure the XML data connection

1. In the Data Manager, add an XML Data Connection. If you have already
added the connection, select it from the list to edit it.

2. In the XML Data URL box, enter the URL where your server script is
hosted, or use the cell selector button to select the URL from the
spreadsheet..

3. On the Usage tab, ensure that Refresh On Load and Refresh Every
are not selected.

Part 2: To send the data selection

Users can vote on four separate categories using a series of sliders. By
adding the cells that are tied to the sliders to the list of ranges to send, we
can send the vote to the server.

To configure an Xcelsius 2008 visualization to send data to an
external source

1. On the Definition tab, click Enable Send.
2. Click the add button [ .

A new range is created.
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3. In the Name box, type a name for the range.

For this example, enter the name "Vote".

4. Click the Range cell selector button and select the range of cells to be
sent to the external data source.

Part 3: (Server-side) To receive data from the XML Data Connection

The XML Data Connection sends specified ranges in a row-column structure.
You can view the exact structure that will be sent to the server using the
Preview XML button in the Send section. The server script should expect
this XML structure.

The following example was developed to run on a Microsoft .NET web server.
There are no restrictions on how the web query needs to be implemented.

The server script for the polling application has two functions. It must handle
the data sent from the SWF and, return the updated totals for the poll.

In order to tally votes, the server-side script must examine the incoming XML
data to extract the vote information. Using this information, the script can
then record the vote by inserting it into a database.

The following files make up the server-side implementation of tallying the
votes:

«  SendPreview.xml.

An XML file generated by Xcelsius 2008 with the Preview XML button of
the Send section on the General tab of the Properties panel.

<data>
<variable name="vote">
<row>
<column>1.0</column>
<column>1.0</column>
<column>1.0</column>
<column>1.0</column>
</row>
</variable>
</data>

* addresults.aspx.
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A VB script that reads the XML data and adds the parsed vote to the
database.

<%@ Page Language="VB" aspcompat=true Debug="true" vali
dateRequest="false" %>

<%@ Import Namespace="System.Data" %>
<%@ Import Namespace="System.Data.SglClient" %>

<

o\©

'Get XML that was send from SWF file
Dim sXMLString

dim item as String
For Each item In Request.Form

'Response.Write(item & " = " & Request.Form(item) & VbCrLf)
sXMLString = sXMLString & item & " = " & Request.Form(item)
Next

'Load XML into object
Dim oXML as Object

Dim oNodelist as Object
Dim oNode as Object

oXML = Server.CreateObject ("MSXML2.DOMDocument")
oXML.async = False
oXML.validateOnParse = False

'Response.Write (sXMLString)
'Response.Write (oXML.loadXML (sXMLString))
0XML. loadXML (sXMLString)

'Use XPath to get the data

dim sPath as String

sPath = "/data/variable/row/column"

oNodeList = oXML.documentElement.selectNodes (sPath)

'Store data in an array

dim i, aVals (3)

i=0

For Each oNode in oNodelist
With oNode

' Just write the xml for that node to show you.
'Response.Write (.text + "<br>")
aVals (i) =.text

i=i+1

End With

Next

'Insert data into database

Dim sSQL as String ' String variable for building our query
Dim oCon as Object
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dim oCmd as Object
dim sConnect as String
'Define insert statement
sSQL = "INSERT INTO ComdexPoll (Booth, Staff, Demos, Buy)
VALUES (" & aVals(0) & ", " & avVals(l) & ", " & aVals(2) &
vv, " & avals(3) & ")"
'Create connection object
sConnect = "Provider=SQLOLEDB;Data Source=yourdb;Initial
Catalog=yourdb;User Id=user;Password=password;"
oCon = Server.CreateObject ("ADODB.Connection")

oCon.ConnectionString = sConnect
oCon.Open

'Create command object

oCmd = Server.CreateObject ("ADODB.Command")
oCmd.ActiveConnection = oCon
oCmd.CommandText = sSQL

'Execute the command to insert the data
oCmd.Execute ()

'Select new totals from the database

dim oRst as Object

oRst = Server.CreateObject ("ADODB.RecordSet")

oRst.ActiveConnection = oCon

sSgl = "select Sum(Booth) as Booth, Sum(Staff) as Staff,

Sum (Demos) as Demos, Sum(Buy) as Buy, Count(ID) as TotalRecs
from comdexpoll"

oRst.Open (sSqgl)

'Build XML data to return
dim sXML as String
sXML = "<data>"

'totalData

sXML = sXML & "<variable name=" + chr (34) + "totalData" +
chr (34) + ">"

sXML = sXML & "<row>"

SXML = sXML & "<column>" & oRst ("Booth") .value & "</column>"
SXML = sXML & "<column>" & oRst ("Staff").value & "</column>"
SXML = sXML & "<column>" & oRst ("Demos") .value & "</column>"
SXML = sXML & "<column>" & oRst ("Buy").value & "</column>"
SXML = sXML & "</row>"

SXML = sXML & "</variable>"

'totalEntries

sXML = sXML & "<variable name=" + chr (34) + "totalEntries"
+ chr (34) + ">"

sXML = sXML & "<row>"

sXML = sXML & "<column>" & oRst ("TotalRecs") .value &
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"</column>"
SXML = sXML & "</row>"
sXML = sXML & "</variable>"

'userDefaults

sXML = sXML & "<variable name=" + chr (34) + "userDefaults"
+ chr (34) + ">"

sXML = sXML & "<row>"

SXML = sXML & "<column>5</column>"

SXML = sXML & "<column>5</column>"

SXML = sXML & "<column>5</column>"
SXML = sXML & "<column>5</column>"
SXML = sXML & "</row>"

sXML = sXML & "</variable>"

'close out the XML data string
SXML = sXML & "</data>"

'Now write the data out so that it gets returned
Response.Write (sXML)

'Cleanup connection vars
oRst.close

oRst = Nothing

oCmd = Nothing
oCon.close

oCon = Nothing

Part 4: To load the data selection

To configure an Xcelsius 2008 visualization to refresh data from an
external source

1. On the Definition tab, click Enable Load.

2. Click the Add button [*J .
A new range is created.

3. In the Name box, type a name for the range.
For this example, enter the name "totalData".

4. Click the Range cell selector button and select the range of cells to be
refreshed.

5. Repeat steps 3-5 to create "totalEntries” and "userDefaults" ranges.

6. Set up the external data source to return the XML.
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You can create an XML file and manually update it as needed or write a
server script that queries a database and translates the results into XML.
Choose an implementation that suits your specific needs.

First configure the XML Data button to enable loading from the external data
source.

Part 5: (Server-Side) To send data to the XML Data Connection

The XML Data Connection expects to receive XML data in the same
row-column format that it uses to send range data. You can view the exact
structure that the connection is expecting by pressing the Preview XML button
in the Load area.

The following example was developed to run on a Microsoft .NET web server.
There are no restrictions on how the web query needs to be implemented.

The server script for our polling application has two functions. It must handle
the data sent from the SWF and return the updated totals for the poll.

To refresh the polling application with the latest results, the server-side script
queries a database to pull the most up-to-date data. The script then converts
the data into the XML structure that the XML Data Connection is expecting.
The XML is sent back to the connection where it is converted into data and
used to update the visualization.

The following files make up the server-side implementation of tallying the
votes:

* LoadPreview.xml

An XML file generated by Xcelsius 2008 with the Preview XML button of
the Load area on the Definition tab of the Properties panel of the
component.

<data>
<variable name="totalData">
<row>
<column>5</column>
<column>10</column>
<column>3</column>
<column>5</column>
</row>
</variable>
<variable name="totalEntries">
<row>
<column>10.0</column>
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</row>
</variable>
<variable name="userDefaults">
<row>
<column>1.0</column>
<column>1.0</column>
<column>1.0</column>
<column>1.0</column>
</row>
</variable>
</data>

addresults.aspx

A VB script that reads the XML data and reads the new data.

<%@ Page Language="VB" aspcompat=true Debug="true" vali
dateRequest="false" %>

<%@ Import Namespace="System.Data" %>

<%@ Import Namespace="System.Data.SglClient" %>

o©

<

'Get XML that was send from SWF file
Dim sXMLString

dim item as String
For Each item In Request.Form

'Response.Write(item & " = " & Request.Form(item) & VbCrLf)
sXMLString = sXMLString & item & " = " & Request.Form(item)
Next

'Load XML into object
Dim oXML as Object

Dim oNodelList as Object
Dim oNode as Object

oXML = Server.CreateObject ("MSXML2.DOMDocument")
oXML.async = False
oXML.validateOnParse = False

'Response.Write (sXMLString)
'Response.Write (oXML.loadXML (sXMLString))
oXML.loadXML (sXMLString)

'Use XPath to get the data

dim sPath as String

sPath = "/data/variable/row/column"

oNodeList = oXML.documentElement.selectNodes (sPath)

'Store data in an array
dim i, aVals (3)
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i=0

For Each oNode in oNodelList

With oNode

' Just write the xml for that node to show you.
'Response.Write (.text + "<br>")

aVals (i) =.text

i=i+1

End With

Next

'Insert data into database

Dim sSQL as String ' String variable for building our query
Dim oCon as Object

dim oCmd as Object

dim sConnect as String

'Define insert statement

sSQL = "INSERT INTO ComdexPoll (Booth, Staff, Demos, Buy)
VALUES (" & aVals(0) & ", " & avVals(l) & ", " & aVals(2) &
", " & avals(3) & ")"

'Create connection object

sConnect = "Provider=SQLOLEDB;Data Source=yourdb;Initial
Catalog=yourdb;User Id=user;Password=password;"

oCon = Server.CreateObject ("ADODB.Connection")
oCon.ConnectionString = sConnect

oCon.Open

'Create command object

oCmd = Server.CreateObject ("ADODB.Command")
oCmd.ActiveConnection = oCon
oCmd.CommandText = sSQL

'Execute the command to insert the data
oCmd.Execute ()

'Select new totals from the database

dim oRst as Object

oRst = Server.CreateObject ("ADODB.RecordSet")

oRst.ActiveConnection = oCon

sSgl = "select Sum(Booth) as Booth, Sum(Staff) as Staff,

Sum (Demos) as Demos, Sum(Buy) as Buy, Count (ID) as TotalRecs
from comdexpoll"

oRst.Open (sSqgl)

'Build XML data to return
dim sXML as String
sXML = "<data>"

'totalData

sXML = sXML & "<variable name=" + chr(34) + "totalData" +
chr (34) + ">"
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sXML = sXML & "<row>"

SXML = sXML & "<column>" & oRst ("Booth") .value & "</column>"
SXML = sXML & "<column>" & oRst ("Staff").value & "</column>"
SXML = sXML & "<column>" & oRst ("Demos") .value & "</column>"
SXML = sXML & "<column>" & oRst ("Buy").value & "</column>"
SXML = sXML & "</row>"

SXML = sXML & "</variable>"

'totalEntries

sXML = sXML & "<variable name=" + chr(34) + "totalEntries"
+ chr (34) + ">"

sXML = sXML & "<row>"

sXML = sXML & "<column>" & oRst ("TotalRecs") .value &
"</column>"

SXML = sXML & "</row>"

SXML = sXML & "</variable>"

'userDefaults
sXML = sXML & "<variable name=" + chr(34) + "userDefaults"
+ chr(34) + ">"

sXML sXML & "<row>"

SXML = sXML & "<column>5</column>"
SXML = sXML & "<column>5</column>"
SXML = sXML & "<column>5</column>"
SXML = sXML & "<column>5</column>"
SXML = sXML & "</row>"

SXML = sXML & "</variable>"

'close out the XML data string
SsXML = sXML & "</data>"

'Now write the data out so that it gets returned
Response.Write (sXML)

'Cleanup connection vars
oRst.close

oRst = Nothing

oCmd = Nothing
oCon.close

oCon = Nothing

&>
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Configuring Flash Variables connections

Definition
Mame: Connection 5
‘ariable Format: =L W

‘‘ariable Daka
Ranges: Marne:

Range:

: | Import Mamed Ranges J

Add or edit the following connection parameters for Flash Variables
Connections:

Definition Tab
* Name

Type a name for the connection.

* Variable Format

Select XML or CSV format data to send to the SWF file.
* Variable Data

The Name and Range parameters apply to the range that is highlighted
in the Ranges list box.

* Ranges List Box

Select a range in the list box to edit the data for that range.
* Add

Use the Add button to add a new range to receive return XML.

« Remove
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Use the Remove button [ to delete the highlighted range from the
list.

- Name

Type a name for the selected range or use the cell selector button to
link to a cell in the spreadsheet..

* Range

Click the Range cell selector button to select a range from the
spreadsheet.

» Import Named Ranges button

Use this button to import named ranges from the spreadsheet.

User Guide Sample: Flash Variables connection

With the Flash Variables connection, you can pass data directly to a SWF
file that is hosted in an HTML page. This data is passed to the visualization
before the SWF file loads and lets you initialize your visualization with any
data that is passed in by this method.

Note: This functionality utilizes the FlashVars property of the Adobe Flash
Player. For more information on this functionality please see the "Using
FlashVars to pass variables to a SWF" TechNote on the Adobe web site.

The sample visualization below lists stock market data for several companies
and displays the latest stock data when the file is viewed as a web page.

To open the User Guide Sample file:

1. Select File > Samples
2. Select the User Guide Samples category.
3. Select the file name in the Items section.

The Sample file will contain all components and the corresponding
spreadsheet data. To follow along with the step-by-step instructions, open
the Sampile file and then delete the components. These instructions will
produce a working visualization that will demonstrate the use of a component
or feature; additional settings, formats, or components may have been added
to enhance the appearance of the sample visualization.
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The completed sample XLF file with embedded spreadsheet data and SWF
file for this visualization can be located by navigating to the following location:

C:\Program Files\Business Objects\Xcelsius\assets\samples\User Guide
Samples

Also included in this directory is the HTML file of the final visualization.

Step 1: To configure the visualization

1.
2,
3.

o

Create an Xcelsius 2008 visualization to display stock data.
Open the Data Manager, click Add, and select Flash Variables connection.
In the Name box, type a name for the range.

For this example, type "Flash Variable example".

. On the Variable Format drop-down menu, select CSV.

For this example, selecting CSV will pass comma separated data to the
SWEF file.

In the Variable Data area, add a Range by clicking the plus button.
Select the added range in the Ranges list box.
In the Variable Data Name box, type a name for the range.

For this example, type "StockData".

In the Variable Data Range box, use the cell selector button to select the
range of cells to be replaced from the spreadsheet.

For this example, the range of cells should contain the stock data.

Click the Close button to exit the Data Manager.

Step 2: To export the visualization

1.
2,

On the File menu, point to Export and click HTML.
Enter a name for the HTML file, and click Save.

For this example, name the file "Stocks.html".

Note: Export to HTML generates an HTML file and a SWF file of the
same name in the specified location.

Open Stocks.html with an HTML editing program such as Microsoft
Notepad.
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4. Find the specified line of code:
* Internet Explorer

<PARAM NAME=FlashVars
VALUE="StockData=Widget%20Maker%20Inc.%2C33.50...

* Netscape/Mozilla

<EMBED src="Stocks.swf" quality=high
bgcolor=#FFFFFF WIDTH="452" HEIGHT="355" FlashVars="Stock
Data=Widget%20Maker%20Inc.%2C33.50...

5. Change the first value (33.50) to 99.50.
6. Save Stocks.html
7. Open Stocks.html with your web browser.

The value change is reflected in Stocks.html.
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Mame:

Range:

Tvpe:

The Portal Data Connection includes three connection types:

* None (Parameter)
+  Consumer

*  Provider

These connections are added to a visualization that needs to have parameters
defined or that needs to pass or receive data from another web part.

Portal without connection

Portal without connection allows visualization designers to define parameters
that they want the user to customize from within a portal. Different users may
want to see the data in different ways.
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There are three important selections in the Parameter section:

Name

Name is user-defined and will be displayed for the visualization in the
property dialog box in Sharepoint. Name is required or the parameter will
not be listed as a parameter in Sharepoint.

Type a name or use the cell selector button to link to a cell in the
spreadsheet.

Range
Range is the area in the spreadsheet where the parameters are set.

Select the range by using the cell selector button to link to a range in the
spreadsheet.

Type

Type sets the type of parameter. The parameter can be Text, Number,
Check Box, Date, or List Box.

+ Textis used to set any text based data within the XLF. For example,
chart titles.

*  Number is used to set any numeric based data. For example, alert
levels.

» Check Box is useful for toggling the value of a cell between zero and
one. It can be used for showing or hiding components using Dynamic
Visibility.

» Date is used to define a date in the XLF. It sets the format to Date and
uses a true date value within the XLF. For example, this type can be
used to set date ranges for data access or for amount of data to
display.

» List Box enables the designer to build user selection options into the
parameters. When List Box is selected, two more options become
available.

* Entries

Entries is used to set what entries are available for the user to
select.

« Default Selection
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Default Selection is used for selecting which entry's value will be
used by default if the user does not make a selection.

The List Box Type allows the designer to specify set values that can
be selected by the user. Text, Number, Check Box, and Date allow
the user to enter any value into the parameter. If the value they enter
is not compatible with the visualization, the correct behavior will not
occur. The List Box type eliminates this issue because the user must
select from values the designer provides.

Portal Consumer Connection

The Portal Consumer connection should be added to any visualization that
will accept data from a web part within the portal. In addition to the
Parameters, there are three important selections to configure on the
Properties panel of the Consumer connection: Range Name, Range Type,
and Range.

* Range Name

Range Name is user-defined and is displayed when connecting web parts
together in Portals. Range Name is required or the web parts cannot be
connected together.

* Range Type

Range Type defines the amount of data that will be passed. Cell consumes
a single cell from another web part. Row is a single row with multiple
columns. Table is multiple rows and columns. If another visualization is
passing in data, the most likely type to select is Cell or Row. Table is used
to pass data from a Portal list.

* Range

Range is the area on the internal spreadsheet of the visualization that
the incoming data will be written to.

Portal Provider Connection

The Portal Provider Connection should be added to any visualization that
will provide data to another web part. In this case only Xcelsius 2008 Portal
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Usage Tab

web parts can be used to consume information from a visualization that is
using the Portal Provider connection.

The Portal Provider contains the same options as the Portal Consumer
connection. See above for details about these three options.

The Usage Tab for the Portal Data connection is only available with Portal
Provider type connections.

See Usage Tab on page 201 for more information.

Configuring Crystal Report Data Consumer

Connections
Deefinition
Fow Headers: %]
Column Headers: &
Data: ]
Descripkion:

Add or edit the following connection parameters for Crystal Report Data
Consumer Connections:

Definition Tab
Row Headers

Use the Cell Selector button to select a row header in the spreadsheet.

e Column Headers

192 Xcelsius 2008 User Guide



Using Advanced Features in Xcelsius Engage
Using the Data Manager

Use the Cell Selector button to select a column header in the spreadsheet.
* Data

Use the Cell Selector button to select a data range in the spreadsheet.
+ Description

Type a description for the Data Connection that will be saved with the
file.

Configuring FS Command Connections

Definition Uszage
Marne: Connection 6
Command: E
Parameters: |3|

For detailed information about FS Command, see the Adobe Flash support
site at http://www.adobe.com/support/flash/action_scripts/actionscript_dictio
nary/actionscript_dictionary372.html

Definition Tab
« Name

Type a name for the connection.
+ Command

Use the Command field to type a command for the FS Command, or click
the Cell Selector button and select a command in the spreadsheet.

* Parameters

Use the Parameter field to type a parameter value for the FS Command,
or click the Cell Selector button and select a value in the spreadsheet.
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Usage Tab

See Usage Tab on page 201 for details on the Data Manager usage
configurations.

Configuring LCDS connections

Definibian
W | Hast, ..
Available Data Destinations

Id Drescripkion

Destination Data

Daca Eement Draka Type Shaps

LiveCycle Data Services, a component of Adobe LiveCycle Enterprise Suite
software, provides up-to-second views of your business data via dashboards
connected to Adobe LiveCycle Data Services. The LCDS connection streams
real-time data into interactive visualizations, animated charts and graphs,
financial presentations, or business calculators, delivering meaningful
information in a visually engaging way.

Add or edit the following connection parameters for Live Cycle Data Services
(LCDS) connections:

Definition tab

*  Dropdown menu
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Select the LCDS host connection to be associated with this connection.
If no hosts are listed, click the Host button to add a new host.

Host button

Click the Host button to launch the Edit a Host dialog box.
* Name

Type a name for this LCDS host.
+ URL
Type the URL to the LCDS server to connect to.

Basic structure:
http://<server name>:<port>/<LCDS context path>/xcelsius

e.g.
http://localhost:8700/flex/xcelsius

Click OK to add the Host and return to the Data Manager
Query button

Click on the Query button to retrieve information on what feed destinations
are available from the LCDS host selected in the dropdown menu.

Available Data Destinations

Select one of the available feed destinations to bind to the CX model.
e |d:

The Id of the LCDS feed destination.
* Description:

The description of the feed destination.
Advanced button

Click the Advanced button to expand the settings available for the selected
feed destination.

° |d:
The Id of the LCDS feed destination.
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» Channel Type:
The type of channel (or communication protocol) that is being used.
»  Channel URL:

The URL associated with the selected feed destination.

Destination Data

This section lists the Data Elements available from the selected Host.
Select a Data Element, and then click the cell selector button on the
bottom right to select a range in your spreadsheet.

« Data Element:

The data element(s) that are being returned by the feed destination.

* Data Type:
The data type of the element:

*  Number
* Txt
» True/False (Boolean)

Shape:

Describes the shape or structure of the data that is returned for this
element:

» Singleton (single value)

* 1D (a column or row of values)
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» 2D (atable of values)

Configuring LiveOffice Connections

Definition Lsage

|Name:

|Session URL: http: f{<webserver =:8080 /dswsbobie fservices fsession v |—l!
Ranges
Data Grid =et 1 | %]

Edit the following connection parameters for LiveOffice:

Note: This Data Connection is only available in BusinessObjects Xcelsius
Enterprise.

Note: The Range option of the Live Office connector does not control how
many columns are returned in an XLF file. This option controls only how
many rows of data are returned. This behavior is by design.

LiveOffice Web Services URL

Use this field to enter the location of the Live Office Web Services that the
visualization will use to connect to Live Office data.

LiveOffice Connections

* Views
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The Views area lists the Live Office Views that are used as data sources
in the XLF file.

* Ranges

The Ranges area lists the Excel ranges that can be selected for refresh
in the XLF file. The ranges are split into headings and data grid.

Click the Cell Selector button below the Ranges area to select a different
range of cells to refresh.

For more information about using LiveOffice connections, see Using
LiveOffice data for Xcelsius 2008 visualizations on page 212.

Configuring Excel XML Maps Connections

& Data Manager =
ROF_Man
|6 ooy | [ oewen | ueose
MName: RDF_Map
XML Data URL: http://sandiego.craigslist.org/sss/index. rss ™
1+ 3 X

Xcelsius 2008 supports the XML functionality that was introduced in Excel
2003. Excel supports the ability to embed XML documents and schemas
into a spreadsheet. These files can be imported in Xcelsius 2008; the Xcelsius
2008 SWF files will retain the link to the XML source generated.

Note: Data that has been mapped using the Excel mapping functionality
can be manually refreshed by using a Connection Refresh button in your
visualization.
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Note: If a Dynamic URL is used with the XML Map feature and an interval
refresh, it must be bound to an Excel cell that contains a formula.

Building the visualization

After the Excel file has been set up, the next step is to build your visualization
and configure the XML Map Options.

For information on setting up the Excel file with an XML map, refer to the
on-line help in Microsoft Excel.

Name

The Name field displays the name of the XML Map. This field cannot be
updated.

XML Data URL

The XML Data URL provides the URL of the data's external location. The
location can be edited by typing or using the cell selector button to select a
cell with the new URL.

Sample visualization: Excel spreadsheet with an XML

map

This sample creates a visualization that lists stock market quotes for several
companies based on data in an XML file. After the data has been imported
into an Excel file you can use Xcelsius 2008 to build a visualization that
retains the link to the XML data source. This means that changes to the XML
file will be reflected in the exported SWF file.

This visualization will display share price information for several companies.
The stock information is contained in an XML file that has been imported
into the Excel file and mapped to a range of cells. A Spreadsheet Table
component has been bound to the range of cells to display the data.

To open the User guide Sample file:
1. Select File > Samples.

Xcelsius 2008 User Guide 199



9

Using Advanced Features in Xcelsius Engage
Using the Data Manager

2. Select the User Guide Samples category.
3. Select the file name in the Items section.

Also included in this directory is the HTML file of the final visualization.

Import an Excel file with XML mapped data.

Place a Spreadsheet Table component on the canvas.
Double-click the Spreadsheet Table to open the Properties panel.
Click the Display Data cell selector button.

Select the range of data in the spreadsheet, and click OK.

Open the Data Manager, click the Add button; select Excel XML Maps
connection.

oakrwbh-=

The connection parameters will be filled in per the existing connection's
parameters.

7. Export the visualization to an HTML file.

Note: Xcelsius 2008 generates the HTML file and a SWF file with the
same name and saves them in the selected directory. These files must
be kept together in order for the HTML file to work properly.

Once the visualization has been exported, you can open the HTML file in
your web browser. Changes made to the source XML file will be reflected in
your HTML file.

Configuring External Interface Connections

External Interface connections allow visualization developers to expose
selected data ranges of the spreadsheet. This essentially creates a generic
framework for getting data into and out of the SWF file of the exported
visualization. It also provides built-in eventing so that it is instantly recognized
when a particular data source has changed (e.g. Slider component is dragged
and updates a cell’s data, etc).

Add or edit the following connection parameters for External Interface
connections:

Definition tab

* Range Name
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Enter a name for the range, or click the cell selector to select a cell in the
spreadsheet.

Range Type

Select one of the following from the dropdown menu:

» Cell — the data range consists of a single cell

* Row/Column — the data range is in a single row or a single column

+ Table — the data range has more than one column or row

Range

Click the cell selector button to select a range from the spreadsheet.
Access

Select one of the following from the dropdown menu:

* Read - an external application will be able to be read data in the range

+  Write — an external application will be able to be write data into the
range

* Read/Write — an external application will be able to be read data in
the range and write data into the range

Usage Tab

The Usage Tab contains the Refresh and Load Status options.

Refresh Options

Refresh On Load
Use this option to refresh the data when the visualization loads.
Refresh Every

Use this option to automatically refresh the XML data. Enter the interval
value, then select a time unit (minutes, seconds, etc.) from the drop-down
menu.

Refresh on Trigger
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Use this option to select a cell that will trigger the visualization to refresh
the data. Use the Cell Selector to select the spreadsheet cell that will
define the Trigger Cell, then set the trigger options:

* When Cell Updates. This option triggers a refresh when the Trigger
Cell is updated, even if the value of the cell does not change.

* When Value Changes. This option triggers a refresh when the value
in the Trigger Cell changes.

*  When Value Equals. This option triggers a refresh when the value in
the Trigger Cell equals the target value. Type a target value, or use
the cell selector to link to a spreadsheet cell that contains the trigger
value.

Load Status

Loading Message

Use this option to specify a message that is displayed while the
visualization is loading. Type your message in the entry field, or use the
cell selector to link to a cell in the spreadsheet.

Idle Message

Use this option to specify a message that is displayed while the
visualization is idle. Type your message in the entry field, or use the cell
selector to link to a cell in the spreadsheet.

Insert In

Use the cell selector button to select the spreadsheet cell that Loading
and Idle Messages will be inserted into.

Enable Load Cursor
Use this to display the cursor while the data is loading.
Disable Mouse Input on Load

Use this to disable mouse input while the data is loading.
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Xcelsius 2008 Integration with SQL Server
Reporting Services

Xcelsius 2008 and SQL Server Reporting Services

Xcelsius 2008 uses Xcelsius Reporting Services (XRS) to dynamically
populate Xcelsius 2008 visualizations based on SQL Server Reporting
Services (RS) data. XRS allows users to connect to an RS report through
the Xcelsius 2008 interface and to create visualizations that can easily be
updated.

Xcelsius 2008 Reporting Services server

You can perform the following tasks within the Reporting Services (RS)
server:

» Configure reports and how they run.
» Set user security and viewing rights.

» Configure caching and scheduling for reports

Note: You can only do this is you have administrative rights.

The web.config file located at <drive>:\inetpub\wwwroot\xrs is where
this server configuration occurs. The most important section of this file, where
the configuration takes place, is shown here.

<appSettings>

<add key="ReportingServicesUrl" value="http://xrsdemo-sd/Re
portServer" />

<add key="ReportServerUrl" value="http://xrsdemo-sd/Reports"

/>
<add key="XrsServicesUrl" value="http://xrsdemo-sd/xrs" />
</appSettings>
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Xcelsius 2008 Portal Integration

Xcelsius 2008 for Portals

Xcelsius 2008 support for portals enables you to create dashboards within
the portal environment. Portal integration supports Sharepoint and
Websphere. Administrators can provide complex visualizations or simple
Xcelsius 2008 components that can be customized by users.

Xcelsius 2008 supports the following Portal scenarios:
» Visualizations can be connected to Sharepoint lists.

» Visualizations can communicate with one another. This scenario is useful
for what-if analyses or drill-downs.

+ Users can customize their visualizations, such as the data, components,
alert levels, date ranges, and default parameters that will be used.

For more information about integration with Websphere, see the
documentation included in the Xcelsius 2008 installation CD.

Deploying Xcelsius 2008 Visualizations
to Microsoft Sharepoint

Xcelsius 2008 for Sharepoint server

Xcelsius 2008 for Sharepoint server (XSP) installs a web part container into
the Sharepoint web part library. After installation and configuration, the web
part container can be added to the Web Part Gallery within Sharepoint and
any user with the appropriate rights can add the web part container to a page
within the site.

Deploying visualizations in Sharepoint

This section outlines the steps required to deploy Xcelsius 2008 visualizations
in Sharepoint
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Step 1: Add Xcelsius 2008 to a Sharepoint web page

1. Navigate to the web page that the visualization will reside in.
. Go to Modify Shared Page > Add Web Parts > Browse to open the

Web Part Gallery.

. Locate the Xcelsius 2008 Sharepoint Connector and drag it to the location

on the page where the visualization will reside.

Step 2: Configure the Xcelsius 2008 Sharepoint web

part

. Click the down arrow on the Xcelsius 2008 Sharepoint Connector, then

click Modify Shared Web Part.

The Properties dialog box opens. The property used during this initial
configuration is Xcelsius 2008 Visualization Source.

. Import the visualization that you are configuring.

To populate the web part with a visualization, that visualization should
already be imported into the Sharepoint library of documents. It is usually
best to create a document list for all visualizations so they can be
accessed from the same location.

. Click the link to open the imported visualization and find its exact URL.
. Copy the URL into the Xcelsius 2008 Visualization Source field on the

Web Part properties dialog box and click Apply.

The visualization appears in the web part on the page. If there are any
parameters defined in the visualization, they appear on the Property dialog
box below the Width parameter. These parameters can be set at anytime
by navigating to the property dialog box, setting the parameters and
clicking Apply.

Note: Parameters can be of 5 types: Text, Numeric, Check Box, Date, and
List Box. They can be used to set the value of any cell within the visualization.
More information about parameters can be found in the description of the
Sharepoint Parameter component in the XSP client section.
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Step 3: Connect the web part to other web parts

When in modify Shared web part mode the user can also connect the
visualization to other visualizations or to other web parts that can pass it
data, such as a Sharepoint List.

1.

Click the down arrow on the Xcelsius 2008 Sharepoint Connector then
click Modify Shared Web Part.

Click the down arrow on the web part then click Connections.

If Connections is unavailable, the visualization was not configured to
connect to another web part.

If Connections is available, after you click it you will see options such as
Consume Row, Send Value, Get Value, and Send list. This means that
the visualization is configured to either send information to another web
part (Provider) or receive information from another web part (Consumer).
These options are discussed in more detail in the Sharepoint Consumer
and Sharepoint Provider component sections of this chapter.

If a visualization has been configured to receive a value from another
visualization, add both visualizations to the page.

Click the down arrow on the web part then click Connections.

Click Get value from and select the other Xcelsius 2008 Sharepoint Web
Part.

The two visualizations are now connected.

These connections can be configured in many ways to allow for What-If
analysis, drilling down to more detailed data, or to allow a user interaction
in one visualization to affect other visualizations.

Note: Xcelsius 2008 visualizations support consumer and provider
connections, but are limited to either a single consumer connection or a
single provider connection.
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Business Objects Platform Integration

Overview

BusinessObjects Xcelsius Enterprise enables you to create interactive
presentations from managed Enterprise data. Using the LiveOffice
connections in BusinessObjects Xcelsius Enterprise and the Live Office Web
Services in BusinessObjects Enterprise XI Release 2 (XI R2) or Crystal
Reports Server Xl R2, you can create and refresh visualizations against
managed Enterprise data.

This chapter discusses how to use Excel spreadsheets built with LiveOffice
as data sources for Xcelsius 2008 files. It also discusses how to manage
Xcelsius 2008 XLF files and SWF files in BusinessObjects Enterprise or
Crystal Reports Server.

Note:

» The functionality discussed in this chapter is only supported in
BusinessObjects Enterprise XI R2 and Crystal Reports Server XI R2.

+ Single Sign-on is not supported in this release.

» This document assumes working knowledge of LiveOffice and
BusinessObjects Enterprise or Crystal Reports Server.

Terms used in this document

There are terms used in this document that you may not be familiar with.
Look at this list to see what these terms refer to.

+ XLF

This is an Xcelsius 2008 design file. It is the file that is created by Xcelsius
2008 and is where all the functionality of the visualization is configured.

+ SWF

This is an Adobe Flash file. Xcelsius 2008 uses Adobe Flash to render
interactive files.

»  Xcelsius 2008 Visualization
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This term is used for the final output of an Xcelsius 2008 file. For example,
when you create a file in Xcelsius 2008 and export it to PowerPoint, the
PowerPoint file is an Xcelsius 2008 Visualization.

« LiveOffice-enabled

This term is used to describe an Excel spreadsheet that is created with
LiveOffice as the data source.

Moving from an unmanaged environment to a
managed environment

If you have upgraded from the Crystal Vision bundle, you likely have
LiveOffice report views that are based on unmanaged Crystal Reports. To
take advantage of the refresh capabilities of the LiveOffice connections in
Xcelsius 2008 and the viewing and distribution capabilities of BusinessObjects
Enterprise or Crystal Reports Server, you must move to managed files. You
can publish your unmanaged Crystal Report to BusinessObjects Enterprise
or Crystal Reports Server and then update your visualizations to take
advantage of the functionality available in Xcelsius 2008.

This section outlines the steps to move from an unmanaged environment to
a managed environment. It does not describe each step in detail but instead
gives an overview of the workflow involved. For detailed information on how
to perform each step, referred to the appropriate product guide.

To move to a managed system

1. Publish your unmanaged Crystal Reports to Crystal Reports Server or
BusinessObijects Enterprise.

For detailed information about how to publish reports, refer to the chapter
"Publishing Reports to Crystal Reports Server" in the Crystal Reports
Server Xl Release 2 Installation Guide or the chapter "Publishing Objects
to BusinessObjects Enterprise" in the BusinessObjects Enterprise Xl
Administrator's Guide.

2. In Live Office, set the location of the report view that you want to update
to be managed. Set this location to the location of its new managed report
source.
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For detailed information about how to set the location of a Live Office
report view, refer to the chapter "Creating Report Views from Unmanaged
Reports" in the Live Office User Guide.

3. Open the XLF that you want to modify with the updated report view.

4. In the Data Manager, add and configure a LiveOffice connection to the
XLF.

For detailed information about how to do this, see Creating an Xcelsius
2008 visualization from a LiveOffice- enabled Excel spreadsheet on
page 212. Specifically refer to the procedure called "To make the Xcelsius
2008 file refreshable”.

5. Save the XLF file to your Enterprise system or export a SWF file to your
Enterprise system.

For detailed information about how to do this, see Storing Xcelsius 2008
files in Crystal Reports Server or BusinessObjects Enterprise on page 216.

Using LiveOffice data for Xcelsius 2008 visualizations

With Xcelsius 2008, you can create Xcelsius 2008 XLF files and SWF (Adobe
Flash files) using Excel spreadsheets constructed from managed Crystal
Reports or Web Intelligence data.

The LiveOffice Web Services in Crystal Reports Server and BusinessObjects
Enterprise enables you to refresh Xcelsius 2008 SWF files and Xcelsius
2008 Visualizations from within InfoView. The BusinessObjects Enterprise
Web Services enables you to refresh the data from outside InfoView, as long
as you can connect to your Crystal Reports Server or BusinessObijects
Enterprise system.

Depending on the data that is contained in the Excel spreadsheet, you can
perform a variety of tasks in Xcelsius 2008 that allow you to interact with
Enterprise data.

Creating an Xcelsius 2008 visualization from a LiveOffice-
enabled Excel spreadsheet

You can create an Xcelsius 2008 Visualization using data in a
LiveOffice-enabled Excel spreadsheet. LiveOffice-enabled means that the
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data in the spreadsheet is actually a View created from either managed
Crystal Reports or managed Web Intelligence documents.

After you have imported a LiveOffice-enabled file into Xcelsius 2008, you
can also make it refreshable against the source data by configuring the
LiveOffice connection in the Xcelsius 2008 Data Manager.

Note: The following procedures assume a working knowledge of LiveOffice.

When launching the program, Xcelsius 2008 will detect if LiveOffice is installed
on the user’s machine. If LiveOffice is detected, the following dialog box will
appear.

In order to use LiveOffice with the embedded spreadsheet inside of Xcelsius,
Live Office Compatibility Mode must be enabled. If you choose to enable
Live Office Compatibility Mode, the performance of other Microsoft Office
programs may be affected. If you choose not to enable Live Office
Compatibility mode, you will need to work with Live Office in a spreadsheet
outside of Xcelsius and then import your spreadsheet. Live Office
Compatibility Mode, can be enabled and disabled by going to File >
Preferences > Excel Options; check or clear the Enable check box under
Live Office Compatibility. The selection made will be retained when Xcelsius
2008 is closed.

To create an Xcelsius 2008 Visualization using LiveOffice

1. Import an Excel spreadsheet that contains LiveOffice data.
2. Open the Data Manager and click Add.
A list of connection types appears.

3. Select LiveOffice connections.
4. Configure each of the LiveOffice views.
5. Select the refresh options on the Usage Tab in the Data Manager.

To make the Xcelsius 2008 file refreshable

1. Open the Data Manager and select the LiveOffice connection you want
to refresh. .

2. On the Definition tab, type the URL into the Live Office Web Services
URL field.

The default URL listed in the field is:

http://<webserver>:8080/dswsbobje/services/session
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If your BusinessObjects Enterprise or Crystal Reports Server has a default
Web Services installation, replace <webserver> in the default URL with
the name of your CMC to correctly complete the URL.

The URL is cached so that you do not have to type it in each time you
configure the LiveOffice connection.

3. On the Definition tab, click the View that you want the LiveOffice
connection to refresh against.

Note:

» If your Excel spreadsheet contains more than one View, you can
choose one, some, or all of the Views listed in the Views area of the
Definition tab. Only the data from the Views you choose will be
refreshed when the Xcelsius 2008 file is refreshed.

* You can increase the range of cells that your Xcelsius 2008
visualization is able to accommodate so that if the data grows, your
Xcelsius 2008 visualization will continue to analyze the full data set

properly.

In the Ranges area of the Definition tab, you will see the cell ranges that
have been imported for the selected view.

To increase the original range that you selected:

a. Click the range that you want to adjust.
b. Click the cell selector button under the Ranges area.
c. Select a new range from your spreadsheet and click OK.

The new cell range is reflected in the field next to the cell selector
button.

4. On the Usage tab, set the refresh options you want.

* Refresh on Load automatically refreshes the data whenever you open
the file.

» Refresh on Interval automatically refreshes on the time interval you
specify. The time is measured in seconds.

+ If you do not select either of these options, the refresh will be manual.
You will need to add and configure a Connection Refresh button to
the visualization, which the end user can click to refresh the connection.

5. Export your XLF file to any format you choose.

214  Xcelsius 2008 User Guide



Using Advanced Features in BusinessObjects Xcelsius Enterprise
Business Objects Platform Integration

11

Depending on what option you chose in step 4, the Xcelsius 2008
Visualization will be refreshed when you open it, when you click the
Connection Refresh Button, or at the set time interval.

Note: You can set additional refresh options with a Connection Refresh
Button. See Web Connectivity Components Reference on page 355 for more
information.

Passing parameters from Xcelsius 2008 to LiveOffice

You can pass parameter values from an Xcelsius 2008 visualization or SWF
file to LiveOffice by taking advantage of Xcelsius 2008's ability to pass values
to an Excel spreadsheet. This way, you can input parameter values in your
visualization and have the correct data returned from the data source.

To pass a parameter to LiveOffice

Note: This procedure requires a LiveOffice-enabled Excel spreadsheet with
a bound parameter. The spreadsheet must require user input for the
parameter when it is refreshed.

1.
2,

8.

Place a Single Value component such as a dial or a slider on the canvas.

On the General tab of the Single Values properties browser, click the cell
selector button next to the Data field.

Click the cell that contains the bound parameter and then click OK.

Repeat steps 1 through 5 outlined in To create an Xcelsius 2008
Visualization using LiveOffice on page 213.

On the Usage tab, click the Cell Selector button beside the Trigger Cell
field.

Click the cell that contains the bound parameter and then click OK.
Ensure that Trigger on Change only is selected.

Configuring the Trigger Behavior this way causes the SWF to refresh
each time there is a change to the cell and in this case, the parameter
value.

Click the Preview button to generate a SWF file.

When you adjust the Single Value component in the SWF file, you receive
a prompt to log on to your Enterprise system. When you have successfully
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logged on, the data is refreshed and the new value or values are reflected
in your SWF file.

Storing Xcelsius 2008 files in Crystal Reports Server
or BusinessODbjects Enterprise

You can use BusinessObjects Enterprise or Crystal Reports Server as a
secure repository to store and manage XLF and SWF files. Once the files
have been added to the Enterprise system, any user with the appropriate
rights can log on and view the XLF and SWF files.

Saving XLF files to an Enterprise folder

Once you have created an XLF file, you can save it to a folder in
BusinessObijects Enterprise or Crystal Reports Server.

To save an XLF file to an Enterprise folder
1. In Xcelsius, on the File menu, click Save to Enterprise.

The Log On to BusinessObjects Enterprise dialog box appears.

2. Enter your logon information.

+ Inthe System field, type the name of the Central Management console
(CMC) where you want to save the XLF file.

The CMC stores information about the objects saved to the Enterprise
system. For more information about the CMC, refer to the
BusinessObjects Enterprise or Crystal Reports Server guides.

* In the User name and Password fields, type your logon credentials.

+ On the Authentication list, click the appropriate authentication type.

If you are unsure of your logon information, contact your system
administrator.

3. Click OK.

4. Select the folder where you want to save the XLF file, enter a file name,
and click Save.

Tip: To add a folder to the CMC, click New Folder.
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Opening XLF files from an Enterprise folder

When an XLF file is saved to an Enterprise folder in BusinessObjects
Enterprise or Crystal Reports Server, it can also be opened from that location.

To open an XLF file from an Enterprise folder

1.

In Xcelsius 2008, on the File menu, click Open from Enterprise.
The Log on to BusinessObjects Enterprise dialog box appears.

Enter your logon information.

* Inthe System field, type the name of the Central Management Console
(CMC) that you want to open the XLF file from.

The CMC stores information about the objects saved to the Enterprise
system. For more information about the CMC, refer to the
BusinessObijects Enterprise or Crystal Reports Server guides.

* In the User name and Password fields, type your logon credentials.

+  From the Authentication list, select the authentication type.

If you are unsure of your logon information, contact your system
administrator.

Click OK.

When you have successfully logged on to your Enterprise system, the
folder structure of your Enterprise system appears in the Open dialog
box.

Select the folder that contains the XLF file you want to open, and click
Open.

The XLF file opens in Xcelsius 2008.

Exporting SWF files to an Enterprise folder

You can export a SWF file generated within Xcelsius 2008 to a folder in
BusinessObijects Enterprise or Crystal Reports Server.

To export a SWF file to an Enterprise folder

1.

In Xcelsius 2008, open the XLF file.
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2. On the File menu, point to Export, and click BusinessObjects Platform.

The Log On to BusinessObjects Enterprise dialog box appears.

Enter your logon information.

* Inthe System field, type the name of the Central Management Console
(CMC) that you want to export the SWF file to.

The CMC stores information about the objects saved to the Enterprise
system. For more information about the CMC, refer to the
BusinessObijects Enterprise or Crystal Reports Server guides.

* In the User name and Password fields, type your logon credentials.

+ On the Authentication list, click the appropriate authentication type.

If you are unsure of your logon information, contact your system
administrator.

Click OK.

The Save As dialog box appears and displays the folder structure of the
Enterprise repository.

Select the folder that you want to export the SWF file to, enter a file name,
and click Save.

The SWEF file is exported to the Enterprise repository.

Managing Xcelsius 2008 files in Crystal Reports
Server or BusinessObjects Enterprise

The Enterprise system allows you to manage Xcelsius 2008 files through
InfoView and the Central Management Console (CMC).

You can perform the following tasks with XLF and SWF files in InfoView:

View a list of your XLF and SWF files.
Search for specific files.
Move or copy files to different folders.

View and refresh SWF files in InfoView.

218 Xcelsius 2008 User Guide



Using Advanced Features in BusinessObjects Xcelsius Enterprise
Business Objects Platform Integration

11

If you have administrative rights to the Enterprise system, you can modify
the edit and view rights for XLF and SWF files within the Central Management
Console (CMC).

Note: You cannot view XLF files in InfoView. To view XLF files that have
been added to the Enterprise system, you must open the XLF file within
Xcelsius 2008. For more information, see Opening XLF files from an
Enterprise folder on page 217.

With the release of Crystal Reports 2008, it is now possible to embed an
Xcelsius-generated SWF file into a Crystal Report and have the SWF
consume data from that report. When set up properly, refreshing the data in
your Crystal Report will update the embedded SWF.

To configure your Xcelsius SWF to consume data from its Crystal Rport
source data, you must open the Data Manager in Xcelsius and add a new
Crystal Report Data Consumer connection. After adding the connection, bind
the following ranges to your spreadsheet:

*  Row Headers
¢ Column Headers
* Data

The components in your visualization should be bound to the aforementioned
ranges.

Next, you will export your visualization to Adobe SWF. Using Crystal Reports
2008, embed the SWF file into the Crystal Report source data file. When
designing your Crystal Report, you will determine what fields/data populate
the Row Headers, Comumn Headers, and Data ranges that were designated
in your Xcelsius SWF. When set up properly, refereshing your Crystal Report
will also refresh the data being sent to and consumed by the embedded
SWEF. See the Crystal Reports 2008 User Guide for more information on
working with Crystal Reports.

Viewing SWF files in InfoView

The process for viewing a SWF file in InfoView is the same as the process
for viewing other file types in BusinessObjects Enterprise or Crystal Reports
Server.
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To view a SWF file in InfoView

1. Tolaunch InfoView, open your web browser and enter one of the following
paths depending on your Enterprise deployment:

+ NET

http://webserver/businessobjects/enterprisell5/

* Java

http://webserver:portnumber/businessobjects/enter
prisell5/desktoplaunch

Here, webserver represents the name of the web server, and portnumber
represents the connection port.

The CMC stores information about the objects saved to the Enterprise
system. For more information about the CMC, refer to the BusinessObjects
Enterprise or Crystal Reports Server guides.

Tip: If you have Enterprise installed on your machine, you can also access
InfoView on the Start menu. Click Start > Programs > Business Objects
> BusinessObijects Enterprise. Click either .NET InfoView or Java InfoView
depending on your Enterprise deployment.

2. Enter your logon information.

* Inthe System field, type the name of the Central Management Console
(CMC) that the SWF file is saved to.

* In the User name and Password fields, type your logon credentials.

«  From the Authentication list, select the authentication type.

If you are unsure of your logon information, contact your system
administrator.

3. Click Log On.
4. Go to the folder that contains the SWF file you want to view.
5. Click the name of the SWF file.

The SWF opens inside the InfoView panel.
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Refreshing SWEF files in InfoView

In InfoView, users can refresh a Live Office-enabled SWF file to view the
newest data.

When you design the visualization in Xcelsius 2008, you can set the
visualization to refresh in InfoView in one of the following ways:

* Refresh on Load

* Refresh on Interval

* Manual Refresh

» Refresh based on Trigger Behavior

If you are unsure of how the data in the SWF file refreshes, check the
LiveOffice connection settings in the XLF file in Xcelsius 2008.

To check the LiveOffice connection refresh setting
1. In Xcelsius 2008, open the XLF file.
2. In the Data Manger, open the LiveOffice connection properties.

3. On the Usage tab, ensure the refresh setting that you want has been
selected and configured.

Refresh on Load

If you selected Refresh on Load when you configured the LiveOffice
connection in Xcelsius 2008, the file automatically refreshes when you view
it.

To refresh a SWF file on load

1. Ensure that you have a Live Office-enabled SWF file saved to Enterprise
that has its refresh option set to Refresh on Load.

2. Open InfoView and find the SWF file you want to view.

For more information, see Viewing SWF files in InfoView on page 219.

3. Open the SWF file.

The SWEF file is refreshed with the newest data from the data source.
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Refresh on Interval

If you selected Refresh on Interval when you configured the LiveOffice
connection in Xcelsius 2008, the file refreshes at the interval you selected.

To refresh a SWF file on interval

1.

Manual refresh

Ensure that you have a Live Office-enabled SWF file saved to Enterprise
that has its refresh option set to Refresh on Interval.

Open InfoView and find the SWF file you want to view.
For more information, see Viewing SWF files in InfoView on page 219.

Open the SWF file.

The SWF file automatically refreshed after the set number of seconds
has passed.

If you did not select any refresh option when you configured the LiveOffice
connection in Xcelsius 2008, you must click a Connection Refresh Button to
refresh the file.

To manually refresh a SWF file

1.

Ensure that you have a LiveOffice-enabled SWF file saved to Enterprise
that has a Connection Refresh Button configured to refresh the LiveOffice
connection.

Open InfoView and find the SWF file you want to view.

For more information, see Viewing SWF files in InfoView on page 219.

Open the SWF file and click the Connection Refresh Button.

Note: This button may have been renamed when the visualization was
created.

When the Connection Refresh button is clicked, the Xcelsius 2008 file is
refreshed with the newest data from the data source.

Refresh based on Trigger Behavior

If you passed a Crystal Reports parameter to the Xcelsius 2008 visualization,
and used the features in the Trigger Behavior area to configure the refresh
option, the data refreshes when the parameter value changes in the Trigger
Cell that you specified.
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To refresh a SWF file based on trigger behavior

1.

Ensure that you have a Live Office-enabled SWF file saved to Enterprise
with the following characteristics:

» A Single Value component configured to trigger the refresh.

» A LiveOffice connection configured to refresh based on the settings
in the Trigger Behavior area.

Open InfoView and find the SWF file you want to view.

For information on how to do this, see Viewing SWF files in InfoView on
page 219.

Open the SWF file and change the value on the Single Value component.

The data is refreshed and the new value or values are reflected in the
file.

Refreshing Xcelsius 2008 visualizations outside InfoView

If you are outside of InfoView and you have a connection to the Enterprise
system, you can still refresh an Xcelsius 2008 visualization with the newest
data.

To refresh an Xcelsius 2008 Visualization outside InfoView

1.

2,

3.

Ensure that you have a LiveOffice-enabled Xcelsius 2008 visualization
with a Connection Refresh Button configured to refresh LiveOffice.

Open the Xcelsius 2008 Visualization and click the Connection Refresh
button .

This button may have been renamed when the visualization was created.
The Log On to BusinessObjects Enterprise dialog box appears.

Enter your logon information.

a. Inthe System field, type the name of the Central Management Console
(CMC) where you want to save the XLF file.

The CMC stores information about the objects saved to the Enterprise
system. For more information about the CMC, refer to the
BusinessObijects Enterprise or Crystal Reports Server guides.

b. In the User name and Password fields, type your logon credentials.
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c. On the Authentication list, click the appropriate authentication type.

If you are unsure of your logon information, contact your system
administrator.

4. Click OK.

The visualization is refreshed with the newest data from the data source.

Modifying edit and view rights in the Central Management
Console

If you have administrative rights to the Enterprise system, you can modify
the edit and view rights of XLF and SWF files in the Central Management
Console (CMC).

For more information about rights and how they work, refer to the
BusinessObjects Enterprise Administration Guide.

To modify rights in the CMC

1. Tolaunch the CMC, open your web browser and enter one of the following
paths depending on your Enterprise deployment:

« .NET
http://webserver/businessobjects/enterprisell5/WebTools/ad
minlaunch/default.aspx

+ Java

http://webserver:portnumber/businessobjects/enter
prisell5/adminlaunch/launchpad.html

Here, webserver represents the name of the web server, and portnumber
represents the connection port.

Tip: If you have Enterprise installed on your machine, you can also access
InfoView on the Start menu. Click Start > Programs > Business Objects
> BusinessObjects Enterprise. Click either .NET Administration
Launchpad or Java Administration Launchpad depending on your
Enterprise deployment.

2. Click Central Management Console.
3. On the CMC Log On page, enter your logon information.
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* Inthe System field, type the name of the CMC where the XLF or SWF
file is stored.

* In the User name and Password fields, type your logon credentials.

* From the Authentication list, select the authentication type.

4. Click Log On.
5. On the CMC home page, click Objects.

A list of all the objects on the CMC appears.

Click the XLF or SWF file you want.
Click the Rights tab.
Use the lists under Access Level to set the rights for each user group.

When you have finished, click Update to submit the changes that you
have made.

© o N

Updating LiveOffice connection settings after system
migration

When content is migrated from one BusinessObjects Enterprise system to
another, the location of the LiveOffice Web Services changes. Therefore,
the Data Manager settings for the LiveOffice connection become incorrect
and LiveOffice-enabled visualizations cannot be refreshed.

You can update the web.config file or web.xml file directly to update the
LiveOffice Web Services location without having to open each individual
visualization.

Note: Editing the web.config or web.xml file incorrectly can lead to
unexpected behavior. Ensure you backup your files before making any
changes to them.

To update the web.config file for .NET InfoView

1. Locate web.config by going to

<drive>:\Program Files\Business Objects\BusinessObjects Enterprise
11.5\Web Content\Enterprise115\InfoView\web.config
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2. Open web.config in a text editor such as Notepad.
3. Search for the following text at the end of file:

<appSettings>
<add key="applications" value="com.businessobjects. encyclo
pedia.reportviewer.wrapper.InfoViewPanel, analyticwrapper"/>

4. When you find this text, add the following text below it:

<add key="webConnectorUrl" value="http://webservice:port/dsws
bobje/services/session"></add>

Where webservice represents the name of your web service and port
represents the port number that the web server communicates on.

This setting overrides the setting that is in Xcelsius 2008.

To update the web.xml file for Java InfoView

1. Locate web.xml by going to:

C:\Program Files\Business Objects\web server\webapps\busines
sobjects\enterprisell5\desktoplaunch\WEB-INF\web.xml

Where web server is the name of your web server.

2. Open web.xml in a text editor such as Notepad.
3. Search for the following text at the end of file:

<context-param>
<param-name>crystalXcelsius 2008.webconnectorurl</param-name>

4. When you find this text, add the following text below it:

<param-value>http://webservice:port/dswsbobje/services/ses
sion</param-value>

Where webservice represents the name of your web service and port
represents the port number that the web server communicates on.

This setting overrides the setting that is in Xcelsius 2008.

Launching an InfoView document from Xcelsius 2008

Xcelsius visualizations stored in InfoView can be configured to open reports
or other documents that are also in InfoView. This is accomplished by adding
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the OpenDocument API (Application Programming Interface) to the URL that
is used to call the document. The OpenDocument AP| was created by
Business Objects to provide a standard way of opening documents and
reports that have been published to BusinessObjects Enterprise using a
simple URL. OpenDocument allows you to specify not only the report but
also report parameters to return only the desired data.

Note: OpenDocument launches the report or documentin a separate browser
window.

Basic Structure:

http://<webserver>/businessobjects/enterprisell5/<platformSpe
cific>?<parameterl>&<paramter2>&...&<parameterN>

Note: The URL needs to be URL-encoded if it contains non-URL safe
characters.

Sample URL.:

http://cdiSboe:8080/businessobjects/enterprisell5/deskto
plaunch/opendoc/openDocument. jsp?sType=rpt&sRepoType=corpo
rate&sPath=[folder], [subfolderl], [subfolder2] &sDocName=Report
Name&IsSpromptNamel=promptValuel

The sample URL is structured per below; sections in bold would need to be
customized to the file:

http://

Protocol:
(can be https://)

Serve.r cdi5boe:

name:

Port: 8080/
businessobjects/enterprise115/desktoplaunch/opendoc/openDoc

isp?

Open Doc ument.jsp?

JSP: Note: the syntax for .NET based systems is businessobjects/en
terprise115/InfoView/scripts/opendocument.aspx
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sType=rpt&

Type: Note: rpt= Crystal Reports; wid = Web Intelligence; rep = Desktop
Intelligence; car = OLAP Intelligence

Repository

Type: sRepoType=corporate&

File Path: [sPath=[folder],[subfolder1],&[subfolder2]

sDocName=ReportName&

Note: If the sDocName is not unique, the sPath will need to be
specified. Alternatively, iDocID can be used to identify the docu-
ment.

FileName:

Prompts: [lsSpromptName1=promptValue1

Tip: OpenDocument can also be used with primary visualizations that are
not in InfoView, but which have secondary files in InfoView. The user will be
prompted for InfoView credentials prior to launching the document.

For more information on URL reporting using OpeDocument, see Viewing
Reports and CDocments using URLs in the BusinessObjects XI SDK
developer documentation.

The OpenDocument URL can be entered directly into the URL field of the
URL Button component. The URL Button can also be linked to a URL as text
in a cell of your spreadsheet. In combination with Selector components and
the Excel CONCATENATE function, the URL can be changed dynamically
based on user selection.

Opening an Infoview SWF with Xcelsius 2008

Xcelsius visualizations stored in InfoView can be configured to open
secondary SWF files that are also in InfoView. This is accomplished by adding
the DocumentDownload function to the URL that is used to call the file. The
DocumentDownload function was created by Business Objects to provide a
standard way of opening SWF files that have been published to
BusinessObjects Enterprise.
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Note:

*  DocumentDownload will open the secondary SWF file within Xcelsius,
for example in a Slide Show component. This makes DocumentDownload
the choice for creating a "nested" or "parent-child" visualization within
InfoView.

* Logon credentials are not passed from the parent visualiztion HTML file
when calling a secondary SWF file. Therefore, DocumentDownload
requires appending CELogonToken to the URL.

Basic Structure:

http://<webserver>/businessobjects/enterprisell5/deskto
plaunch/opendoc/documentDownload?<parameterl>&<parame
ter2>&...&<parameterN>&CELogonToken=<>

Note: The URL needs to be URL-encoded if it contains non-URL safe
characters.

Sample URL:

http://cdib5boe:8080/ businessobjects/enterprisell5/deskto
plaunch/opendoc/documentDownload?iDo
cID=10348&sKind=Flash&CELogonToken=SERVER%408757Jxnge3URUJ8L4

The sample URL is structured per below; sections in bold would need to be
customized to the file:

http://
Protocol:
(can be https://)
Server | gisboe:
name:
Port: 8080/
E . | businessobjects/enterprise115/desktoplaunch/opendoc/document
unction:
Download?
iDoclD=10348&
Document
ID*: Note: iDoclD is the ID or the CUID of the SWF file.
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sKind=Flash&

File Type™: Note: sKind must be Flash.

LogonCre

.. | CELogonToken=SERVER%408757JxmheURUJ8L4
dentials*:

**These parameters are required with the documentDownload function.

Tip: To obtain the document ID, navigate to the document in InfoView, hover
your mouse over the document name hyperlink, and look for the ID number
in the browser's staus bar. You can also obtain the document ID from the
Central Managment console.

BusinessObjects Xl Release 3 Notes:

* In Release 3, you can use the sDocName (file name) parameter as an
alternative to the iDoclID.

* In Release 3, the DocumentDownload function is appended to read:
Xcelsius/opendoc/documentDownload?

Note: Additional parameters can be passed into the SWF file by adding
FlashVar ranges to the URL, for example: "Range1=yyy&Range2=zzz&"

To pass the CELogonToken from the parent visualization to a child SWF, a

Flash Variable connection must be added to the primary visualization. Open
the Data Manager, click Add, and select Flash Variables. In addition to the

connection required for the CELogonToken, any additional parameters must
have Flash Variable connections. Any additional parameters are converted
to FlashVars by the Flash Player.

The DocumentDownload URL can be entered directly into the URL field of
the Slide Show component. The Slide Show can also be linked to a URL as
text in a cell in your spreadsheet. In combination with Selector components
and the Excel CONCATENATE function, the URL can be changed
dynamically based on user selection.
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Frequently Asked Questions
Installation questions

Installation questions

Do I need to install Adobe Flash to use Xcelsius 2008?

Adobe Flash player version 9 is required for Xcelsius 2008 to function
properly. If you did not install Adobe Flash as part of the installation process,
you can download and install Flash from the Adobe web site
http://www.adobe.com.

Why doesn't Xcelsius 2008 function after I upgrade
or install Microsoft Office?

When Xcelsius 2008 is installed, it automatically configures itself to work
with the version of Microsoft Office that is installed. If you upgrade or change
the version of Microsoft Office on your machine, Xcelsius 2008 must be
re-installed to work properly with the new version.

Embedded Spreadsheet questions

Why doesn't my Excel formula paste correctly?

You may have more than one instance of Excel open. Excel can only copy
formulas within a single instance of Excel. When Xcelsius 2008 launches, it
opens an instance of Excel in the background. If you subsequently open
Excel, it will open as a second instance, and formulas will not copy between
the two instances.

Tip: You can see how many instances of Excel are running by checking the
Processes tab in the Task Manager.

If you are planning to work with Excel spreadsheets while you work with
Xcelsius 2008, we recommend opening Xcelsius 2008 first, then opening
the Excel spreadsheets you need by navigating to them using the Windows
explorer and double-clicking on them. Do not open the files by using File >
Open in the Excel menu.
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Frequently Asked Questions
LiveOffice questions

Why does the look of my component change when I
copy it into a new visualization?

Some component customization will carry over into a new visualization.
Themes will not carry over into a new visualization, but other customizations
can effect the appearance properties in the new visualization:

» If you have not customized the component, it will take on the properties
of the components in the new visualization.

+ If you have customized the component the properties will carry over.

Why doesn't my visualization display my spreadsheet
customization?

Some Excel functions (conditional formatting and macros, for example) that
are available in the embedded spreadsheet are not supported in Xcelsius
2008 models and will not display properly in your visualization.

LiveOffice questions

Why do all of the spreadsheet columns refresh, instead of just the selected
columns?

When specific columns are selected for refresh in a XLF file that connects
to a Live Office View, all the columns are refreshed in the SWF file, not just
the ones indicated in the XLF. This is because all columns are refreshed
regardless of the column selection. You can, however, select individual rows
to refresh.
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Frequently Asked Questions
Language questions

Language questions

How to | change the language in Xcelsius 2008?

Go to File > Preferences > Languages and select the desired language from
the dropdown menu. Only languages that were selected during installation
will be available in the dropdown menu.

What if the language | want is not listed in Preferences?

Languages are only available in the Preferences drop-down if they were
selected when Xcelsius was installed. To add languages available under
File > Preferences > Languages, you must uninstall Xcelsius 2008 and
re-install the program. During the installation process, you will be asked
which languages you would like to install; the languages you select to install
wil be available in the Preferences drop-down

Microsoft Excel questions

Can I re-import an Excel file with a renamed
spreadsheet?

You can re-import spreadsheets with renamed sheets, but any bindings to
cells in the renamed sheet will be lost.

Why does my table look different than my Excel
spreadsheet?

The Table component only supports the Verdana font. Your Excel
spreadsheets may be using a different font which will result in minor visual
differences between the spreadsheet and your tables. To match your views,
change the spreadsheet font to Verdana.
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Why does my VLOOKUP formula calculate a value
while in Preview mode that is different from the
value calculated in the embedded spreadsheet?

This error can occur if the VLOOKUP formula used in the spreadsheet has
the following conditions: a “range_lookup” of TRUE; the first column of the
“table_array” is sorted in ascending order; and there are sequential duplicate
entries in the in the first column of the “table_array”. This error is caused by
differences in the way Xcelsius and Excel calculate some functions in the
Lookup & Reference category, some of these being VLOOKUP, HLOOKUP,
LOOKUP and MATCH. With the above conditions, Xcelsius will calculate
and return the first matching value in the case of duplicates; Excel will return
the second matching value in the case of duplicates. This is a known issue
with Excel and is addressed by article 181201 on the Microsoft Support
website. To avoid this issue, when possible, it is recommended to use the
“range_lookup” of FALSE.

Microsoft PowerPoint questions

How can I embed an Xcelsius 2008 SWEF file into an
existing PowerPoint presentation?

Within Xcelsius 2008 you can embed your current SWF file into a new
PowerPoint presentation using the Export to PowerPoint options. You can
then cut and paste your SWF into another presentation. See Exporting your
visualization to PowerPoint on page 136 for more information.
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Troubleshooting questions

Why doesn't my component show scientific
formatting?

The visual display of scientific formatted numbers is not supported at this
time. Calculations that are dependent upon scientific formatted numbers are
not affected.

Why doesn't my URL button work?

In order to reference web based content, your URL must include http:// for
it to function correctly.

What happened to the scenarios I saved?

If you are having trouble saving and loading scenarios with the Scenario
button, refer to How does the Local Scenario Button component work? on
page 120.

Why can'tI drag my Slider, Dial, or other single value
component?

The values of single value components that are linked to cells with formulas
cannot be adjusted. This prevents inconsistencies in the visualization.

Why do I receive a Server Busy message?

The Server Busy message means that Excel has a pending operation or is
busy performing an instruction. Check Excel to make sure it is not in the
process of editing and then click Retry on the warning dialog box.
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Why do I receive the message "A script in this movie
is causing Flash Player to run slowly..."?

The Flash Player used to view Xcelsius 2008 visualizations displays this
message when a script has taken more than 60 seconds to run. Due to the
complexity of Xcelsius 2008 visualizations, larger visualizations running on
slow machines may cause this message to be shown, particularly at startup.
If you click No on the message dialog box, the visualization should load

properly.

Note: While in Preview mode, pressing Yes to abort the script causes the
preview to stop working. You will need to exit Preview, then return to Preview
mode, to properly preview the visualization.

Why does my visualization start in a strange state?

When a visualization is loaded, all selectors insert their default selection data
into their Destination ranges to populate other components with data. When
more than one selector inserts into the same range, the selector at the highest
layer inserts last. This overrides the default data inserted by the other
selectors.

You can use the Object Browser to view the order of the components and
change the order using the Layer Options.

Why are my URL-based images not visible in preview
mode?

Relative paths

URL references to images that are relative paths do not display in preview
mode because the preview SWF file is generated in a temporary directory.

When you export the SWF file to a location that will make the relative paths
valid, the images will load properly.
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JPEG files on a web site

If you are referencing JPEG files on a web site, be sure that the JPEG files
are not progressive JPEGs. Progressive JPEGs load in stages, which allows
low-bandwidth users to see an image quickly