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The purpose of this document is to present the process for users to save report filtering and display criteria for subsequent, consistent reuse.

[bookmark: _Toc443331403][bookmark: _Toc496278848]Other, Related Documents
	Document
	Link
	Relevance

	PPM Report Catalog
	https://sharecio.gov.bc.ca/asb/PPM/Shared%20Documents/PPM%20Report%20Catalog.docx
	Provides a listing of all out-of-the-box PPM reports.



The PPM application provides context-sensitive guidance. You may click the ‘Help’ link within the application (upper right of the screen) for materials you feel might not be sufficiently covered in this text.




[bookmark: _Toc496278849]Introduction
A wide number and variety of reports are provided with PPM ‘out-of-the-box’. These are accessed through the Advanced Reporting link under the application’s Home menu.
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Figure 1 - Access to reports appears under the 'Home' menu
Note: Screen examples are captured from the Development/Test environment, and so the colour palette displayed is different from that of the Production environment.
Report filtering, data grouping and display options are offered to narrow and summarize the results displayed and, depending on the report, to affect how information is displayed. Report options may appear blank by default, or may show common, useful settings. The Apply button displays the report with the settings you have selected, while the Reset button allows you to undo your selections to the ‘factory settings’ and restart the filtering/selection process.
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Figure 2 - The Save button will be unavailable until you follow the procedure described below.
Over time and through experimentation, you may develop a preference as to which reports are your favourites. You may want to be able to refer back to these same settings time and again, either as an on-demand report or one that is scheduled to compile on a routine basis.
With the centrally administered set of reports, you will not have the option to click the Save button to preserve your preferred settings. This is because the ‘out of-the-box’ reports are protected against being accidentally revised by users.
The following procedure describes how to create reports with your preferred settings (also known as ‘Report Versions’) that you can save for subsequent reuse.
[bookmark: _Toc496278850]Step One – Create a Replica of the Original Report
The first step in creating a personal Report Version is to create a replica of the original report. This involves copying, navigating and pasting the ‘out-of-the-box’ report into your personal reports directory.
The second step is to open that replica, apply your preferences, and then save your selections.
Note: If you have need for more than one Version of the same Report – for example, a ‘Project Status Report List’ grouped by Project Manager, and another grouped by Department, you will need to follow this step only once; alternate groupings or filtering of a given report would be different Versions of the same Report. These are functions performed exclusively in Step Two below.
[bookmark: _Toc496278851]View the Repository
Open the View -> Repository page. The contents of the reporting Repository will be displayed.
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Figure 3 - Pausing over the 'View' menu option will display the 'Repository' (and other) menu options.
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The Repository is functionally the same as a network file structure, with the ‘root’ of the structure shown at the top. The ‘+’ signs indicate that the folder can be expanded to display the content structure underneath. Once expanded, the folder icon is overlaid with a ‘–‘ sign to indicate that the folder can be collapsed.
The root of the Production environment’s Repository is named cppm9010, while the root of the Development environment’s Repository is named cppm9010_dev.
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Figure 4 - The Repository folder structure display is initially collapsed .
The directories under CA PPM allow users to view but not modify reporting objects (including adhoc views, reports, etc). This protects the integrity of the reports that everyone has rights to use, and needs to rely upon their consistency.
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Figure 5 - Reports (and other objects) in the 'CA PPM' folder are protected from being edited. Users have the ability to share Reports in the ‘Shared’ folder, or to keep private copies in their Users’ personal folder.
Reports are organized into directories, characterized by Report Themes. If a user has a Project Management profile, relevant reports will be displayed under the Project Management themed directory; seen as 'cppm9010 -> CA PPM -> Reports -> Project Management'. If they are also a Portfolio Manager, Financial Manager or Resource Manager, those respectively themed directories will also have reports displayed.
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Figure 6 – The Report Themes a user has access to are displayed in a nested folder structure.
Important Note: If a user has not been given permission to view a Report’s Theme – for example, they are a Project Manager but not a Resource Manager - that respective report directory will be suppressed from display. Hence, the list of an individual’s Report Themes may be different from what is characterized above.
[bookmark: _Toc496274237][bookmark: _Toc496275437][bookmark: _Toc496274238][bookmark: _Toc496275438][bookmark: _Toc496274239][bookmark: _Toc496275439][bookmark: _Toc496274240][bookmark: _Toc496275440][bookmark: _Toc496274241][bookmark: _Toc496275441][bookmark: _Toc496274242][bookmark: _Toc496275442][bookmark: _Toc496274243][bookmark: _Toc496275443][bookmark: _Toc496274244][bookmark: _Toc496275444][bookmark: _Toc496278853]Copy the Desired, Original Report
You have two options. Either:
1. Right-click the name of the report that you would like to copy, then (left-) click the Copy command in the displayed list, or
2. Click to the left of the report’s name, then use the Copy command in the menubar. Options in the menubar are displayed in bold.

Caution: If you (left-) click directly on the report’s name, this will result in the report opening. Click the Back command to return to the Repository display.
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Right-clicking on the report’s name, a floating menu appears.
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Figure 7 - Option 1 using a right-click command.

[bookmark: _Toc496278855]Copy Option #2
Left-clicking next to a report’s name, the Run, Copy and Paste options become available.
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Figure 8 - Screen example before the report has been selected, showing no menu commands available for use.
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Figure 9 - Click next to the report's Name to enable the Copy menu command.
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Navigate through the directory structure to locate your personal Reports directory; in the screen example below, ‘cppm9010_dev -> Users -> pm -> Reports’. When using your own, personal ID – for example in the Production environment -  the directory will take the format of ‘cppm9010_dev -> Users -> {your email address} -> Reports’.
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Figure 10 - Open your personal 'Reports' folder.
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Use the Paste command that appears in the menubar to create your personal replica of this report. The copied report will be displayed in the list on the right-hand side of the screen.
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Figure 11 - A copy of the report has been pasted into your folder.
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Having created a personal replica of the original report, you will now be able to create a ‘Report Version’ comprised of the original Report together with your filtering, grouping and display preferences.
As noted above: If you have need for more than one Version of the same Report – for example, a ‘Project Status Report List’ grouped by Project Manager, and another grouped by Department, you will repeat this step as many times as you wish for as many alternate filtering, grouping and display preferences you have for the same Report. Each subsequent time will create different Versions of this Report.
[bookmark: _Toc494211440][bookmark: _Toc496036214][bookmark: _Toc496274262][bookmark: _Toc496275462][bookmark: _Toc496278859]Open the Report
To open the report, you can simply click on the report’s name. Alternately, you can right-click the report’s name, then either click the Run command that appears in the floating menu, or use the Run command in the displayed menubar. All three options have the same affect.
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[bookmark: _Ref496274275]Figure 12 - Example of the right-click option, then select Run.
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Figure 13 - The 'Save' button is now enabled in your personal copy of the original report.
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Set your desired filtering parameters and display options for the report; each report varies for what is offered to the user. Some selections will be mandatory and some will be optional, depending on the report.
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Figure 14 - In this example, the Project OBS ‘Type’ and ‘Unit’ are optional fields, but the report will not display data beyond what your security privileges permit. You can use these fields to narrow the results displayed in your report.
Note: The OBS Type and Unit fields work in tandem. In order to make use of the Unit field to restrict results to a Department, it is first necessary to select ‘Department’ in the OBS Type field.
You will also be offered options to possibly affect the level of detail displayed and the scope of the contents.
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Figure 15 - This example uses a calendar to allow selection of a date.
Click the Apply button to see the effect of your choices, or the Reset button to restore the options to their original settings.
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[bookmark: _Toc496278861]Save, giving the Report Version a distinctive name
Give the report a distinctive name; is helpful to enter something that provides general indication as to the filtering and display options used, or the proposed usage of the report. As you will see shortly, it is not necessary to repeat the name of the report - for example Project Status Report List – since it will appear in the report list displayed.
[image: ]
Figure 16 - Title describing the report's filtering or options, or its proposed usage.
Click the Save button to complete the process. A ‘Option Saved’ message will be displayed at the top of the screen confirming that your report has been saved.
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Figure 17 – The name provided will be displayed under the report’s ‘Options’.
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[bookmark: _Ref496275139]Figure 18 – Alternate Report Versions will also be displayed under the report’s Options.

[bookmark: _Toc496278862]Repository Results
Prior to applying and saving report parameters - as characterized in Figure 12 above – a single report appeared in the user’s report Repository.
Having saved at least one Report Version, a triangle appears next to the name of the original report.
[image: ]
Figure 19 - A newly appearing triangle appears next to the Report Name.
Clicking the triangle displays the Versions of the given Report.
Note: (Left-) Clicking directly on the report’s name will result in that report being opened for running.
[image: ]
Figure 20 - Names of Report Versions are automatically indented from the name of their original Report.
If you open either the Report Version or the original Report, you will have the choice of selecting a different (or blank) set of report options through the Options drop-down list as characterized in Figure 18 above. Each time you open the report, you will need to click the Apply button to display the results of your parameters and options.
[image: ]
Figure 21 - The 'Apply' button must be used each time a report is opened.
[bookmark: _Toc496278863]Caution
You may notice through the process characterized above that either or both of the Save or the Save As… button become available for your use.
Use of these commands will not result in you saving your preferred combination of a Report plus the Parameters/Options you select; it saves only the report layout, and is mainly of use to those who are creating their own custom reports or modifying the layout of an existing report.
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