Unregistering an NPC/CAPC data source

Document created by Stuart_Weenig on Jul 29, 2014Last modified by Stuart_Weenig on Dec 17, 2016
Version 2Show Document
  • View in full screen mode

The following web services will allow you to unregister a data source from Performance Center. The web service must be launched from the local host desktop. Once the web service is displayed, click the invoke button. The resulting XML should indicate a success/failure.

NFA/ReporterAnalyzer: http://localhost/reporterdatasource/productsyncws.asmx?op=UnregisterPerformanceCenter

NetVoyant: http://localhost/pollerwebservice/productsyncws.asmx?op=UnregisterPerformanceCenter

UCMonitor: http://localhost/VoIPMonitorWebService/ProductSyncWS.asmx?op=UnregisterPerformanceCenter

EventManager: http://localhost/EventManager/ProductSyncWS.asmx?op=UnregisterPerformanceCenter

    You may need an IISReset after this.

    Alternate method on CAPC:

          mysql -P 3308 -D em -e "DELETE from general where Attribute LIKE ‘%NPC.%’;"

          /etc/init.d/caperfcenter_eventmanager restart

SuperAgent: http://localhost/superagentdatasource/productsyncws.asmx?op=UnregisterPerformanceCenter

    It seems there was an issue with superagent unbind that did not clear out all the database entries. At superagent console cmd prompt:

    Mysql -P3308 super -e "delete from parameter_descriptions where level='ProductSync'"

Spectrum: Launch the OneClick web page and select the administration tab. On the left select the Performance Center Integration Configuration. Select the option “Disable”. Re-start tomcat services and try to add the data source.

    If that doesn't work:

  1. Start -> Run: 'bash-login' (Open bash prompt)
  2. > Cd mysql / bin (Go to the $ SPECROOT / mysql / bin directory)
  3. >. / Mysql-uroot-proot
  4. At mysql> drop database netqos_integ;
  5. Then, restart Tomcat Spectrum service.
  6. Then try to add the data source again to CAPC / NPC.

eHealth: For a distributed eHealth environment run the following command on the distributed eHealth console:

          ./nhNpcSetup -clear

          Now try re-adding the eHealth datasource to NPC.

     For standalone eHealth environments, execute the query below to clear the NPC config from the eHealth DB:

          $NH_HOME/bin/sys/nhisql "delete from nh_metadata where subject_area='NPC'"

     If the change doesn’t immediately allow for the datasource to be re-added, try the steps below to get it going.

  1. Bring down the ehealth web, httpd and tomcat. (maybe something is caching the value)
  2. Re-check to make sure there are still no NPC values in that table.
  3. Bring back up the ehealth web, httpd and tomcat.
  4. Try to join npc to ehealth again.

     Alternate method:

  1. Log into Oracle SQL developer
  2. Expand “Tables”
  3. Select the NH_METADATA table from the tree on the left hand side
  4. In the right hand panel select the “Data” tab
  5. Use the shift key to multi-select the 5 entries that have “NPC” in the SUBJECT AREA field
  6. Hit the “Red X” at the top of the page to “Delete Selected Rows”
  7. Hit the “Green Check Mark” to “Commit Changes”