Tech Tip: The ehealth Web server doesn't start with option -passphrase

Document created by A.Poissonnier Employee on Nov 4, 2014Last modified by A.Poissonnier Employee on Dec 17, 2016
Version 2Show Document
  • View in full screen mode

Description Behavior

To configure the webserver with SSL you use the command nhWebProtocol which restarts the webserver.

If the option -passphrase is used the server is not started and cannot be startedmanually with "nhHttpd start".

 

Comment

The Health Apache uses the following command to read out the key pass phrase out of /opt/eHealth/sys/ehUsers.cfg: /opt/eHealth/web/webCfg/nhManageSsl.

This  ommand calls then /opt/eHealth/web/webCfg/nhiManageSsl. Noticed that in the environment of nhiManageSsl the env variable TZ is not set.

If  that var is not set, the command nhiManageSsl fails to run:                

                                                                           

-bash-3.00$ /opt/eHealth/web/webCfg/nhiManageSsl -decrypt                  

Fatal Internal Error: Invalid time zone parameter ''. (cos/cosTzSet)       

                                                                           

Work Around

1)   Edit $NH_HOME/web/webCfg/nhManageSsl

2)   Add the following at the beginning of the script after the comment

header:

                TZ=${TZ:-MET}; export TZ

3)   Save, then nhHttpd stop/nhHttpd start

Attachments

    Outcomes