Upgrade WAAE 11.3.5 INC3 TO HIGHER RELEASE FAIL

Document created by zgofa01 Employee on Aug 31, 2015
Version 1Show Document
  • View in full screen mode

Problem Description:

--------------------------------

 

Upgrade from CA WorkloadAutomation AE r11.3.5 INC3 Server to

future release fail with following error:

x Entry     "/opt/CA/WorkloadAutomationAE/autosys/lib/libsafe.so" is not a s

ymbolic link.

x Reason:   The specified file system entry exists, but is a regular file or

  a directory.

x Action:   Check if the entry can be removed and repeat the installation

 

Solution:

-------------

 

CA WAAE 11.3.5 INCR4

CA WAAE 11.3.5 INCR3 + RO83925

 

Workaround

-----------------

 

Remove  libsafe.so/sl file and create softlink as follow

For HP-UX only

        $ rm -rf libsafe.s1

        $ ln -s  libsafe12.sl libsafe.sl

        $ chown -Rh autosys:autosys libsafe.sl

For Linux, AIX or Solaris

        $ rm -rf ibsafe.so

        $ ln -s  libsafe12.so libsafe.so

        $ chown -Rh autosys:autosys libsafe.so

        Note: Change the ownership as appropriate.

Attachments

    Outcomes