Tech Tip: SCOM Connector Service starts and stops

Document created by ScottOrzechowski Employee on Nov 17, 2015Last modified by ScottOrzechowski Employee on Dec 17, 2016
Version 2Show Document
  • View in full screen mode

CA Spectrum Tuesday Tip by Scott Orzechowski, Principal Support Engineer, February 2, 2012



Description:

After installing the Spectrum SCOM Connector and attempting to start the Spectrum SCOM connector service, the service starts and stops. Windows pops up a message that says:

"The Spectrum SCOM connector service started and then stopped. Some services stop automatically if they are not in use by other services or programs."



Check out the <$SPECROOT>/SCOMConnector/CONNECTOR_DEBUG.OUT file. It will tell you what has failed.

It could be that the file .scomrc does not exist in the
<$SPECROOT>/SCOMConnector directory with permissions, or it is not named “.scomrc.”

...or it could be that the system does not resolve the hostname of either
the ssHost or scomHost in the <$SPECROOT>/SCOMConnector/.scomrc file. Try fully qualifying the
hostnames. See what Windows returns on the command line for

nslookup <the name you have entered in the .scomrc file for ssHost>
nslookup <the name you have entered in the .scomrc file for scomHost>
ping -a <the name you have entered in the .scomrc file for ssHost>
ping -a <the name you have entered in the .scomrc file for scomHost>

Edit the .scomrc file so that the entries match what the system returns.

Attachments

    Outcomes