Tech Tip: Graphics Not Displaying under "Interfaces" Tab in NFA GUI

Document created by KahlilVThomas Employee on Dec 18, 2015
Version 1Show Document
  • View in full screen mode

Issue:

Attempting to generate charts under "Interfaces" in the NFA Web GUI. After the initial spinning icon, the charts fail to appear and are replaced by "X" icons. Yet, there are no problems running Custom Reports to access the same data.

 

Environment: 

 

NFA Web interface using any supported browser.

 

Cause:

 

Whenever charts are generated or refreshed, new Chart*.PNG files are generated in the following directory on the NFA Master Console machine:

reporter\NetQoS.ReporterAnalyzer.Website\graphics

If there is a problem accessing that directory, then charts cannot be displayed.

 

Resolution:

 

  1. 1. If no Chart*.PNG files are getting created, there may be a permissions problem accessing 'reporter\NetQoS.ReporterAnalyzer.Website\graphics'.

Make sure that the 'Authenticated User' account has Full Control over the \graphics directory.

 

  1. 2. If there are many thousands of old Chart*.PNG files stuck in the 'reporter\NetQoS.ReporterAnalyzer.Website\graphics' directory, then NFA may time out when attempting to display the graphics. In this case, the old Chart*.PNG files can be safely deleted. Files in this directory that are more than a few hours old should get automatically deleted when you attempt to access new charts, but if there are a large number of stuck files then Windows might start having problems cleaning up the old files. Eventually, if there are too many files stuck in this directory, NFA might not be able to display charts anymore.

 

 

This was published as Tech Doc TEC1402792 http://www.ca.com/us/support/ca-support-online/product-content/knowledgebase-articles/tec1402792.aspx

Attachments

    Outcomes