TEC1959465: Agent connecting in disallowed or denied mode

Document created by musma03 Employee on May 25, 2016Last modified by SamCreek on May 25, 2016
Version 2Show Document
  • View in full screen mode

Document ID:  TEC1959465

Last Modified Date:  9/11/2015
Author: musma03

 

  • Products
    • CA Application Performance Management
  • Releases
    • CA Application Performance Management:Release:CA APM 9.7
    • CA Application Performance Management:Release:CA APM 9.6
    • CA Application Performance Management:Release:CA APM 9.5
    • CA Application Performance Management:Release:9.7
    • CA Application Performance Management:Release:9.6.1
    • CA Application Performance Management:Release:9.6
    • CA Application Performance Management:Release:9.5.6
    • CA Application Performance Management:Release:9.5.5
    • CA Application Performance Management:Release:9.5.3
    • CA Application Performance Management:Release:9.5.2
    • CA Application Performance Management:Release:9.5
    • CA Application Performance Management:Release:9.5.1
  • Components
    • APM AGENTS

 

 

 

Introduction:

If an Agent is not showing up in the Investigator, it may be connecting in disallowed (aka denied) mode.

 

Instructions:

There are two ways to check if an Agent is connecting in disallowed mode:

1. Check the Agent log for a message like this:

[INFO] [IntroscopeAgent.ConnectionThread] Connected to mom.ca.com:5001,com.wily.isengard.postofficehub.link.net.DefaultSocketFactory in disallowed mode.

 

2. Check the APM Status Console for any denied agents.

disallowed.png

 

As shown above, a Weblogic Agent has connected, but is in denied or disallowed mode.

 

There are a few causes for this:

1. A configuration in loadbalancing.xml that is preventing an agent from connecting to any Collector.

2. Agents are denied connection when any of the following conditions occur:

  a. The introscope.apm.agentcontrol.agent.allowed property is set to true AND loadbalancing.xml disallows the agent.

  b. The introscope.apm.agentcontrol.agent.allowed property is set to false AND loadbalancing.xml does not explicitly allow the agent.

  c. Either of these clamp values are reached or exceeded:

      introscope.enterprisemanager.agent.disallowed.connection.limit

      introscope.enterprisemanager.agent.connection.limit

 

Additional Information:

If the above does not help resolve this issue, then do the following to investigate further:

1. Open a Support Case

2. Upload the zipped contents of <EM HOME>/logs (debug enabled if possible) from both the MOM and Collectors.

3. Upload loadbalancing.xml from the <MOM HOME/config directory.

4. Provide a screenshot of the Agent controllability/supportability metrics located in:

  Superdomain | Custom Metric Host | Custom Metric Process | Custom Metric Agent | Enterprise Manager | Connections | Disallowed Agents Clamped

  Superdomain | Custom Metric Host | Custom Metric Process | Custom Metric Agent | Enterprise Manager | Connections | Number of Disallowed Agents



 

Search the Entire CA APM Knowledge Base

 

search-kb.jpg

Attachments

    Outcomes