Tech Tip:  How to display double byte characters (Chinese, Japanese, Korean) in messages on UIM 8.4

Document created by David_Kim Employee on Oct 16, 2016Last modified by SamCreek on Dec 17, 2016
Version 5Show Document
  • View in full screen mode

Summary: 

By default, double byte characters (Chinese, Japanese, Korean) in messages are garbled in IM/USM/UIM database.

To display the double characters properly, it requires to remove -Dfile.encoding=UTF-8 java option from the probes related with handling messages.


Instructions:

Step1 details:
1. From IM, select wasp probe
2. Right-click and select Configure from menu
3. Click Setup tab in the wasp configuration dialog
4. Remove -Dfile.encoding=UTF-8 option from Extra Java VM arguments field
5. Click Apply and OK to close the dialog


Step2 details:
1. From IM, select alarm_enrichment probe
2. Right-click and select Edit…from menu
3. In Arguments field, remove -Dfile.encoding=UTF-8
4. Click OK to close the dialog


Step3 details:
1. From IM, select trellis probe
2. Right-click and select Edit…from menu
3. In Arguments field, remove -Dfile.encoding=UTF-8
4. Click OK to close the dialog

 


Additional Information:

The latest CA UIM 8.47 is not available in the Korean language.

https://docops.ca.com/ca-unified-infrastructure-management/8-47/en/upgrading-release-notes/release-notes

2 people found this helpful

Attachments

    Outcomes