Tech Tip : CA Single Sign-On : Getting HTTP 500 Internal Server error when accessing an URL ending with ".sac" extension

Document created by Albert_Fernandez Employee on Nov 2, 2016Last modified by kristen.palazzolo on Dec 17, 2016
Version 3Show Document
  • View in full screen mode

Problem: 

We are getting a HTTP 500 internal server error when we try to access an URL with .sac extension. When we disable the agent, this error doesn't appear, but with the agent enabled always appears an internal server error before the form is shown.

URL Example:
https://localhost.server.com/resource.htm -> runs OK
https://localhost.server.com/resource.sac -> gets HTTP 500 internal server error

To try to solve this error, we have verified that the IgnoreExt ACO parameter is configured with the .sac extension, but it was unsuccessful.

 

Environment:  

Web Agent R12.52, R12.52 SP1 (prior to CR04)

 

Cause: 

For Session Assurance feature the Web Agent introduced the ACO parameter SACExt where the file extension can be defined, and its default value is ".sac" even if no Session Assurance is configured as it is disabled by default.

This extension is used by other software as MatLab, SAC (Seismologic software) and also corresponds to Adobe Shared Asset Catalog.

Therefore the Web Agent interprets this request as a Session Assurance request and causes the error "Missing SESSION for updating the session spec" in Policy Server log, as it cannot find Session Assurance flow data needed, and ends the transaction with error "Exiting with HTTP 500 server error '30-0002'"

 

Resolution/Workaround:

As workaround, you can modify the ACO by adding the parameter SACExt and set it to a different extension to do not use the default value ".sac", like ".test"

This was fixed in R12.52 SP1 CR04.

 

KD : TEC1447652

Attachments

    Outcomes