Tech Tip : CA Single Sign-On : R12.52 SP1 Federation Manager AdminUI is not accessible after an upgrade

Document created by Albert_Fernandez Employee on Dec 21, 2016
Version 1Show Document
  • View in full screen mode

Issue:

I have recently upgraded our standalone Federation Manager server which was version R12.52 SP1 to CR04. There were no errors reported during the installation nor any errors seen in the installation logs. But now, when I try to access the Web AdminUI of the Fedma server I cannot open the UI and there are no errors in the log. 
I am not sure what could have caused the issue after the upgrade. This is a standalone install and uses all default components included the SPS server and the IWA agent. The services stop and start without any errors.

 

Environment:

CA Federation Manager R12.52 SP1 CR04

 

Cause:

The upgrade behavior in CR04 was slightly changed to address a known issue which affects "local.host" server.conf parameter, which if it was previously set to "localhost", it needs to be changed before or after the upgrade process.

 

Resolution:

In order to solve the issue, you need to do the following steps:

  1. Backup and Edit server.conf file under <your Federation Manager home path>\secure-proxy\proxy-engine\conf folder.
  2. Locate the line with parameter local.host (you may find it set as "local.host=localhost", and set it as follows: local.host=*
  3. Save changes and restart Federation Manager services.

Now your AdminUI is accessible again.

 

Additional Information:

KD : TEC1599058

Attachments

    Outcomes