Tech Tip: UIM - Errors during upgrade from UIM v8.4 to v8.51

Document created by danst04 Employee on Mar 13, 2017Last modified by danst04 Employee on Mar 13, 2017
Version 3Show Document
  • View in full screen mode

Document ID:  TEC1415335
Last Modified Date:  03/11/2017
Show Technical Document Details

 

Issue:

Customer tried to upgrade from 8.4 to 8.51 and saw errors upon finishing.

 

Install scenario: Test system with UIM and UMP installed on the same machine.

 

Environment:
- UIM v8.4
Cause:

The installation (as you can see from the install log), did not complete properly.

uimserverpackages.zip package was not full downloaded.

 

Resolution:

We determined that the installation (and as you could see from the install log), did not complete properly. The service_host probe was still present and enabled, and http://<localhost>:<port>/adminconsoleapp was not accessible.

 

Moreover, the mps package version 8.5 or any other version of mps was NOT present in the archive and the uimserver_home 8.50 package was also not present in the local hub archive.

 

We checked the uimserverpackages.zip on the primary hub's filesystem and found that the size of it was not correct. The size of the file was 1,256,795 Kb and the proper size should be ~2.2 GB or 2,246,786 Kb.

 

When the customer was downloading it again, we also noticed that their McAfee applciation performs a scan on the file. In a few cases we have seen that the file may finish downloading but show NO evidence of a 'partial' file download and the browser may consider it complete (but the size is off).

 

Once something like this occurs, the file needs to be downloaded again and the UIM install can then be rerun.

 


After the install, the admin console should be accessible via:

 

http://<uim_primary_hub>:<port>/adminconsoleapp

 


and the UIM server home page should be accessible at:

 


http://<uim_primary_hub>:<port>/uimhome/

 

Note that the wasp port for the admin console and the uimhome page defaults to port 80.

 

Notes:
Even though it is a test environment, it is recommended that customers follow the requirements/recommendations for installing UIM, UMP and the backend Database on a different server, and CABI on its own robot attached to the primary hub. This is due to recent changes and would be the best to maintain in terms of testing and rollout routines as well as to ease data management. Virtual machines would be best for fast local resource changes if possible.

 

Note that you must install CABI Server on a robot connected directly to the primary hub. Do not deploy CABI Server on a robot running UMP. A separate robot is advisable to avoid scale and performance issues. Please note that it is recommended not to install CABI Server on a robot connected to a 'secondary' hub as this configuration is not supported.

 

Be careful about the JAVA version and path too - always check the release notes and/or CA Community for gotchas/known issues.

 

Re-download uimserverpackages.zip and rerun the installation.

1 person found this helpful

Attachments

    Outcomes