CA UIM CABI (Jaspersoft) - Configuring the report scheduler for email notifications

Document created by Phani Devulapalli Champion on Apr 5, 2017Last modified by Phani Devulapalli Champion on Apr 5, 2017
Version 2Show Document
  • View in full screen mode

I am sharing this as a document in community for quick access in case anyone needs it. I was looking for similar information when I was configuring the scheduled reports in CABI today morning and could not find this part of the CA UIM documentation and had to search through the Jasper documentation to find the steps.


Hope it would be helpful to everyone.


CA UIM 8.4.7 

CABI 1.0

In order for the CABI scheduler to successfully send email notifications and distribute reports, it must be configured to connect to an outbound email server.


Below are the steps to be followed for configuration


1. Login to the server where you have installed the cabi probe and open the following configuration file in your preferred text editor: 

    C:\Program Files (x86)\Nimsoft\probes\service\wasp\webapps\cabijs\WEB-INF\ js.quartz.propertie


2. Set the value for the property to your outbound mail server



3. Set the mail.sender.username and mail.sender.password properties using valid login credentials to your outbound mail server. (only if needed)

    Example: report.scheduler.mail.sender.username=myusername      



4. Set the value for the mail.sender.from property to the email address you would like emails to come from.



5. Set the value for the mail.sender.protocol property to the protocol used by your outbound mail server.

    Example: report.schedulers.mail.sender.protocol=smtp


6. Set the value for the mail.sender.port property to the port that your outbound mail server listens on.

    Example: report.schedler.mail.sender.port=25


7. As an additional step, if your SMTP server requires authentication as noted in step 3 above , "mail.smtp.auth" parameter in the below file needs to be set to “true”

    C:\Program Files (x86)\Nimsoft\probes\service\wasp\webapps\cabijs\WEB-INF\ applicationContext-report-scheduling.xml


     Change from “false “to “true” for the below

                 <prop key="mail.smtp.auth">true</prop>


8.Restart wasp and cabi probe for the configurations to take effect.


For more information please refer to the below

4 people found this helpful