After upgrading the XenApp probe to 1.20 it cannot connect to the Citrix XenApp server.

Document created by Richard_Little Employee on Jul 14, 2017
Version 1Show Document
  • View in full screen mode

Techdoc TEC1420805

Published 14 July 2017

Issue

  • After upgrading the XenApp probe to 1.20 it cannot connect to the Citrix XenApp server.
  • When clicking test the error “An unexpected exception occurred while testing the resource. Please retry your test.” is received
  • Have verified all pre-requisite configurations have been made
  • kerberos is configured
  • WinRM is configured
  • the following is seen in the XenApp probe log at level 3

Error, Get-XAFarm: No connection could be established with "net.tcp: //************: 2513 / Citrix / XenAppCommandsRemoting". The connection attempt has lasted for a period of 00: 00: 03.0420585. TCP Error Code 10061: A connection could not be established because the target computer denied the connection ***.***.***.***:2513. 

Environment

CItrix XenApp Server 6.5

Cause

  • The XenApp probe requires the "Citrix XenApp Commands Remoting" service to be running on the Citrix XenApp Server.
  • This service tries to download the certification revocation list from Microsoft and if it does not succeed in a timely manner it will not start.
  • If the XenApp server does not have internet access then this service will never start

Resolution

  1. Enable internet access on the XenApp Server

    OR

  2. Create a file called "Citrix.XenApp.Commands.Remoting.Service.exe.config" with the following contents: 

    <?xml version="1.0" encoding="utf-8"?> 
    <configuration> 
    <runtime> 
    <generatePublisherEvidence enabled="false" /> 
    </runtime> 
    </configuration> 

    Copy this file into: "C:\Program Files\Citrix\XenApp Commands" (assumes default install path)
    Restart the "Citrix XenApp Commands Remoting" service 

Attachments

    Outcomes