TEC TIP: cabi probe v3.0 deployment problems

Document created by Ryan Dunn Employee on Aug 25, 2017
Version 1Show Document
  • View in full screen mode

Summary:

New deployment of the cabi probe (v3.0). The probe appeared to deploy successfully however, it didn’t extract any files or even attempt the jaspersoft installation. The cabi wasp probe also does not start and is in an error state (no port or pid). Also, no /c/ folder or tables in db, cabi dashboards not working in the UMP - cabi probe log file: 

 

Aug 21 17:59:27:032 [main, cabi] Login to NimBUS is OK 

Aug 21 17:59:27:032 [main, cabi] cabi is configured in inactive mode. 

Aug 21 17:59:27:032 [main, cabi] Changing probe state from 'INITIALIZING' to 'INACTIVE' 

Aug 21 17:59:27:032 [main, cabi] cabi_mode is inactive, probe will run but will not be active 

Aug 21 18:02:26:916 [attach_socket, cabi] changed the account name to be same as default organization; accountName=UIM 

Aug 21 18:02:26:916 [attach_socket, cabi] Error: Probe.cbEnsureUserExists - userSynchronizer was null 

 

Environment:

  • UIM 8.51
  • cabi probe v3.0
  • cabi robot 7.80
  • cabi wasp 8.51
  • SQL Server (using sa user in data_engine)

 

Instructions:

  1. Uninstall the cabi wasp probe:
  • If cabi is installed on a separate robot:

- delete wasp probe from IM or Admin Console

- delete directory C:\Program Files (x86)\Nimsoft\probes\service\wasp (on the cabi robot)

 

  • If cabi is installed along with UMP or UIM server:

- delete the cabijs app in wasp probe through probe utility.

 

  1. cabi probe:
  • deactivate the cabi probe from IM or Admin Console (do not delete it)
  • login to your database server and copy and execute commands specified at the following path:

- C:\Program Files (x86)\Nimsoft\probes\service\cabi\config\scripts\drop_tables\1.2\sqlserver (assuming sql server db)

  • Make sure that all script commands are run successfully.
  • Delete the cabi probe from IM or Admin Console

 

  1. cabi robot:
  • delete directory: C:\Program Files (x86)\Nimsoft\probes\service\cabi
  • delete C:\Program Files (x86)\Nimsoft\c

 

  1. Re-install cabi 3.0.0 probe:
  • Drag and drop cabi 3.0.0 and the latest version of uim_core_dashboards_pack onto the robot
  • Once it is green then go to Raw Configure and change the cabi_mode value to bundled. This triggers cabi installation; wait for the installation to complete.
  • Ensure the ump_cabi v3.0 package is deployed to the ump wasp robot.

 

Additional information:

Install or Upgrade for a Bundled CA Business Intelligence JasperReports Server - https://docops.ca.com/ca-unified-infrastructure-management/8-5-1/en/installing-ca-uim/ca-business-intelligence-with-ca-uim/installing-and-upgrading-ca-business-intelligence-jasperreports-server-with-ca-uim/install-or-upgrade-for-a-bundled-ca-business-intelligence-jasperreports-server

7 people found this helpful

Attachments

    Outcomes