Support for a modern HSM within Auth/RiskMinder

Idea created by ArronBrice on Aug 18, 2016
    Under review
    Score3
    • RobM
    • JMCColorado
    • CBertagnolli

    Currently the advanced auth product supports two HSM products that are over 8 years old and no longer supported by the hardware vendors. So in essence advanced auth no longer supports an HSM... The request is to update the support libraries to support the existing versions of the two HSM products, in particular the SafeNet 6.x HSM software (presently supports 4.x).

     

    This support is needed in order to make advanced auth be compliant to issue NIST LOA-3 based credentials. Public agencies are moving toward stronger security models to protect government systems and citizen data. If this change is not made, the Advanced auth product will not be able to be used within those agencies and we will have to look for other solutions.