Improve GMU<=>Gateway version compatibility

Idea created by MattVan on Feb 13, 2018
    New
    Score9
    • wauch01
    • Abhishek_Bose
    • nyawe01
    • StPaulPete
    • Carlo JAMAR
    • RemcoDekker
    • MattVan
    • CBertagnolli
    • mosg

    GMU needs to provide at least some minor level of forward and/or backward compatibility with API Gateway versions.  E.g. GMU 9.2 compatible with Gateway 9.2 or 9.3.  In organizations large enough to have dev, test, production, etc. environments, it isn't feasible or reasonable to expect all environments to upgrade at the same time.  There will be weeks (months?) where different minor versions are running in each environment.  GMU-based migration still needs to be possible during the transition time.