Axis 1.4 client upgrade to new version for APM connector for SOI

Idea created by Britta_Hoffner Employee on Nov 27, 2018
    New
    Score9
    • UdoC
    • christian.gubo
    • welge
    • Tobias_Unbereit
    • Kristian_S
    • ReWi
    • support1107.1107
    • Britta_Hoffner
    • Andre_H

    APM connector 3.6.2 for SOI 4.2 is using Axis 1.4 client. The SOAP call is sometimes causing exception:

     

    2018-11-05 02:40:25,926 DEBUG [MdrMonitorThread] connector.ApmConnector - isSystemUp::Exception: Cannot connect to Introscope EM at PB2XAPM11:8444. Cause: java.util.ConcurrentModificationException.
    java.net.ConnectException: Cannot connect to Introscope EM at xxxxxxx:8444. Cause: java.util.ConcurrentModificationException
    at com.wily.introscope.client.alerts.manager.SSLEnabledIntroscopeClient.validate(SSLEnabledIntroscopeClient.java:130)
    at com.ca.wily.apm.connector.ApmConnector.isSystemUp(ApmConnector.java:1545)
    at com.ca.sam.ifw.framework.Silo$MdrMonitorThread.run(Silo.java:1797)

     

    This problem is mentioned in

     

    https://stackoverflow.com/questions/52218759/axis-client-1-4-with-jdk-8-gives-org-apache-axis-axisfault-java-util-concurrent

     

    According to this new Axis client version has to be certified for SOI 4.2