AnsweredAssumed Answered

GEL - possible SSL error?

Question asked by alex.sinclair on Jan 22, 2013
Latest reply on Feb 1, 2013 by nick_darlington
Hi,

I have a process with a GEL script contained within. The script should XOG in a list of Resources from an Excel spreadsheet however I'm hitting an error very early on which I think might be related to our environment running SSL or possibly just some syntax error on my part in setting up my XOG connection params

Seperate note - we have current issue whereby the cert for our Dev environment is not named correctly (ie doesn't match the hostname) which I've been told will mean I cannot run my code from the cmd prompt. However I believe it should work if executed within a process (please correct me if wrong)

The actual error I'm getting back after excuting the process is as follows:
[XOG]XOG failed: org.apache.commons.jelly.JellyTagException: null:50:59: <soap:invoke> Failed to send a SOAP message generated to 'https://sw610niku:8043/niku/xog'.HTTPS hostname wrong: should be <sw610niku>
The error appears to be relating to the invoke SOAP part of the script.

Snippets of code (I can provide more if required however I think these are the important bits relating to the error)
<!-- *****************************************************************
< 1 Establish GEL   
< ***************************************************************** -->
<gel:script 
xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" 
xmlns:core="jelly:core" 
xmlns:gel="jelly:com.niku.union.gel.GELTagLibrary" 
xmlns:file="jelly:com.niku.union.gel.FileTagLibrary" 
xmlns:soap="jelly:com.niku.union.gel.SOAPTagLibrary" 
xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" 
xmlns:sql="jelly:sql" 
xmlns:xog="http://www.niku.com/xog" 
xmlns:xsd="http://www.w3.org/2001/XMLSchema" 
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<gel:parameter var="p_XOGURL" default="https://sw610niku:8043"/>
<gel:parameter var="p_XOGUsername" default="admin"/>
<gel:parameter var="p_XOGPassword" default="changeme" secure="true"/>
<!-- *****************************************************************
< 4 Invoke SOAP 
< ***************************************************************** -->
<gel:out>[XOG]Logging into Clarity XOG at ${p_XOGURL}.</gel:out>
<gel:log level="INFO" category="XOG">Logging into Clarity XOG at ${p_XOGURL}.</gel:log>
<core:catch var="v_xog_exception">


<soap:invoke endpoint="${p_XOGURL}/niku/xog" var="auth">



<soap:message>




<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xog="http://www.niku.com/xog">





<soapenv:Header/>





<soapenv:Body>






<xog:Login>







<xog:Username>${p_XOGUsername}</xog:Username>







<xog:Password>${p_XOGPassword}</xog:Password>






</xog:Login>





</soapenv:Body>




</soapenv:Envelope>



</soap:message>


</soap:invoke>
Any ideas what I'm doing wrong here? Happy to provide more information but I'm hoping it's something simple I'm getting wrong

Thanks

Alex

Outcomes