AnsweredAssumed Answered

Error Xogging through GEL script but not when Xog client is used

Question asked by Pankaj_Navlekar on Feb 28, 2013
Latest reply on Mar 1, 2013 by Chris_Hackett
Hi,

I am trying to XOG in a custom object instance through a process GEL script. The process creates a gel script like the one below;

<?xml version="1.0" encoding="UTF-8"?> <NikuDataBus xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="../xsd/nikuxog_customObjectInstance.xsd"> <Header action="write" externalSource="NIKU" objectType="customObjectInstance" version="12.1.0.5840"/> <customObjectInstances objectCode="sun_ts_app_job"> <instance instanceCode="TS_AUTO_10" objectCode="sun_ts_app_job"> <CustomInformation> <ColumnValue name="name">TS_AUTO_10</ColumnValue> <ColumnValue name="code">TS_AUTO_10</ColumnValue> <ColumnValue name="sun_ts_app_run">false</ColumnValue> <ColumnValue name="page_layout">odf.sun_ts_app_jobFrame</ColumnValue> </CustomInformation> </instance> </customObjectInstances> </NikuDataBus>


But when the gel script tries to xog, I get an error, given below. When I xog this very XML via xog client it does it all fine

Error XML =

<?xml version="1.0" encoding="UTF-8"?> <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"> <soapenv:Header/> <soapenv:Body> <XOGOutput xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="../xsd/status.xsd"> <Object type="customObjectInstance"/> <Status state="SUCCESS"/> <Statistics failureRecords="1" insertedRecords="0" totalNumberOfRecords="1" updatedRecords="0"/> <Records> <Record> <KeyInformation> <column name="sun_ts_app_job">TS_AUTO_10</column> </KeyInformation> <ErrorInformation> <Severity>FATAL</Severity> <Description>com.niku.union.odf.exception.ODFServiceException: &lt;?xml version="1.0" encoding="UTF-8"?&gt; &lt;insertService type="xbl" componentId="odf" description="custom/customInsertService.xbl" transaction="dbTransaction" xmlns="http://schemas.niku.com/2002/objectTypes"/&gt; </Description> </ErrorInformation> </Record> </Records> </XOGOutput> </soapenv:Body> </soapenv:Envelope>

Please help!!

Regards

Outcomes