AnsweredAssumed Answered

Reports and Jobs Webi Report only works with Saved Parameters

Question asked by Fair32 on Jul 26, 2013
Latest reply on Aug 29, 2013 by Fair32
Looking for anyone else that has experienced this issue with running a webi report from the v13 Clarity side (Reports and Jobs as opposed to using InfoView).

After v12.1 upgrade to 13.1, existing reports will not run from Reports and Jobs without first saving parameters (worked fine just using "submit" with v12).
User gets error: "RPT-0007: Specified report did not execute properly".
And even if you save parameters first, all the parameters are not always respected with the returned data.

Error that appears on the CMC side is that Clarity is trying to pass bad parameter values "The prompt 'param_t_obs_unit' contains an invlaid numeriv value. (WIS 10705)". If you save the parameters first in Clarity though, and then run the report, it passes the correct values (ID # instead of text).

Webi works fine if you go in through InfoView.
It appears to be happening with the call from Clarity to Webi. Ruled out browsers and load balancers, and have tried on three different environments.

Please let me know if you have experienced anything similiar.

Thank You


Clarity v13.1 fix pack 4
BO 3.3

Outcomes