Suman Pramanik

Slow Timesheet Posting after upgrade to 13.1.

Discussion created by Suman Pramanik Employee on Aug 29, 2013
Latest reply on Aug 29, 2013 by sundar
Large Clarity customers with Oracle as database when upgraded to Clarity 13.1 from 12.x experiencing major performance issues with the timesheet posting job.


1. Stop Clarity Services

2. Edit properties.xml file and make the following changes

3.
Disable Action Trace.
In the properties.xml file, add the two highlighted addition properties in the <logger> element. Do this on all Clarity application servers. Don’t remove or add any other property. The order does not matter.
<logger alternateDirectory="" traceEnabled="false" traceJDBCEnabled="false" dynamicConfigurationEnabled="true" traceAlarmThresholdSeconds="0" multitenantErrorReportingEnabled="false"/>

4. Reload the file using command admin general upload-config

5. Restart app and bg to take effect.

Try to see the performance and see if it improves, if it doesn't then perform the other two steps.

6.Create a custom index on the PRAssignment table and gather stats.
CREATE INDEX Z_PRASSIGNMENT_01 ON PRASSIGNMENT
(PRTASKID, PRRESOURCEID,PRACTTHRU)
TABLESPACE INDX_LARGE;

7.Disable the On The fly rate matrix feature.
Update cmn_option_values set value=0 where option_id = (select id from cmn_options where option_code='PRJ_RT_RATES_EXTRACTION');
commit;

Regards
Suman Pramanik

Outcomes