AnsweredAssumed Answered

WTG on Linux Issues (9.1.4.0)

Question asked by Ramiro.Estrada on Nov 12, 2013
Latest reply on Nov 18, 2013 by Ramiro.Estrada

Ive been using WTG on Windows in a very simple means successfully for a few months.  Switching over to linux and now there is a handful of issues we're running into.

1) The agent is installed and making requests but they are failing due to SSL Handshake errors even on non-SSL sites.

2) The Introscope DataAPI which seems to be just an EPAgent is failing to run because it was picking up the IntroscopeNativeDataReporter.exe file which isnt appropriate for linux.  So I renamed it so that it doesnt detect it and proceeds with the java startup.  Then found that it was missing the EPAgent.jar file, so I supplied it from a proper EPAgent install

Now we are failing with the following:
 

11/12/13 10:40:18 AM PST [ERROR] [EPAgent] EPAgent failed to start because: Introscope EPAgent has no plugins configured and no network ports enabled. Exiting.
com.wily.introscope.epagent.IllegalConfigurationException: Introscope EPAgent has no plugins configured and no network ports enabled. Exiting.
        at com.wily.introscope.epagent.EPAgent.start(EPAgent.java:356)
        at com.wily.introscope.epagent.EPAgent.main(EPAgent.java:513)
        at com.wily.introscope.api.IntroscopeEPAgent.main(IntroscopeEPAgent.java:55)
 
 
Question is, which are the proper plugins for the WTG Agent?  

Outcomes