AnsweredAssumed Answered

WTG (9.1.4.0) on Linux - SSL Handshake Errors

Question asked by Ramiro.Estrada on Nov 18, 2013
Latest reply on Dec 11, 2013 by Hiko_Davis

Having some issues with WTG agent on linux in that all of my scripts which worked perfectly fine while running on windows agents, are now throwing SSL errors.  I have tried a variety of different settings in the scripts (enable/disable wininet, sslversion2/23) and they still fail with a variety of differnet errors but all handshake related.  The errors even seem to happen for non https sites.

Here are a few:

With sslversion=23

1|C|30000|30000|0|0|14|Connect error: 11:SSL Handshake Failed: error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure|https://website.domain.com/some/path?some=params%20to%20send||1|

With sslversion=3

1|C|30000|30000|0|0|16|Connect error: 11:SSL Handshake Failed: error:14094410:SSL routines:SSL3_READ_BYTES:sslv3 alert handshake failure|https://website.domain.com/some/path?some=params%20to%20send||1|

With sslversion=2

1|C|30000|30000|0|0|2|Connect error: 11:SSL Handshake Failed: error:140650B5:SSL routines:CLIENT_HELLO:no ciphers available|https://website.domain.com/some/path?some=params%20to%20send||1|

 

Any ideas?

Outcomes