AnsweredAssumed Answered

Agent/EM comatibility, same release different service pack

Question asked by James.Sweeney on Dec 9, 2013
Latest reply on Dec 10, 2013 by puran02

I'm currently on 9.5 infrastructure (CEM, MOM, MTP/TIM) and have to install new agents.  I don't want to upgrade to 9.5 agents as it is a .0 release, and these are critical apps.  I'm deciding between 9.1.7 and 9.5.1 for the agents.  My question is, can a 9.5.1 agent talk to a 9.5.0 EM?  Looking at the documentation, "Agents can be either the same version as, or an earlier version than, the Enterprise Manager (EM)."  I'm not sure if this applies to my case, where the agent would be 9.5.1 and a EM of 9.5.0.  The agent would have a higher service pack/gen level.

Can the release be the same, but the agent have a higher servicepack/gen level than the EM?

Does this apply in this scenario?  The documentation page I am referring to is below regarding Component Version Compatibility.

Any insight would be appreciated.

Component Version Compatibility

These rules govern version compatibility among Introscope components.

Enterprise Manager

  • The Enterprise Manager and the Workstation must be the same version. The Command-line Workstation must also be the same version as the Enterprise Manager.

    When you upgrade an Enterprise Manager, you install a new Workstation of the same version. This includes upgrades to service pack or patch releases.

  • All Enterprise Managers in a cluster must be the same version. This includes the MOM, all Collector Enterprise Managers, and the WebView Server.

Cross-Cluster Data Viewer

The Cross-cluster Data Viewer must be the same version as the Collectors and clusters it connects to.

TIM

Some versions of Enterprise Manager support older versions of TIM. To determine whether you can use your existing TIM with an upgraded Enterprise Manager, consult the CA APM Compatibility Guide, available on CA Support.

To determine your TIM version:

  1. TIM must be running, so if necessary, restart TIM.
  2. In a browser, browse to http://<TIM_Home>/cgi-bin/wily/system/index where <TIM_Home> is the name or IP address of the computer running TIM.

    The TIM Home Page appears, displaying information about the TIM, including version number.

Agents

  • Agents, AutoProbe or ProbeBuilder, and the Platform Monitor must all be the same version. If you upgrade agents, you also upgrade AutoProbe or ProbeBuilder, and Platform Monitors.
  • Agents can be either the same version as, or an earlier version than, the Enterprise Manager (EM).

 

7.0 Enterprise Manager?

8.x Enterprise Manager?

9.x Enterprise Manager?

7.0 agent works with...

Yes

Yes

Yes

7.2 agent works with...

Yes

Yes

Yes

8.x agent works with...

No

Yes

Yes

9.x agent works with...

No

No

Yes

Note: With pre-9.1.x agents, basic location map functionality is available. For full location map functionality, use 9.1.x agents and Enterprise Managers version 9.1 or later.

If agents are pre-9.1.x, it is possible that the location map does not display information such as infrastructure alerts or host information. This situation can occur because the 9.1 agent sends correlation properties to Unified Service Model (USM) by way of the CA APM connector. These correlation properties enable computer systems that are created by different connectors (such as eHealth and CA APM) to be seen as one computer system. CA APM can then see alerts generated by other systems, such as eHealth. If this correlation does not occur, manually modify the policies of other connectors to include the primary DNS name or perform manual correlations.

Upgrading agents when you upgrade CA APM is recommended, but not required. In some environments, upgrading all agents at the same time as the Enterprise Manager and Workstation is impractical because it requires restarting each application server.

You can update agents in one of two ways:

  • Continue to run the previous version of the agent until you can schedule upgrade of all agents at the same time.
  • Upgrade your agents gradually.

Outcomes