AnsweredAssumed Answered

XOG is not working

Question asked by Adersh Ram on Feb 4, 2014
Latest reply on Feb 4, 2014 by Adersh Ram

Hi Team,

Need your suggestions.

Using Clarity PPM v13.1

I am trying to xog out a Incident object instance from Production envronment, when executing the below xml request using the XOG.CLIENT windows, it shows a error message " Invalid request read for object incident". Please look into below xml request

Input xml:

<?xml version="1.0" encoding="UTF-8"?>
<NikuDataBus xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:noNamespaceSchemaLocation="../xsd/nikuxog_read.xsd">
  <Header version="7.5" action="read" objectType="incident" externalSource="NIKU">
    <args name="documentLocation" value="/niku/xog/test/documentXogLocation/incident"/>
  </Header>
  <Query>
    <Filter name="incidentCode" criteria="EQUALS">S000045</Filter>
  </Query>
</NikuDataBus>

Output xml:

<?xml version="1.0" encoding="UTF-8"?>
<XOGOutput xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="../xsd/status.xsd">
  <Object type="unknown"/>
  <Status elapsedTime="0.016 seconds" state="FAILURE"/>
  <Statistics failureRecords="0" insertedRecords="0" totalNumberOfRecords="0" updatedRecords="0"/>
  <ErrorInformation>
    <Severity>FATAL</Severity>
    <Description>Exception while processing client request</Description>
    <Exception type="com.niku.xog.XOGException">com.niku.xog.XOGException: Invalid request read for object incident</Exception>
  </ErrorInformation>
</XOGOutput>

The same xml request work in UAT and DEV environement. sad

Any idea ?

Thank,

Ram

 

 

 

Outcomes