AnsweredAssumed Answered

Library issue

Question asked by ramakantjoshi on Jun 2, 2014
Latest reply on Jun 9, 2014 by ramakantjoshi

I'm trying to call a java function (the jar exists in my hotDeploy). This jar has a dependency on a function org.apache.commons.codec.binary.Hex.encodeHexString defined in commons-codec.jar (version 1.6 and up). I did add that library to my hotdeploy, but looks like LISA is still referring to the defauly codec library that comes bundled with LISA (which I assume is of a lower version). How do I get LISA to use the library in my hotdeploy (or lib folder) instead of the one that comes bundled with LISA? I'd assume there will be cases when I need to use a more recent version of such common libraries.

 

I keep getting this exception

Target exception: java.lang.NoSuchMethodError: org.apache.commons.codec.binary.Hex.encodeHexString([B)Ljava/lang/String;
 
LISA version is 6.0.9
 

Outcomes