AnsweredAssumed Answered

Custom Emailer 1.1

Question asked by jiteshud on Jun 3, 2014
Latest reply on Jun 17, 2014 by Hiko_Davis

Hi Experts,

We have installed APM 9.5 and used the CustomEmailer1.1 available on community itself.

When I try to execute the CustomEmailer.cmd from the shell command action in Introscope. I don't get any emails afterwards.

Following is the update I get in logs(Verbose Mode):

INFO   | jvm 1    | 2014/06/03 13:00:46 | 6/03/14 01:00:46.196 PM IST [INFO] [Alarm Pooled Worker] [Manager.Action] Action "Email Test" successfully executed shell command "E:\email\CustomEmailer.cmd"

I've attached the CMD file and email.properties file for your reference.

CMD File

set JRE_HOME="E:\Program Files\CA APM\Introscope9.5.2.0\jre"
set EM_HOME="E:\Program Files\CA APM\Introscope9.5.2.0"
%JRE_HOME%\bin\java -jar %EM_HOME%\CustomEmailer.jar %EM_HOME%\%1 %2 %3 %4 %5 %6 %7 %8 %9 %10 %11 %12 %13 %14 %15 %16

email.properties

custom.message=A problem on System {1} has detected {2:5} and {3} or {2}
custom.message.title=CA APM Alert{1}
alert.recipient=jitesh.udwani@gridinfocom.com
debug=false

# Host whose mail services will be used
# (Default value : localhost)
mail.host=192.168.1.246

# Return address to appear on emails
# (Default value : username@host)
mail.from=noreply@gicad.com

# Other possible items include:
# mail.user=
# mail.store.protocol=
# mail.transport.protocol=
# mail.smtp.host=
# mail.smtp.user=
# mail.debug=

We have also checked the SMTP server by sending a "Simple SMTP Mail Action". And It works fine through that.

Kindly suggest.

Thanks,

Jitesh

Outcomes