Sagi_Gabay

imcss skin isn't working as default

Discussion created by Sagi_Gabay Employee on Jul 26, 2014

If you would like to make one of the /imcss skins be your default skin then here is what you need to do:

 

1. Make sure to edit the /imcss/index.jsp and specify the skin you would like to use at top of the /imcss list of skins.

2. In IDM management console (/immanage) go to: Environments -> Your IME -> Advanced Settings -> Miscellaneous.  In there you need to make sure you have a variable called: "Default Console" and it needs to be set to "imcss".  Note that by default this variable is set to "ui7" which is why unless you change it you will not be able use your 'imcss' as your default skin. You need to make sure you have this variable defined and set to 'imcss'. Further, You must restart your IME (envrionment) for this to take effect using the Restart Environment button.

     a. Further: We noticed that when changing the Default Console variable it might still not take effect even if IME is restarted. This could be because once you save the new value for Default Console what happens is that the variable is saved with a leading space character which basically means it's a different variable name (so it's saved as: " Default Console" - notice the leading space , instead of "Default Console").  If your changes didn't take effect please look into that. To do that you should:

          1. Export your IME and look at your advanced settings xml file and search for Default Console.

          2. If you notice the leading space then edit the file, eliminate the leading space char, save the file and then import it back to the IME. To import it back you should go to Advanced Settings -> import and select your updated file. Make sure to Restart Environment after the import to have your change take effect.

 

Yours,

Sagi Gabay,

CA Technologies

Outcomes