AnsweredAssumed Answered

batch script calling perl, via action not working

Question asked by Russ_Russell on Sep 9, 2014
Latest reply on Nov 27, 2014 by Crys

I have a very frustrating issue that I (and others) am unable to figure out. Hoping I am just overlooking something simple, and that someone here can help.

 

We have a batch script that invoked a perl script as part of an action. This has worked great in our old 8.2 environment. After upgrading to 9.5, the action triggers, the batch script is called, but the line inside calling the perl script is never executed. (I see that the script is called via a echo/log I added to the end of the batch script which can be seen on the final line of the batch below).

 

If I run the batch script manually from a command prompt (and pass it the same information that is being passed via the introscope action), everything works as expected. This leads me to believe that is has something to do with pathing or access when the script is called via the introscope action, but I cannot figure out how/where this issue might be.

 

As you can see, the script is extremely simple (see below a screenshot of the action and the text from the batch script)

 

bemalert.jpg

 

@ECHO OFF

setlocal

CD d:\sysmgt

SET DiSCONN_ALERT=%1

start /B /WAIT d:\perl64\bin\perl.exe d:\sysmgt\ha_event.pl %DISCONN_ALERT%

echo %DISCONN_ALERT% >>d:\sysmgt\test.log

Outcomes