AnsweredAssumed Answered

Dynamic instrumentation not working

Question asked by gauravbali17 on Sep 30, 2014
Latest reply on Oct 1, 2014 by gauravbali17

Hi all,

 

I am using 9.5.5 agent on Unix boxes and enabled the dynamic instrumentation on agent side and have the given the access to the user as per the Document

IntroscopeAgent.profile:

introscope.autoprobe.dynamicinstrument.enabled=true (default: false)

introscope.agent.remoteagentdynamicinstrumentation.enabled=true (default: true)

 

User is added with the following permission Dynamic_ Instrumentation & Full

and receiving the following error when i use to see the call methods

"Failed to retrieve method Information"

 

and can see the logs in the debug mode :

IntroscopeAgent.DatabaseQueryDelegate] Initializing Connection manager

9/29/14 09:26:29 AM EDT [INFO] [IntroscopeAgent.Agent] Agent Connection Manager is initializing

9/29/14 09:26:29 AM EDT [ERROR] [IntroscopeAgent.DynamicInstrumentation] Unexpected error in Dynamic Instrumentation Invocation

9/29/14 09:26:36 AM EDT [INFO] [IntroscopeAgent.DatabaseQueryDelegate] Initializing Connection manager

9/29/14 09:26:36 AM EDT [INFO] [IntroscopeAgent.Agent] Agent Connection Manager is initializing

9/29/14 09:26:36 AM EDT [ERROR] [IntroscopeAgent.DynamicInstrumentation] Unexpected error in Dynamic Instrumentation Invocation

9/29/14 09:27:27 AM EDT [INFO] [IntroscopeAgent.DatabaseQueryDelegate] Initializing Connection manager

9/29/14 09:27:27 AM EDT [INFO] [IntroscopeAgent.Agent] Agent Connection Manager is initializing

9/29/14 09:27:27 AM EDT [ERROR] [IntroscopeAgent.DynamicInstrumentation] Unexpected error in Dynamic Instrumentation Invocation

 

 

Please let me know if some one also faced the same issue.

 

 

Thanks

GB

Outcomes