AnsweredAssumed Answered

XQLVisitorException XOG custom portlet

Question asked by FloGoya on Oct 20, 2014
Latest reply on Oct 22, 2014 by Dave

Hello Friends,

 

I'm trying to xog a custom portlet from prod environment to sandbox, but I'm getting the below error:

 

<?xml version="1.0" encoding="UTF-8"?>

<XOGOutput xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="../xsd/status.xsd">

  <Object type="contentPack"/>

  <Status elapsedTime="0.039 seconds" state="FAILURE"/>

  <Statistics failureRecords="1" insertedRecords="0" totalNumberOfRecords="1" updatedRecords="0"/>

  <Records>

    <Record>

      <KeyInformation>

        <column name="externalSource">NIKU</column>

        <column name="source"/>

        <column name="code"/>

      </KeyInformation>

      <ErrorInformation>

        <Severity>FATAL</Severity>

        <Description>XOG-3250: Portlet record has not been inserted. com.niku.xql2.XQLVisitorException&#xd;

  at com.niku.xql2.handlers.ThrowHandler.postProcess(ThrowHandler.java:25)&#xd;

  at com.niku.xql2.XQLVisitor.postProcess(XQLVisitor.java:1355)&#xd;

  at com.niku.union.xml.dom.DOMWalker.postProcess(DOMWalker.java:210)&#xd;

  at com.niku.union.xml.dom.DOMWalker.traverseIntern(DOMWalker.java:94)&#xd;

  at com.niku.union.xml.dom.DOMWalker.traverseIntern(DOMWalker.java:92)&#xd;

  at com.niku.union.xml.dom.DOMWalker.traverse(DOMWalker.java:51)&#xd;

  at com.niku.xql2.handlers.LoopHandler.processObject(LoopHandler.java:161)&#xd;

 

 

I tried xogging from two different environments and xogging out and in in the same environments and everytime I receive the same error.

I have also tried using the xog client http://clarity/niku/nu#action:xog.client and the error is the same.

 

I xog out just fine, the error is when writing.

 

Thanks for any advice!

 

Regards

Flo

Outcomes