AnsweredAssumed Answered

Lisa 7.5 Docker implementation addressing problems

Question asked by sdetweil2 on Jan 22, 2015
Latest reply on Jan 22, 2015 by robertwilliams

We are evaluating SV, using 7,5 (I know)..

 

we need to deploy VSE in a cloud environment, there are no ports open in our firewall for the VSE to talk to the Registry..

so Registry also has to be deployed in cloud..

 

I am building Docker containers to do this implementation..

 

Installed product on Ubuntu, zipped the install folder, and unzip into container on startup.. (yes there are better ways, this is a POC).

created a script to start up either a Registry or a VSE, and use Docker Linking to connect a VSE to a specific Registry.

 

Registry runs fine.

VSE starts up -m url_to_registry_on_source_container_using_ip_address

connects to registry, using its dynamically created hostname (hosts file only)

then it appear the registry attempts to connect back to the VSE using that hostname.. but the Registry system will never know that name,

and the connection fails..

 

is there a way to tell the VSE to use its IP address and not its hostname when registering?

 

Creating a virtual service environment:

... VSE Server name: tcp://bfeeea604f98:2013/VSE

..... Registry name: tcp://172.17.0.78:2010/Registry

.

.

[LISA AGENT:C][INFO][156][1][main][Jan 22, 2015 4:13:55 PM] Connection to tcp://172.17.0.78:2009?daemon=true established...

[LISA AGENT:C][INFO][156][54][ActiveMQ Session: ID:bfeeea604f98-36785-1421943233175-3:3:1][Jan 22, 2015 4:13:55 PM] Agent online: [ID: -2127754409][NAME: VSE:root@bfeeea604f98][IP: 172.17.0.81][MC: com.install4j.runtime.launcher.Launcher][PID: 156]

[LISA AGENT:C][INFO][156][54][ActiveMQ Session: ID:bfeeea604f98-36785-1421943233175-3:3:1][Jan 22, 2015 4:13:55 PM] Agent online: [ID: 297087253][NAME: Broker:root@3ed9d4652861][IP: 172.17.0.78][MC: com.install4j.runtime.launcher.Launcher][PID: 143]

[LISA AGENT:C][INFO][156][1][main][Jan 22, 2015 4:13:55 PM] Connection to tcp://172.17.0.78:2009?daemon=true established...

Cannot register with the LISA Registry [JMS Messaging problem with ServerRequestHandler for tcp://bfeeea604f98:2013/VSE Could not connect to broker URL: tcp://bfeeea604f98:2013?wireFormat.maxInactivityDuration=0. Reason: java.net.UnknownHostException: bfeeea604f98; nested exception is:

 

registry

 

[LISA AGENT:BC][INFO][143][83][ActiveMQ Session: ID:3ed9d4652861-39186-1421875225681-2:3:1][Jan 22, 2015 4:13:55 PM] Agent online: [ID: -2127754409][NAME: VSE:root@bfeeea604f98][IP: 172.17.0.81][MC: com.install4j.runtime.launcher.Launcher][PID: 156]

[LISA AGENT:BC][INFO][143][58][Timer-1][Jan 22, 2015 4:14:07 PM] Agent offline: [ID: -2127754409][NAME: VSE:root@bfeeea604f98][IP: 172.17.0.81][MC: com.install4j.runtime.launcher.Launcher][PID: 156]

Outcomes