Sagi_Gabay

IDM Supports JSF 1.2 (not 2.0)

Discussion created by Sagi_Gabay Employee on Feb 2, 2015

With Web Sphere 8.5 the default JSF version is 2.0. However, refer to Identity Manager's support matrix and see that it supports JSF 1.2 and does not support 2.0.

If left with 2.0 then errors will happen with attempt to invoke tasks from the User Interface.

 

To change your WAS 8.x JSF version to 1.2 you shall:

 

Rename  "\IBM\WebSphere\AppSrv01\plugins\com.ibm.ws.jsf.myfaces.jar" to  "\IBM\WebSphere\AppSrv01\plugins\com.ibm.ws.jsf.myfaces.jar.old

 

Then, Restart Web Sphere.

 

 

Yours,

 

Sagi Gabay,

CA Technologies.

Outcomes