DavidJF

Problem with Perl: "not a valid Win32 application"

Discussion created by DavidJF on Jul 1, 2014
Latest reply on Jul 1, 2014 by DavidJF

I'm running Strawberryperl 5.16.3 on Windows Server 2008 R2 SP1 x64

 

When i try to use the Nimbus API, I get a version error.

 

I hve the SDK_perl probe 5.06 installed.

 

Should this work? Has anyone successfully used StrawberryPerl?

 

E:\Nimsoft>ver

Microsoft Windows [Version 6.1.7601]

E:\Nimsoft>perl -e "print $^V"
v5.16.3
E:\Nimsoft>perl -I e:/nimsoft/perllib -I e:/nimsoft/perllib/MSwin32-x64-multi-thread -MNimbus::API -e"print '$^V'"
Can't load 'e:/nimsoft/perllib/MSwin32-x64-multi-thread/auto/Nimbus/API/API.dll' for module Nimbus::API: load_file:%1 is not a valid Win32 application at f:/source/Perl/perl/lib/DynaLoader.pm line 190.

 at -e line 0.
Compilation failed in require.
BEGIN failed--compilation aborted.

E:\Nimsoft>

Outcomes