1_Greenage

NAS Error

Discussion created by 1_Greenage on Nov 18, 2012
Latest reply on Nov 19, 2012 by ntimm

Hi Everyone,

 

I had a problem yesterday with the NAS in our Nimosft environment.  It error'd and wouldnt reactivate..

 

I tried restarting it, and then viewed the log, the log reported that the NAS was already running (so it aborted), so I logged onto the affected Hub and checked to see if it was running, and it wasnt..I made sure that "show processes for all users" was checked..

 

A strange thing was that no instance of the NAS was running at all, other probes were present, but no NAS.

 

I logged a case with Nimsoft and there's an extract of things I have tried further down this post....

 

I ended up redirecting all messages to another hub (HUB05) and re-enabled the NAS and the messages came through fine.

 

I've now just had a phone call from our 24/7 staff to tell me that the NAS on the HUB05 has error'd in the same way and that alerts are not coming through.

 

The only things I can think of now is to try and update the NAS to a later version (if one is available) but I'll have to be careful and to export all rules I've configured in the NAS just in case they get deleted/lost..

 

Does anyone know anything else I can try? Other than replacing the NAS probe?

 

I'm not sure if Nimsoft support is open over the weekend, but I really need to get this resolved for Monday :smileysad:

 

 Nimsoft initial response:

 It looks like the nas is already running. Can you log onto the box and bring up task manager and look to see if nas is running?

If it isn't, can you restart the robot, as this may help it.
Failing that I will need you to rename the transaction.db file in the nas directory and start it.

Thanks

Dave

 

Response from me:

Thanks David,

Ive check that, and there's no NAS.exe running in task manager, I've tried restarting the NAS and it keeps failing, or do I need to restart the robot on the Hub?

I've also renamed the transaction.db file and restarted the NAS but get the same error...

 

Nimsoft response:

Hi,

Can you rename database.db too, and restart the controller - the hub will restart too.

Thanks

Dave

 

Response from me:

Hi Dave,

It still says the NAS is already running...

Can we Webex?

 

Response from me:

Hi,

 

I've reattached the queues in another Hub and the alarms have started coming though. I do need to get to the bottom of the NAS error issue though..

Let me know when you can take a look at this.

Regards,
Sam

Outcomes