AnsweredAssumed Answered

glibc++.so.5 - Problem with NMS5.0 installation

Question asked by chris.luekermann on Oct 27, 2010
Latest reply on Oct 27, 2010 by chris.luekermann

Hi,

should you use a pretty new SuSE Enterprise Server 10/11 or a RedHat EL, it is still quite likely that you will receive a error message when installing NMS 5.0 complaining that glibc++.so.5 is not available.

 

If that is the case, before you try to download any packages to get that file from somewhere or try to update the system using the package managers (yast/yum) - please check on the filesystem first as you might actually have a higher version than 5 already.

Unhappily our installer doesn't check for that.

 

Simply check by executing "ls /usr/lib/glibc++*" - you might have a glibc++.so.6.

In such a case, simply create a link from the version 6 file to the version 5 file by executing "ln -s /usr/lib/glibc++.so.6 /usr/lib/glibc++.so.5" - then the installation will succeed.

 

-chris

Outcomes