AnsweredAssumed Answered

logmon probe: help with this situation

Question asked by Daniel Blanco Champion on Oct 8, 2014
Latest reply on Oct 14, 2014 by anders.synstad

Hello, I would appreciate it if someone can help, walk me thru setting up the logmon probe to do the following. I've watched all 3 reference videos (https://www.youtube.com/user/nimsoftTech/search?query=logmon) but am sitll confused as to where the variables defined come into play?

 

What I want to do: We have a program that writes to a log file after it does its thing and appends to a webpage the following content:

10/6/2014 2:06:38 PM,12
10/6/2014 2:08:50 PM,10
10/6/2014 2:11:03 PM,10
10/6/2014 2:13:13 PM,7
10/6/2014 2:15:33 PM,14

 

The program runs every few minutes and appends the results to the contents of this webpage. We need to keep these values in order to generate QoS reports for this task. 

 

Question 1: Can the logmon probe keep both the date & time in one QOS Variable and then the ## after the comma in another Variable? Or in terms of QoS history, it will only record the # I want it to grab once it starts running? Is there a way to enter all the previous values on this page as QoS entries for that specifc date and time? 

 

Continuing, I created a new Profile called MailCheck then specified the Mode: URL, then put the URL link in the URL and it can get to the page no problem. View works fine.

I set the check to every 1 min.

I checked off Generate QOS. I don't need to generate any alarms yet. I want to get this portion working first. 

 

The only values from the webpage we want to keep for QoS reporting is the ## after the coma.

 

So, I then went to Watcher Rules, New Watcher called GetTime.  In the Match Expression I put:  (\d+)$

Everything else I left blank and the Message Severity I set to clear. I don't want to alarm. 

 

At this point I'm not clear what to do next? I tried on the QoS Tab, I defined a new QoS Entry: Time, Units was Seconds,S Hit Ok. In the QoS Target field I put: MailCheck.GetTime.  I tried it setup this way and not QoS data gets created.

 

So I then added a new Variable called RspTime and set Source FROM position: Character Position: 1, then TO was To End of Line.  Nothing elese checked off. 

Back on the QoS Tab, I added the RspTime variable into the QoS Variables table, checked it off and gave this a shot but still nothing.  I am just lost at this point?

The log files say NO MATCH

Oct  8 10:28:41:099 [10476] logmon: [SynMail] NO MATCH [RecordTime] offset now -1

so not sure what I am doing wrong at this point.  

Any help with from someone who knows the flow I would really appreciate the help. 

Outcomes