careyb

Anyone got hands on with the sap_agentil probe?

Discussion created by careyb on Aug 5, 2014
Latest reply on Oct 26, 2015 by Clecimar

i'm giving the SAP_Agentil probe (v4.01) a try but it will not run on my machine at the moment. 

 

The probe log is useless at the moment because it just contains an error saying that the max probe restarts has been reached.

 

I've tried running the sapbasis_agentil_starter.exe manually from the command line as the documentation suggests and I get the error: 

 

java: symbol lookup error: /tmp/cg-ifd62o.so: undefined symbol: JVM_GetManagement 

 

I have a support call logged but its very slow going with them. I have 2 questions for the community......

 

1) Does anyone have any clues what that error means and how I get past it, if I had to guess I think it maybe related to Java version, does anyone know a confirmed version of Java RE that works with the probe.

 

2) One suggestion form support is to up the logging level of the probe to 5000. This would be fine except the GUI will not run if the probe isn't running so I can't set the logging level there. Also there are no parameters in a raw configure (at all) so there is nothing I can change there. Probably I have to add a line to the cfg manually but does anyone know what line I should add to up the loging level.?

 

Normally I would expect a probe to have a <probename>/cfg file. The SAP_Agentil probe just has a file called probe.cfg which just contains one empty section called probe. i.e. <PROBE></PROBE>

Normally I would expect a <setup> section with a log level line like below from the url_response probe. Can I just add a section? are setup sections standard in every probe with the same naming for the loglevel variable?

 

<setup>
loglevel = 0
logsize = 100
logfile = url_response.log
force_synchronous = no
min_threads = 10
max_threads = 100
alarm_on_each_sample = yes
sendAlarmOnEveryInterval = no
</setup>

 

Any help appreciated,

regards

   Carey

Outcomes