mpszczolka

logmon - two identical emails sent for every alert

Discussion created by mpszczolka on Dec 2, 2013
Latest reply on Dec 5, 2013 by bvloch

I have the following configuration of logmon:

 

   <SWIFT_ROUTER_PAYMENT_ERR>
      active = yes
      interval = 30 sec
      scanfile = d:\Spectrum\CS\FSSDWNLD\payment\paymtERR.log
      scanmode = updates
      alarm = yes
      qos = yes
      message = no
      subject = Swift_Router_Error_Payment
      monitor_exit_code = No
      max_alarm_sev = 5
      max_alarms =
      max_alarm_msg =
      password =
      user =
      <watchers>
         <error>
            active = yes
            match = Error|SQLServerException|Fail|ERROR
            level = major
            subsystemid =
            message = Error occurred in SwiftRouter paymtERR.log: $message_from_log
            i18n_token =
            restrict =
            expect = no
            abort = no
            sendclear = no
            count = no
            separator =
            suppid =
            source =
            target =
            qos =
            runcommandonmatch = no
            commandexecutable =
            commandarguments =
            pattern_threshold =
            expect_message =
            expect_level =
            <variables>
               <message_from_log>
                  definition = 1:
                  operator = eq
               </message_from_log>
            </variables>
         </error>
      </watchers>
   </SWIFT_ROUTER_PAYMENT_ERR>

Nimsoft server is configured to send email for me if pattern is found in the file. Emails are sent with 10 minutes interval.

And it works, but always I'm receiving 2 identical emails, for every probe I'm trying to configure.

 

Any idea what is wrong? May it be caused by Nimsoft server settings? I'm not Nimsoft admin in my company.

 

Thanks,

Marek

Outcomes