igate

Unable to start custom java probe

Discussion created by igate on Oct 10, 2013

I have created a custom java probe having a single class pushing a new QOS definition into NIS.

I have packaged this class file into a jar file.

When i deploy this probe on the hub, the log file shows error message: Timed probe <Probe Name> returned with error code 1/0.

However, the color symbol is dark green.

 

The following are the steps i followed while packaging.

1) Selected <MyProbeJarName>.jar , nimsoft.jar and .cfx file in Files tab.

2) Selected timed probe with 5 min interval.

a) Command : <startup java> 

b) Argument :  -cp nimsoft.jar;<MyProbeJarName>.jar <MyProbeClassName>

c) configuration file: .cfx file.

 

After successful deployment, i could see nimsoft.jar;<MyProbeJarName>.jar and .cfx files created within Nimsoft\probes\MyGroup folder.

When i run this jar file with same command like java -cp nimsoft.jar;<MyProbeJarName>.jar <MyProbeClassName>,

it runs successfully.

 

Alternatively i tried replacing jar file with class while packaging and replacing argument with only class name. But it still didnot work.

 

Also when i tried using the bat file(which has the command to run the class from jar) in the probe, the probe was able to push the QOS to NIS.

But with jar file and class it fails.

 

Any suggestion would be very much helpful.

 

Thanks.

Outcomes