AnsweredAssumed Answered

Hub tunnel through Citrix Netscaler

Question asked by mika.tuominen on Jul 2, 2012
Latest reply on Jul 5, 2012 by 1_keithk

Has anyone created a tunnel connection to hub through Citrix Netscaler?

I tried to do this with Netscaler version 10.0 without any success.
What I have done so far, have been two different approaches.

 

At beginning installed a hub with DMZ wizard, created the certificate and setup the tunnel server.
Then: 

First with SSL_BRIDGE
Created virtual server and service on Netscaler with SSL_BRIDGE, since the traffic between the master hub and client hub is SSL traffic. No luck to get the tunnel up. The log on the master hub gives:

Jul  2 17:35:37:517 [5200] hub: SSL_read error occurred (SSL_ERROR_SYSCALL)  Jul  2 17:35:37:517 [5200] hub: tsess_read - SSL_ERROR_SYSCALL err=0,bytes=-1  Jul  2 17:35:37:517 [5200] hub: CTRL receive message failed for get id command (connection closed)  Jul  2 17:35:37:517 [5200] hub: CTRL failed to get ID from ***.***.***.***/48003  Jul  2 17:35:37:517 [5200] hub: SSL_shutdown on TSESS-530696 failed  Jul  2 17:35:37:517 [5200] hub: Error shutting down SSL connection  Jul  2 17:35:37:517 [5200] hub: CTRL  is waiting for 0 TSESS to terminate  Jul  2 17:35:37:517 [5200] hub: CTRL  waited 0 seconds for 0 TSESS to terminate  Jul  2 17:35:37:517 [5200] hub: CTRL N/A is terminating with exit code 0 

 I can telnet to the port from the master hub, but the connection doesn't get established.

Then I tried it by configuring the tunnel to the Netscaler with plain TCP connection, but same results. Can telnet to the tunnel port 48003, but can not extablish a tunnel connection.

 

Does anyone have any ideas, or has done the tunnel through Citrix Netscaler?

Outcomes