AnsweredAssumed Answered

Data Engine restart issue

Question asked by bvloch1 on Aug 5, 2011
Latest reply on Aug 9, 2011 by bvloch1

I have an issue in which the only way that I can assure my data_engine will successfully connect and perform QoS inserts into the database is to restart the Nimbus services. A restart of the probe itself does not always work. When attempting to perform maintenance tasks that would cause the data_engine to perform what I will call a soft restart (change log level, delete some QoS definitions, etc) the probe will attempt to connect to that database -> timeout after 30 seconds -> attempt to connect -> repeat. 

 

I believe I am experiencing a timeout issue when the data_engine attempts load and/or query the s_qos_data table. Due to the shear number of QoS definitions I have in this table (~800000) it takes about 20 secs for this query to complete from SQL management studio. I have to believe that there is some key that I could place in the raw_config that would increase this timeout. Something similar to command_timeout (which I have tried in this case)  Restarting the service is the only way that I can get the data_engine to reconnect.  

 

I am running data_engine 7.56.  I believe that there has to be setting that would allow me to increase this timeout. Any one have any suggestions? I have checked the raw_config and do not have any values set to 30 seconds and command_timeout does not have an effect on this behavior. I have already trimmed rows in the s_qos_table.

 

Thanks in advance

Outcomes