Hi, it seems that 'name' variable definition for interface_traffic probe interface configuration section is being pulled from ifDescr (if available) or ifName snmp variables (can someone confirm if this is the case).
Given above, we are struggling to come up with standard for 'name' variable naming convention across different network equipment vendor operating systems (Cisco IOS, Cisco PIX OS, Juniper JUNOS, Juniper ScreenOS, etc). 'name' variable definition is becoming very important for us if we start exposing UMP performance reports designer to clients and 'name' variable is contained in QoS target.
Instead of having QoS target as device:ethernet0/0, we might want to change this to device:LAN-public to give client better understanding on what they are looking at. Is anyone else thinking about this or running into the same issues?
In our experience not all network equipment vendors give you capability to change ifDescr or ifName snmp variable values in device configurations. Some of them give capability to define ifAllias variable...
Going and changing interface configuration 'name' variable manually in interface_traffic probe seems to be a lot of manual labor intensive work. I was thinking maybe there is a way in interface_traffic probe to define what snmp variable to poll for 'name' variable definition?