mika.tuominen

E2E Pause Until to match on website

Discussion created by mika.tuominen on Mar 11, 2011
Latest reply on Feb 1, 2016 by Ismail.Baig

I just can't figure out how to do this.

 

I'm having problems getting synchronization for website to work, after startbrowser function.

I have this problem with few different websites.

 

I've tried to do the matching by OCR and Image synchronization, but those seem to fail every now and then. Even if I add any pause x secs commando before it tries to do the image/OCR matching.

Also have tried to match the page exactly, but that seems to sometimes continue before the whole page has been loaded.

I'm having this problem with Citrix Web Interface and also with couple different websites, which are little bit more complex.

Everything works just fine, when I test the script while I have a RDP session to the E2E machine. After I disconnect from the machine, and leave the script to run through e2e_appmon probe, those image/OCR recognitions start to fail. And when I reopen the RDP session everything works just fine.

 

Is there a way to do the pause until function so that it searches the website to match a predefined text string?

For this it should capture the text from the page and then do the pause until matching for the page.

 

Or give me your suggestion for the best and most stable way to check that the website is loaded properly and even do a pause until synchronization for the website, before the script continues.

Outcomes