AnsweredAssumed Answered

IE10/IE11 with Business Objects Infoview - Fix for 404 error

Question asked by am1 Champion on Apr 9, 2015
Latest reply on Oct 9, 2016 by sergy

ie10 or ie11 will not work properly with infoview in the version of business objects that comes with CABI.

This is because the URL it parses when trying to view properties or schedule is incorrect.

404_missingpage.png

 

How to fix

Step 1

Navigate to the "shared_caf_utils.js" in the tomcat folder

Example path:

Business Objects\CA\SC\CommonReporting3\Tomcat6\webapps\InfoViewApp\js\shared_caf_utils.js

Step 2

Make a back up of this file (i.e. copy and rename) and store somewhere safe

Step 3

Stop the tomcat service

Step 4

Edit shared_caf_utils.js in notepad, find:

if(window.navigator.userAgent.indexOf("MSIE") > -1) {


Step 5

replace this entire line with:

  var blnIE_LT_9 = false;
  try {
  /*@cc_on
      blnIE_LT_9 = (@_jscript_version < 9);
  @*/
  }
  catch(err) { }
    if(window.navigator.userAgent.indexOf("MSIE") > -1 && blnIE_LT_9) {


Step 6

Save

Step 7

Start the tomcat service

Step 8

Clear cache in your ie11 browser and log into infoview, you will now be able to access the properties or schedule a report.

 

 

Hope this is of use to the CA PPM community


Disclaimer: You install this code at your own risk. it is unsupported by CA and SAP, has no guarantee of working and therefore you take all responsibility in making this suggested change.

You MUST make a back up of the original file. This should be fully tested on a non production environment before deploying.


Outcomes