AnsweredAssumed Answered

Anyone have this issue with MSP and work hours shifting in the Time Scale View?

Question asked by vtleogal2 on Apr 21, 2015
Latest reply on Nov 15, 2017 by ifdscanada

I've been working with support now for two months, and we've made some progress but nothing that resolves this issue.  Has anyone seen this and had a hot fix in place?  Support has agreed that it seems to be related to CLRT-77371, but we cannot find a way to fix it.

13.3  (SQL)   patch 7 but occurs on patch 8 and 9

This happens randomly on some projects and some resources.   I am not 100% sure of the steps to make it happen, but I was able to recreate it in the CA Sandbox.


  1. On project A - add resource 1 at 0% default allocation. Dates (do not seem to matter but...) from current date to 7/1/15
  2. Add a task and assign this resource to the task.  (This can be done in Clarity or MSP.  ours come from templates and the one I used in the Sandbox was from a template).
  3. Track mode for project is Clarity as it for the resources
  4. open the project in MS Project 2010  ( we don't use 2013 yet)
  5. Set the view to show the task, resource and time scale view of  Work and Baseline hours  (usually the task usage view will give you this). It does not matter if the view is in Months  then weeks or Year then Months, but seeing it in Months is easier to track.
  6. Enter the following numbers in the Months
  • April - 10 hrs
  • May  20 hrs
  • June 10 hrs

7. Baseline this  in MSP so you know what you keyed in (but the issue is not related to baseline)

8.  Save back to Clarity

9.  Close the project

10. Reopen the project and  the hours are changed to

  • April 9.55 ( or any number depending on the day of the week)
  • May 20
  • Jun - 1 0

but now July has  .45 hours

The numbers are being reduced off one month (or week ) and moved to the next available month/week

 

Even though these are set to track mode = Clarity,these work hours DO transfer to the ETC in Clarity (the documentation states this only happens if it is non clarity).


The issue is related to when the last day of the month in the assignment falls on a working day. Then MSP flags the resource as saying the 'Resource is assigned to non-working time'  and does not allocate any hours on the last day of the month. The original bug stated the hours were changed to  0 in its entirety, but in this case the numbers are being reduced and only the last day of the month is being set to 0 work hours.  I can validate this by going to the resource usage view and setting the time scale to view the data daily.


In order to test this, you must also have the  MSP Options registry key "AllowedWorkContour" installed and set to 1; otherwise, all numbers are removed and shoved to the first week/month. This is an old CA issue and the install does not have this registry key to date.

***************************************

Things we have tried/eliminated


1. We use Fixed work tasks, but this happens on Fixed duration and units as well, regardless of effort driven or not

2. The MSP settings are set per CA recommendations and we (support and I) have played with several with no impact

3. Does not matter about the resource calendar (those these are standard US just like the Sandbox)

4. I have tried changing the project calendar to be from Standard to US in MSP, but this has no impact

5.  We have tried adjusting the max % load,   the units in MSP  (Default allocation) to say 100%, , tried changing the resource Work Contour (even though it is correctly set to Contoured and it actually forces itself back); have tried changing the loading pattern in Clarity from fixed to any other (this drives the work contour setting in MSP), but nothing has helped.

6. CA had me install the 13.2 MSP connector (on a test laptop) and the issues does NOT occur on 13.2, it is in 13.3. and you cannot run the 13.2 connector with 13.3. (not supported)

7.  The defect is misleading in that it says WORKAROUND is to load the 14.1 /14.2 driver but that too is not supported. We have tried to install the 14.2 connector and run it against the 13.3 but so far, it is causing a lot more issues (this is what I am in the progress of testing with CA).

8 . I have been successful in that if I enter the monthly ETC on the task in Clarity then it correctly  "sticks" when I open it in MSP. However, once you do any edits, it will eventually revert. Also, our groups often need to forecast out beyond the timeslice limit and doing the ETC on a task in Clarity (in time scale) is very inefficient.


I may have tried other things and just can't remember them, but that is what I recall over the last two months.

This is causing a huge impact as this feeds into the cost plans which are created using populate from assignment and revenue forecasting is incorrect.


Has anyone encountered this? CA said one other client reported it, but it was being done in a slightly different way.

I have attached a screen shot from the CA sandbox of what the results look like when the hours are shifted.


If no one has encountered this,  I will post the update if we ever find a resolution/ hot fix. We can't wait to upgrade to 14.2 (later this summer), due to the revenue impact.


Thanks

Lynn


Attachments

Outcomes