AnsweredAssumed Answered

DevTest8.0.2 - Change CAI / portal tcp port from default?

Question asked by MatthewWood62133886 on Apr 29, 2015
Latest reply on Apr 29, 2015 by MatthewWood62133886

Due to some current FW constraints i'm attempting to change the DevTest 8.0.2 CAI / portal default port.  This should be done by modified LISA property "devtest.port=" but it's not working.

 

i modified lisa.properties..

from:  devtest.port=1507

To :  devtest.port=1506     (note: i've also configured Ent Dashboard to run on a different port  eg. tcp8083)

 

But when restarting the PortalService it's not fully taking effect.  (i did also restart Registry).

Reviewing portal.log  i can see the new value is read in, but Listener still starts on tcp1507.

 

[root@localhost 8.0.2]# cat lisa.properties | grep devtest.port=

#devtest.port=1507

devtest.port=1506

 

[root@localhost 8.0.2]# cat /root/lisatmp_8.0.2/portal.log | grep 1506

2015-04-29 15:59:52,725Z (15:59) [main] INFO  com.itko.lisa.test.Environment - LISA prop 'devtest.port'='1506'

 

[root@localhost 8.0.2]# cat /root/lisatmp_8.0.2/portal.log | grep 1507

[resHubService] - Configuring RestAdapter with API Endpoint: http://localhost:1507/res-hub

2015-04-29 15:59:26,354Z (15:59) [main] INFO  grails.app.services.com.itko.lisa.test.TestResHubService - test reshub res-hub endpoint: http://localhost:1507/res-hub

2015-04-29 15:59:28,331Z (15:59) [main] INFO  grails.app.services.com.itko.lisa.vse.SaveVsService - res-hub endpoint: http://localhost:1507/res-hub

2015-04-29 15:59:54,954Z (15:59) [main] INFO  org.eclipse.jetty.server.ServerConnector - Started ServerConnector@6e2543f1{HTTP/1.1}{0.0.0.0:1507}

[root@localhost 8.0.2]#

 

tcp        0      0 0.0.0.0:8083                0.0.0.0:*                   LISTEN

tcp        0      0 0.0.0.0:2003                0.0.0.0:*                   LISTEN

tcp        0      0 0.0.0.0:22                  0.0.0.0:*                   LISTEN

tcp        0      0 127.0.0.1:25                0.0.0.0:*                   LISTEN

tcp        0      0 0.0.0.0:1530                0.0.0.0:*                   LISTEN

tcp        0      0 0.0.0.0:52674               0.0.0.0:*                   LISTEN

tcp        0      0 0.0.0.0:1507                0.0.0.0:*                   LISTEN

 

 

Additionally, after restarting Registry and Portal processes...

 

Browse and login to DevTest Console - http://192.168.99.9:1505/index.html
click on CAI Link - it refreshes then prompts with error - The DevTest Portal Service is unavailable. Would you like to be redirected anyway?

But if i click yes "redirect anyway"

i get redirected to:  http://192.168.99.9:1506/devtest/#/main/createartifacts

It's attempted to redirect to the define port "tcp1506", but of course i'm getting a webpage not available error - ERR_CONNECTION_REFUSED

 

If i manually change to tcp1507 -   eg. http://192.168.99.9:1507/devtest/#/main/createartifacts

it takes me to portal login page, but temporarily displays an alternate login page

 

 

Therefore what else needs to change to reconfigure the Portal tcp port.

 

 

regards

matt.

Outcomes