Nika_Hadzhikidi

Jaspersoft issue alert: Jaspersoft reports do not open when external SSL is used on 14.2.0 - resolved in 14.2.0.1, now available for OP

Discussion created by Nika_Hadzhikidi Employee on May 22, 2015
Latest reply on May 25, 2015 by navzjoshi00

Hello fellow communities members,

 


There is a known issue with Jaspersoft and SSL that is now been resolved in 14.2.0.1 which is now available on Support site for On Premise customers. Please ensure you install it if you believe you may hit the issue. The patch also includes few important bug fixes for 14.2, so I would recommend you to install it even if you don't have it.

 

Here are the details on the issue, please take a look:

 

CLRT-77687 : Jaspersoft request processor does not correctly handle requests when Clarity is configured for external SSL

Steps to Reproduce: 
1. Set SSL mode in the application server to "external"
2. Set HTTPS OFF for the application server
3. Specify an entryUrl that points to the external SSL-enabled server
4. Specify 8080 for the HTTP port (or any port number above 80 - the code explicitly skips port 80)
5. Log in to Clarity with a user that has all Advanced Reporting rights
5. Attempt to run any report

 

 

Expected Result: The report runs normally. All requests use the standard entryUrl value exactly as it is specified
Actual Result: The report times out or just fails. Browser request tracing will reveal that the HTTP port has been inserted into the Jaspersoft request URL along the way

 

Hope this helps!

 

Kind Regards

 

Nika Hadzhikidi
CA Technologies
Principal Support Engineer

Outcomes